Search found 239 matches

by Ciao121
Mon Mar 28, 2016 8:57 pm
Forum: [3.0.x] Support Forum
Topic: Attachment security issue..
Replies: 10
Views: 457

Re: Attachment security issue..

AmigoJack wrote:As per /docs/CHANGELOG.html this was fixed in 3.0.RC8 already, which means you're dealing with 3.0.0 or a similar old release.
Yes you are right! I'm dealing with a very old phpbb setup. Now I have found the right changelog entry!

Thank for your assistance!
by Ciao121
Mon Mar 28, 2016 9:19 am
Forum: [3.0.x] Support Forum
Topic: Attachment security issue..
Replies: 10
Views: 457

Re: Attachment security issue..

I'm writing in this old topic because I'm wrking on an old phpbb install and I encountered a similar problem. Logged in users (having acl_get('u_pm_download') set to true) can view attachment in private messages (also in those not sent to them) by using a random file ID. ie: http://www.mysite.com/do...
by Ciao121
Fri Nov 06, 2015 2:40 pm
Forum: [3.1.x] Styles Support & Discussion
Topic: Problem with curly brackets
Replies: 4
Views: 1636

Problem with curly brackets

On a template file I have to use:

Code: Select all

var xxxx = {};	
bute when I open the page, in the source code I can see:

Code: Select all

var xxxx = ;	
Curly brackets are stripped down.
I think this is because curly brackets are used for template variables.
Should I escape them in any way?

Thank you!
by Ciao121
Fri Apr 03, 2015 10:38 am
Forum: [3.1.x] Support Forum
Topic: Mass delete post from unregistered
Replies: 2
Views: 213

Re: Mass delete post from unregistered

Thank you for your reply. But the page you posted here is to help pruning posts from (auto) registered users. In my case posts are from unregistered users. Anyway I found out how to solve. I write it here for others. My Board is not in english so it is possible that page are not named exactly as I w...
by Ciao121
Fri Apr 03, 2015 10:30 am
Forum: [3.1.x] Support Forum
Topic: Mass delete post from unregistered
Replies: 2
Views: 213

Mass delete post from unregistered

Hi, I'm helping a friend that had an old forum. I upgraded his forum from 2.x to to 3.1.3. He had wrong permissions set, so guest users (spammers) posted a lot (thousand of messages). Now I have set the correct permission. I'm trying to figure out how to delete all posts from unregistered users from...
by Ciao121
Fri Feb 20, 2015 12:47 pm
Forum: [3.1.x] Support Forum
Topic: Help using create_search_index script
Replies: 4
Views: 143

Re: Help using create_search_index script

Finally got it working:
Changed

Code: Select all

$search = new $class_name($search_errors);
To

Code: Select all

$search = new $class_name($search_errors, $phpbb_root_path, $phpEx, $auth, $config, $db, $user);
in the script
by Ciao121
Fri Feb 20, 2015 12:16 pm
Forum: [3.1.x] Support Forum
Topic: Help using create_search_index script
Replies: 4
Views: 143

Re: Help using create_search_index script

I Found that "php create_search_index.php "phpbb\search\fulltext_native"" does something. But db tables are not populated. On video I see errors like: <b>[phpBB Debug] PHP Warning</b>: in file <b>[ROOT]/phpbb/search/fulltext_native.php</b> on line <b>100</b>: <b>Missing argument 2 for phpbb/search/f...
by Ciao121
Fri Feb 20, 2015 11:51 am
Forum: [3.1.x] Support Forum
Topic: Help using create_search_index script
Replies: 4
Views: 143

Re: Help using create_search_index script

Thanks for your reply.
The file name of what? arg1 it should be to specyfy index_type. But how. I tried fulltext, fulltext_native.. but no luck.
by Ciao121
Fri Feb 20, 2015 4:16 am
Forum: [3.1.x] Support Forum
Topic: Help using create_search_index script
Replies: 4
Views: 143

Help using create_search_index script

Hi,
I've found this script:
https://github.com/phpbb/phpbb/blob/dev ... _index.php
It seems to me a cli tool to rebuild the phpBB search index; but I don't understand what it expect as arguments.

Anynbody knows?
Thanks
by Ciao121
Mon Feb 02, 2015 4:31 pm
Forum: [3.1.x] Styles Support & Discussion
Topic: Subsilver2 in 3.1.3 changede files
Replies: 4
Views: 1178

Re: Subsilver2 in 3.1.3 changede files

I understand; but if the subsilver is not installed (and it is not installed by default) I think it should not be present in the phpBB update package. Or subsilver shuld be present by default in the main phpBB package.

Ivan
by Ciao121
Mon Feb 02, 2015 4:16 pm
Forum: [3.1.x] Styles Support & Discussion
Topic: Subsilver2 in 3.1.3 changede files
Replies: 4
Views: 1178

Subsilver2 in 3.1.3 changede files

I installed 3.1.2. In the package the only style is prosilver. Then I used the changed files to update form 3.1.2 to 3.1.3. In this package there is also a subsilver2 folder inside the styes folder. Only few files. But there is not subsilver2 style in the original install (3.1.2) and, after the upda...
by Ciao121
Mon Feb 02, 2015 4:02 pm
Forum: [3.1.x] Support Forum
Topic: Broke 3.1.2 board while updating to 3.1.3
Replies: 20
Views: 444

Re: Broke 3.1.2 board while updating to 3.1.3

Found the answer myself... I didn't execute the install/database_update.php.
Executing it solved the error.
by Ciao121
Mon Feb 02, 2015 3:56 pm
Forum: [3.1.x] Support Forum
Topic: Broke 3.1.2 board while updating to 3.1.3
Replies: 20
Views: 444

Re: Broke 3.1.2 board while updating to 3.1.3

Hi, I have the same error. I'm trying to understand what is wrong (not for a solution that is already here). I updated using changed files (I need to update this way). So I downloaded the changed files package and uploaded files in the right place. If this is the right way (isn't it?) why do I have ...
by Ciao121
Tue Jul 30, 2013 5:09 pm
Forum: [3.0.x] Support Forum
Topic: how to solve [sec] jussues whithout full uppgrade
Replies: 3
Views: 810

Re: how to solve [sec] jussues whithout full uppgrade

Yes it is "issues". Sorry for my english. The fact is my forum is heavily modified and customized. I' considering to update it to the latest version maintaining just posts, users etc. (also becaouse many self made customization are now included in the standard phpbb). But in the meantime I was looki...

Go to advanced search