Search found 5025 matches

by asinshesq
Thu May 07, 2015 7:09 pm
Forum: Extensions in Development
Topic: [CDB] Mark Post Unread
Replies: 56
Views: 9151

Re: [BETA] Mark Post Unread

Wow, thanks for doing this. At some point I will test it. For now, here are some thoughts on the options you included (and btw, I think it's great that you added options rather than providing notes the way I did on how to edit the mod to do these things): - The text in the option allowing admins to ...
by asinshesq
Mon Jan 26, 2015 10:57 pm
Forum: Extension Writers Discussion
Topic: any plans to allow mods in 3.1?
Replies: 10
Views: 413

any plans to allow mods in 3.1?

Now that people have been experimenting with extensions for a while, I was wondering whether there are any plans to allow mod authors to submit phpbb3.1 mods (as opposed to extensions) for validation (and to support automod for phpbb3.1). I admit that I have not yet spent a lot of time studying the ...
by asinshesq
Sun May 04, 2014 10:53 am
Forum: [3.0.x] MOD Writers Discussion
Topic: testing for existence of language files?
Replies: 5
Views: 362

Re: testing for existence of language files?

Here's the update: I didn't get an answer as to why the rules technically require me to fix that issue, but the comment does not apply to add_lang() since that function already gracefully falls back to en if the folder for the lang in question doesn't exist. My mod happened to include a language fil...
by asinshesq
Sat May 03, 2014 6:51 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: testing for existence of language files?
Replies: 5
Views: 362

Re: testing for existence of language files?

This happens even without debug and debug extra. After experimenting a bit, I see the issue is a bit narrower. For regular language entries used by my mod, my test board gracefully defaults to en in the absence of the appropriate language folder. The narrower problem occurs when the mod sends out em...
by asinshesq
Sat May 03, 2014 6:35 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: testing for existence of language files?
Replies: 5
Views: 362

Re: testing for existence of language files?

Thanks, tabitha (and how have you been?). You are definitely right that mods only have to work with prosilver style and en, but I guess the validator believes that if it fails with another language it should do so gracefully (without throwing errors). In that regard, I note that if I switch my own a...
by asinshesq
Sat May 03, 2014 5:58 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: testing for existence of language files?
Replies: 5
Views: 362

testing for existence of language files?

I got the following message in connection with denial of a new version of one of my mods: This MOD doesn't test if the language file exist: http://dl.dropbox.com/u/156020164/screen/2014-04-26-20h12-32.png Testing for the existence of a language file (presumably to cover the situation where the perso...
by asinshesq
Sun Mar 30, 2014 3:58 pm
Forum: Extension Writers Discussion
Topic: "Hello World!" - Extension & Skeleton Tool
Replies: 73
Views: 49594

Re: "Hello World!" - Extension

PayBas wrote:Too early. Either use licence (instead of license), or wait for beta 2.
Thanks. Where would I change this in the sample extension?
by asinshesq
Sun Mar 02, 2014 5:40 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: version numbers in includes/ucp/info/ucp_foo.php
Replies: 1
Views: 263

version numbers in includes/ucp/info/ucp_foo.php

When we add a ucp module we create a file in includes/ucp/info that looks something like this: <?php /** * * @package ucp * @version $Id: includes/ucp/info/ucp_foo * @license http://opensource.org/licenses/gpl-license.php GNU Public License * */ /** * @package module_install */ class ucp_foo_info { ...
by asinshesq
Sun Mar 02, 2014 12:35 am
Forum: [3.0.x] MOD Writers Discussion
Topic: modx problem with in-line replace plus before-add
Replies: 7
Views: 590

Re: modx problem with in-line replace plus before-add

Actually, I just looked at the changed file you pm'd me and you are seeing the same thing I am: automod added the comment before the line in question but did not make the the inline replace with change. I don't know if that's a automod bug or the wrong xml code that I was using.
by asinshesq
Sun Mar 02, 2014 12:08 am
Forum: [3.0.x] MOD Writers Discussion
Topic: modx problem with in-line replace plus before-add
Replies: 7
Views: 590

Re: modx problem with in-line replace plus before-add

Thanks for checking. Mine installs fine too (i.e. it says success), but then when I go into functions_posting.php I see that the in-line replace-with action was not actually done. Are you sure that your changes actually took effect?
by asinshesq
Sat Mar 01, 2014 11:07 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: modx problem with in-line replace plus before-add
Replies: 7
Views: 590

Re: modx problem with in-line replace plus before-add

I found a very unsatisfying kludge around the problem as follows: <open src="includes/functions_posting.php"> <edit> <find><![CDATA[/** * User Notification */ ]]></find> <action type="after-add"><![CDATA[// added $post_approval and mod_approved_poster_id parameters in next line to allow moderators t...
by asinshesq
Sat Mar 01, 2014 10:02 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: modx problem with in-line replace plus before-add
Replies: 7
Views: 590

modx problem with in-line replace plus before-add

I'm stuck on a modx change. I'm trying to replace some text in-line and add a comment before the line in question, and what I've done looks fine when I open the xml in a browser, passes the mpv and is allowed by automod, but when I actually install with automod the inline changes do not get done (th...
by asinshesq
Fri Jan 31, 2014 1:03 pm
Forum: [3.0.x] Support Forum
Topic: practicalities of using external smtp service
Replies: 4
Views: 334

Re: practicalities of using external smtp service

Thanks, both of you. And that's an interesting thing for me to check, brf. When you say bad address, you mean one that is incorrectly formed (as opposed to one that doesn't exist), correct? For example, one with a space or without an '@' in it?
by asinshesq
Thu Jan 30, 2014 8:36 pm
Forum: [3.0.x] Support Forum
Topic: practicalities of using external smtp service
Replies: 4
Views: 334

practicalities of using external smtp service

If I switch to a good external smtp service with limits that work for me and I then turn off the phpbb3 queue (email package size = 0), will a post hang unacceptably if the forum is mailing 70 email notifications at once (the usual number for most posts on my forum)? How about 500 users (an occassio...

Go to advanced search