Search found 24 matches

by berniewest
Fri Dec 21, 2012 7:24 am
Forum: [3.0.x] MOD Requests
Topic: Newbie - question about issuing moderator warnings.
Replies: 9
Views: 375

Re: Newbie - question about issuing moderator warnings.

In the ACP I created 3 new custom bbcode tags for my moderator warnings: [modwarning1], [modwarning2], and [modwarning3]. In posting.php: find: if (!$post_data) { if (!($mode == 'post' || $mode == 'bump' || $mode == 'reply')) { $user->setup('posting'); } trigger_error(($mode == 'post' || $mode == 'b...
by berniewest
Wed Dec 19, 2012 3:56 am
Forum: [3.0.x] MOD Requests
Topic: Newbie - question about issuing moderator warnings.
Replies: 9
Views: 375

Re: Newbie - question about issuing moderator warnings.

I've finally found where all the necessary code parsing is, and have done my own code modification. It works well and won't quote the moderator warning tags in any reply. Once I found where the code needed to go (and refreshed my memory on constructing regular expressions) it was a pretty easy fix. ...
by berniewest
Tue Dec 18, 2012 2:24 am
Forum: [3.0.x] MOD Requests
Topic: Newbie - question about issuing moderator warnings.
Replies: 9
Views: 375

Re: Newbie - question about issuing moderator warnings.

I've been searching around for a while and can't really find a mod or code fragment that I could use to implement this in the way I would like. I'd like to try modifying the code myself - such that when a user quotes a post, the system won't parse the custom moderator-warning tag (or anything in it)...
by berniewest
Mon Dec 17, 2012 11:11 am
Forum: [3.0.x] Support Forum
Topic: Can't find index_body.html in template folder
Replies: 1
Views: 185

Re: Can't find index_body.html in template folder

ok, I figured out it was inheriting from the prosilver theme template. Problem sorted!
by berniewest
Mon Dec 17, 2012 11:01 am
Forum: [3.0.x] Support Forum
Topic: Can't find index_body.html in template folder
Replies: 1
Views: 185

Can't find index_body.html in template folder

I've just downloaded the Prosilver Special Edition 1.0.9 theme and installed it on my board. It works fine, but I wanted to change a bit of the code. All other themes that i've used have a index_body.html file in the /template directory of the theme. But I can't find it in this one. Any ideas?
by berniewest
Fri Dec 14, 2012 5:54 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

Cheers for that.

I have gone ahead and created a generic moderator group and assigned it permissions in all forums except the one I don't want moderated.
by berniewest
Fri Dec 14, 2012 5:34 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

Thanks for telling me what I can't see, despite seeing it. See image below. You definitely can set moderator permissions in in the forum for the Global Moderators. However, setting them has no effect. They simply shouldn't be there.
by berniewest
Fri Dec 14, 2012 3:32 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

You misunderstand. I only want them unable to moderate the special sub forum where just the moderators and the admins discuss moderation and site issues. It's just a precautionary approach, in case a mod goes rogue and starts changing other people's comments or deleting them. I can always find out w...
by berniewest
Fri Dec 14, 2012 12:10 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

This whole thing just doesn't make any sense. Why does the ACP have settings that allow me to set forum permissions for Global Moderators, yet they don't work? :?: So, is the solution to not use the Global Moderator groups, but instead use a different moderator group, and then assign them moderator ...
by berniewest
Thu Dec 13, 2012 1:07 pm
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

The other mod has shown up and he has full mod privileges in there despite the fact that I have set all Global Moderator (the group he belongs to) privileges to "Never" for that forum. What am I doing wrong?
by berniewest
Thu Dec 13, 2012 3:34 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

Re: How to stop moderators moderating in a certain subforum?

Ok, I just found the dropdownlist at the top which allows me to select moderator permissions in that forum. I have set them all to 'No', but my separate moderator account can still perform all mod actions. I'm thinking that I have given my own moderator account some admin privileges somewhere that a...
by berniewest
Thu Dec 13, 2012 3:28 am
Forum: [3.0.x] Support Forum
Topic: How to stop moderators moderating in a certain subforum?
Replies: 13
Views: 2144

How to stop moderators moderating in a certain subforum?

Hi. I have created a hidden subforum on my phpbb board for moderators and admins to discuss things. I want to be able to stop moderators from having permissions to moderate in that forum. I've done what seems logical in the ACP by selecting Groups' Forum Permissions, but the permissions only cover s...
by berniewest
Tue Dec 11, 2012 7:10 am
Forum: [3.0.x] Support Forum
Topic: modifying the forum code
Replies: 7
Views: 292

Re: modifying the forum code

Cheers for that. I eventually got it working yesterday. I think it was failure to purge the cache that was stopping the changes from taking effect.
by berniewest
Mon Dec 10, 2012 4:04 pm
Forum: [3.0.x] Support Forum
Topic: URGENT HELP REQUIRED - Admin Panel no longer working
Replies: 3
Views: 148

Re: URGENT HELP REQUIRED - Admin Panel no longer working

I've fixed the admin panel problem. It's a long story... but the short version is there was some errant text inserted before the opening <php> tag. This query can be closed. I will open a separate one for the debug warning messages. Sorry for any confusion.
by berniewest
Mon Dec 10, 2012 3:56 pm
Forum: [3.0.x] Support Forum
Topic: URGENT HELP REQUIRED - Admin Panel no longer working
Replies: 3
Views: 148

URGENT HELP REQUIRED - Admin Panel no longer working

Support Request Template What version of phpBB are you using? I Don't Know What is your board's URL? http://www.rationalforums.org Who do you host your board with? hostgator How did you install your board? I used a tool provided by my host What is the most recent action performed on your board? Fre...

Go to advanced search