Search found 14 matches

by jtaubman
Sat Mar 03, 2018 2:37 pm
Forum: Extension Requests
Topic: A better search - Using Algolia?
Replies: 2
Views: 473

Re: A better search - Using Algolia?

The way the routine works it only updates the posted or updated records (so the impact is only about the same as someone viewing the Recently updated posts). I run the Cron every 15 mins (it could easily be every 5), the initial build obviously is a bit more of a hit, but not too bad. The advantages...
by jtaubman
Sat Mar 03, 2018 1:17 pm
Forum: Extension Requests
Topic: A better search - Using Algolia?
Replies: 2
Views: 473

A better search - Using Algolia?

I have been experimenting with the Algolia Search API on my http://www.fhug.org.uk site and it's working well for us. It uses a Cron job to keep the index up to date and you need an api key from Algolia for the index. It's currently built as a standalone from PHPBB, but obviously the cron job access...
by jtaubman
Thu Jun 22, 2017 6:52 pm
Forum: Custom BBCode Development and Requests
Topic: Using # in RELATIVE_URL
Replies: 0
Views: 700

Using # in RELATIVE_URL

I have the following BB custom code [kb]{RELATIVE_URL}|{TEXT2}[/kb] which converts using <a href="../wiki/doku.php?id={RELATIVE_URL}" class="postlink">Knowledge Base {TEXT2}</a> This works fine unless someone want's go to to a section on a page at which point it does not resolve. e.g This Works [kb]...
by jtaubman
Sat Oct 29, 2016 11:52 am
Forum: [3.1.x] Support Forum
Topic: V3.1.9 to 3.1.10 reports DB at 3.1.10-RC1
Replies: 3
Views: 263

V3.1.9 to 3.1.10 reports DB at 3.1.10-RC1

I have just upgraded from 3.1.9 to 3.1.10 and it's now saying Files Version 3.1.10 Database version 3.1.10-RC1 As I have never had the RC1 installed is this simply that the Database update is reporting the wrong level? I used the FTP method of updating and ran the Database upgrade. The Site seems to...
by jtaubman
Mon Aug 18, 2014 8:54 am
Forum: [3.0.x] Support Forum
Topic: Allow Users to move topics within Parent Forum
Replies: 1
Views: 162

Allow Users to move topics within Parent Forum

Support Request Template What version of phpBB are you using? phpBB 3.0.12 What is your board's URL? http://www.fhug.org.uk/forum/ Who do you host your board with? TSOHOST How did you install your board? I used the download package from phpBB.com What is the most recent action performed on your boa...
by jtaubman
Wed Sep 04, 2013 9:07 am
Forum: [3.0.x] Convertors
Topic: Generic message import
Replies: 46
Views: 68554

Re: Generic message import

Just in case anyone comes along and has been using the "WebApp Automated Perl Portal", I did a couple of scripts to convert forums to the XML format for this converter. cvtforum Change the $filelist array to include all the forum files you need to import. <?php $header = '<?xml version="1.0" encodin...
by jtaubman
Fri Aug 30, 2013 5:58 pm
Forum: [3.0.x] Convertors
Topic: Imported messages not resolving BB codes for normal users
Replies: 8
Views: 645

Re: Imported messages not resolving BB codes for normal use

Can you merge this thread in or do I need to start again?
by jtaubman
Fri Aug 30, 2013 5:55 pm
Forum: [3.0.x] Convertors
Topic: Imported messages not resolving BB codes for normal users
Replies: 8
Views: 645

Re: Imported messages not resolving BB codes for normal use

Thank's I have now tried that, but it did not fix it. I then edited the post and ticked the disable bbcodes and saved it and then ticked it and saved and that fixed the post, which suggests the field in the DB is wrong, but I have looked at some others and they all appear to have 1 in the BBCODE fie...
by jtaubman
Fri Aug 30, 2013 5:31 pm
Forum: [3.0.x] Convertors
Topic: Imported messages not resolving BB codes for normal users
Replies: 8
Views: 645

Re: Imported messages not resolving BB codes for normal use

Sorry it'a been a long day. The converter was Generic Message import https://www.phpbb.com/community/viewtopic.php?f=65&t=2115251 but I think the problem is permissions on the forums and as it'a all new to me I was just hoping someone might recognise the symptoms as I don't want to reimport as the t...
by jtaubman
Fri Aug 30, 2013 5:21 pm
Forum: [3.0.x] Convertors
Topic: Sending All Users a new password
Replies: 1
Views: 367

Re: Sending All Users a new password

just to answer my own post, I wrote a quick php script with worked with a comma separated list of users, emails and passwords and sent the message using Amazon SES.
by jtaubman
Fri Aug 30, 2013 5:18 pm
Forum: [3.0.x] Convertors
Topic: Imported messages not resolving BB codes for normal users
Replies: 8
Views: 645

Re: Imported messages not resolving BB codes for normal use

Sorry I think it might be a standard feature. It uses a acp include called acp_import_messages.php, which I imported each of the files of messages I converted to the XSD format manually.

To get to it I go to Posting tab and then Import Messages.
by jtaubman
Fri Aug 30, 2013 5:08 pm
Forum: [3.0.x] Convertors
Topic: Imported messages not resolving BB codes for normal users
Replies: 8
Views: 645

Imported messages not resolving BB codes for normal users

I have imported using the "import messages" plugin to my forums, but am missing something obvious in the permissions for example This post : http://www.fhug.org.uk/forum/viewtopic.php?f=40&t=5821 shows the BB img tags for two pictures, but if I edit the post (as admin) the pictures show and the disa...
by jtaubman
Thu Mar 21, 2013 11:56 am
Forum: [3.0.x] Convertors
Topic: Sending All Users a new password
Replies: 1
Views: 367

Sending All Users a new password

I am migrating from an old perl CMS, and have around 4,500 users. I have managed to import all the users along with the messages, but the password field in the old system is one way encrypted, so I can't set the passwords on the users in the new system from the old one. Is there a plugin or other to...
by jtaubman
Thu Aug 09, 2012 3:21 pm
Forum: [3.0.x] Convertors
Topic: Generic message import
Replies: 46
Views: 68554

Re: Generic message import

I have managed to create the XML file and it validates fine. How ever when I import if falls over with the message below. I have a couple of missing users (some of the message are 10 years old), which it reports during the preview stage and it fails when it tries to process the first message from on...

Go to advanced search

cron