Search found 32 matches

by energyuser
Mon Dec 29, 2014 11:27 pm
Forum: Extension Requests
Topic: phpBB-MediaWiki Bridge
Replies: 0
Views: 190

phpBB-MediaWiki Bridge

I've seen this as a MOD but now that phpBB 3.1 does not use MODs I'd like to ask for an extension about it. The extension should work like this: User creates an account at the phpBB forum. That account is stored in the database where the forum and the wiki are. So that the user can enter the same ac...
by energyuser
Mon Nov 03, 2014 6:35 pm
Forum: [3.1.x] Styles Support & Discussion
Topic: Avatar and online image
Replies: 14
Views: 1984

Re: Avatar and online image

There is a workaround: .post.online { background-image: none; position: relative; } .post.online:after { content: ''; display: block; position: absolute; right: 0; top: 0; width: 60px; height: 60px; pointer-events: none; background: url('./en/icon_user_online.gif') right top no-repeat; } This solut...
by energyuser
Sat Nov 01, 2014 10:02 am
Forum: [3.1.x] Styles Support & Discussion
Topic: Avatar and online image
Replies: 14
Views: 1984

Re: Avatar and online image

Alright, any chance of at least seeing this fixed some day?
by energyuser
Fri Oct 31, 2014 1:26 pm
Forum: [3.1.x] Styles Support & Discussion
Topic: Avatar and online image
Replies: 14
Views: 1984

Avatar and online image

When I upload an avatar of size for example 400x400 it hides/overlaps the "online" image. I want these images to act the other way around: the "online" image SHOULD overlap the avatar... I could've done this myself but I don't understand the new template system and that's why I need some help with t...
by energyuser
Thu Oct 30, 2014 11:37 am
Forum: [3.1.x] Support Forum
Topic: Wrong request sent?
Replies: 2
Views: 121

Re: Wrong request sent?

Oyabun1 wrote:Try uploading all the files again except for /config.php.
Whoops, it was a problem with my hosting company, they were updating the server, works now. Thanks anyway!
by energyuser
Wed Oct 29, 2014 5:33 pm
Forum: [3.1.x] Support Forum
Topic: Wrong request sent?
Replies: 2
Views: 121

Wrong request sent?

I just uploaded a fresh install of phpBB 3.1 on my server. I tried to configure my profile via the UCP -> Profile -> Edit Profile -> Whatever I edit there and click Submit I am redirected to an error page (even no error code sent at all?!). I am using Apache 2.4.10 and PHP 5.5.18 and latest version ...
by energyuser
Tue Jul 15, 2014 6:06 pm
Forum: phpBB Discussion
Topic: [Poll] Community Choice: Next Official Extension
Replies: 114
Views: 32938

Re: [Poll] Community Choice: Next Official Extension

I went with Auto Groups, but here's my list in order of preference if anybody cares. :D Auto Groups Paypal/Donation Pages Posting Templates I'm exactly the same! Auto Groups is a new feature; Paypal/Donation is nice; There is a tutorial about creating custom Pages in the KB already, they'll update ...
by energyuser
Wed May 21, 2014 2:15 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: Some questions about the template files...
Replies: 4
Views: 552

Re: Some questions about the template files...

The extension used by the templates is irrelevant. Back in phpBB2 they were .TPL files. They were only changed to .html for phpBB3 because they contain mostly HTML code. There is no difference at all to whatever extension you want to use. I know about the *.tpl files, been using phpBB2 back then......
by energyuser
Wed May 21, 2014 2:02 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: Some questions about the template files...
Replies: 4
Views: 552

Re: Some questions about the template files...

I know but somehow I want to have a *.xhtml extension for my template files, since they use the xHTML DOCTYPE ... Sorry, but that's what I'm used to. All my web project using the xHTML syntax have a *.xhtml extension and content-type application/xhtml+xml . However all my HTML projects have the *.ht...
by energyuser
Wed May 21, 2014 1:22 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: Some questions about the template files...
Replies: 4
Views: 552

Some questions about the template files...

So the phpBB 3.0.12 template uses the xHTML 1.0 Strict DOCTYPE . I'd like to either modify the DOCTYPE declaration to HTML5 or to change the file extension form *.html to *.xhtml ( Content-Type: application/xhtml+xml rather than text/css ). But both won't be easy, because: If I change the DOCTYPE , ...
by energyuser
Sun Apr 20, 2014 6:46 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: CSS background image does not show up?
Replies: 5
Views: 922

Re: CSS background image does not show up?

That's a MOD: Medals System
by energyuser
Sat Apr 19, 2014 7:47 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: How to add custom template variables?
Replies: 2
Views: 804

Re: How to add custom template variables?

So, the solution I've found is:

Code: Select all

'T_SCRIPTS_PATH'   => $phpbb_root_path . 'styles/' . rawurlencode($user->theme['template_path']) . '/scripts',
It outputs the following:
./styles/prosilver/scripts/main.js
Now, I only need to know does the script execute correctly.
by energyuser
Sat Apr 19, 2014 4:40 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: How to add custom template variables?
Replies: 2
Views: 804

How to add custom template variables?

When browsing index.php 's source code I noticed some inline script tags. I want to have my JS/CSS code separated from the HTML template and I thought I could add them via an external script tag. But instead of writing the whole path to my ./styles/prosilver/scripts/filename.js , I'd like to use som...
by energyuser
Fri Apr 18, 2014 7:10 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: CSS background image does not show up?
Replies: 5
Views: 922

Re: CSS background image does not show up?

Brf wrote:The prosilver style does not link the CSS files. The overall_header links to style.php which gives the compiled stylesheet, not the css files themselves.
OK but how do I modify the theme so that the vars value to be shown?
by energyuser
Fri Apr 18, 2014 6:59 pm
Forum: [3.0.x] Styles Support & Discussion
Topic: CSS background image does not show up?
Replies: 5
Views: 922

CSS background image does not show up?

I have the following CSS code: .approve-icon, .approve-icon a { background-image: url("{IMG_ICON_POST_APPROVE_SRC}"); } ul.approve-icons, li.approve-icon { width: {IMG_ICON_POST_APPROVE_WIDTH}px; height: {IMG_ICON_POST_APPROVE_HEIGHT}px; } /* Icon images ---------------------------------------- */ ....

Go to advanced search