Search found 26 matches

by jknacnud
Mon Feb 27, 2006 2:28 pm
Forum: [2.0.x] MODs in Development
Topic: [DEV] phpBB and MediaWiki shared login.
Replies: 11
Views: 3219

I am currently using this method: http://www.phpbb.com/kb/article.php?article_id=143 However, that does not log my users into MediaWiki it just secures the MediaWiki area so that they do not need another login. However, the site has come to the point that MediaWiki is requiring a login for certain t...
by jknacnud
Sun Jan 29, 2006 6:51 am
Forum: 2.0.x Support Forum
Topic: How I Instal phpbb with SSL?
Replies: 6
Views: 259

Yep, that will work too. The trick is where to put it. Perhaps in the index.php, or perhaps in the login.php page. I guess it really depends on when you want it to be enforced and what the most common entry point is for your site.
by jknacnud
Sat Jan 28, 2006 8:54 pm
Forum: 2.0.x Support Forum
Topic: How I Instal phpbb with SSL?
Replies: 6
Views: 259

That does not force SSL. It just sets the secure parameter in the setcookie PHP function. phpBB2, from what I have seen, is not natively setup to enable or disable SSL. It is able to keep the HTTPS protocol once set however. So if your forum is initially called with HTTPS it will keep it until someo...
by jknacnud
Wed Jan 25, 2006 4:14 pm
Forum: [2.0.x] MOD Database Releases
Topic: [20/01/07] Admin Userlist
Replies: 2286
Views: 501720

Glad to hear it. Thank you.
by jknacnud
Wed Jan 25, 2006 3:12 pm
Forum: [2.0.x] MOD Database Releases
Topic: [20/01/07] Admin Userlist
Replies: 2286
Views: 501720

Does this mod still work for current phpBB version?

I just found this mod and it looks like it does what I want it to do. I am just wondering if this mod still works for the current version (2.0.19). I ask this because I notice on the MOD page that it has not been updated since 08/09/04.

Thanks,
by jknacnud
Tue Apr 19, 2005 12:59 pm
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

Re: How and what to alter in the database for larger User ID

That's a direct link to what is (currently) the documentation on the structure and foreign keys for phpbb_users. You can check to see if you missed any. :-) They're not all called "user_id". For example, it's called poster_id in the phpbb_posts table. (I see that you have that one... in f...
by jknacnud
Tue Apr 19, 2005 12:51 pm
Forum: [2.0.x] MOD Writers Discussion
Topic: Integrating phpBB functionality into external website
Replies: 30
Views: 8837

I do not get it. That fix should not make any difference. It is very interesting that it works.
by jknacnud
Tue Apr 19, 2005 12:50 pm
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

epoch7 wrote: Im trying to put a login form on a different page than login.php but im having problems


I looked at the other forum and it looks like you found a fix. Good job.
by jknacnud
Tue Feb 01, 2005 5:49 am
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

How and what to alter in the database for larger User ID's

After pouring through a database dump several times, I came up with the following list of tables and their fields which seem to contain the user id for a user. ALTER TABLE phpbb_banlist MODIFY ban_userid int(11) NOT NULL default '0'; ALTER TABLE phpbb_forums MODIFY forum_last_post_id int(11) unsigne...
by jknacnud
Thu Jan 27, 2005 7:31 am
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

Red Leader, we found them, repeat, we found them!

Ok, I am not sure how to feel, so currently I am elated that I finally figured out my problem. I set user id's manually in my installation of phpBB. I do this so that the user id's in phpBB match the user id's of users on my site. No big deal right? Except that these user id's have 7 digits and may ...
by jknacnud
Tue Jan 25, 2005 5:16 am
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

Ok, I logged in as the Admin to check the cookie settings and change the cookie path to match the script path. Then I logged out and tried to log in with my custom form. It still did not work, but was is odd is that the user data still shows the Admin information. userdata: Array ( [0] => 2 [user_id...
by jknacnud
Tue Jan 25, 2005 4:49 am
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

I cleared all my sessions and waited a couple of days. Not much difference. Here is what happens, according to the relevant parts of the userdata array: userdata: Array ( [0] => 5 [user_id] => -1 [1] => 1 [user_active] => 1 [2] => JONATHAN [username] => JONATHAN [3] => 123asdf456asdf789asdf132asdf45...
by jknacnud
Tue Jan 25, 2005 12:09 am
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

Does anyone think it would be beneficial for me to cross-post this to another category/forum? If so, which one? General Support?
by jknacnud
Mon Jan 24, 2005 3:29 pm
Forum: [2.0.x] MOD Writers Discussion
Topic: Site Integration - Login not working
Replies: 11
Views: 1158

Perhaps I am taking the wrong approach to this. How about if I ask this a different way.

Is anyone else using a form, other than the one on the login.php page, that is outside of the phpBB install directory and even on a different server and it works?

Go to advanced search