Search found 26 matches

by mad_dog_bob
Thu Apr 15, 2004 2:05 pm
Forum: [2.0.x] MOD Database Releases
Topic: [Tools] phpBB 2.0.7 to 2.0.8 Code Changes
Replies: 30
Views: 22092

Hi, First, thanks for the mod, makes updating much easier for me :D Second, I've spotted a small problem with the HTML instructions for updating login.php A lot of the changes to this file say things like: $url = str_replace('&', '&', $url); Wondering why you'd want to replace a character with itsel...
by mad_dog_bob
Wed Aug 27, 2003 9:20 am
Forum: [2.0.x] MODs in Development
Topic: [RC] Post Display Order
Replies: 42
Views: 15782

Sorry to bother you again...got a couple of suggestions: In admin/admin_users.php and usercp_register.php instead of: 'L_SORT_ASCENDING' => $lang['Sort_Ascending'], 'L_SORT_DESCENDING' => $lang['Sort_Descending'], I've used 'L_SORT_ASCENDING' => $lang['Oldest_First'], 'L_SORT_DESCENDING' => $lang['N...
by mad_dog_bob
Sat Aug 23, 2003 4:29 pm
Forum: [2.0.x] MODs in Development
Topic: [RC] Post Display Order
Replies: 42
Views: 15782

Glad to be of help. My first post was just saying that the SQL was using the wrong variable name ($user_sort_order instead of $sort_order) but I think you've figured out what I was saying now :D I'm using it on my TacticalTrader site now, and it'll be interesting to see how many people choose newest...
by mad_dog_bob
Fri Aug 22, 2003 4:21 pm
Forum: [2.0.x] MODs in Development
Topic: [RC] Post Display Order
Replies: 42
Views: 15782

One more :D The user's settings aren't loaded when editing their profile... This needs adding: # #-----[ OPEN ]------------------------------------------ # includes/usercp_register.php # #-----[ FIND ]------------------------------------------ # $allowviewonline = $userdata['user_allow_viewonline'];...
by mad_dog_bob
Fri Aug 22, 2003 3:56 pm
Forum: [2.0.x] MODs in Development
Topic: [RC] Post Display Order
Replies: 42
Views: 15782

Here's another change for you: In viewtopic.php #-----[ FIND ]------------------------------------------ # $post_order = 'asc'; $post_time_order = 'ASC'; # #-----[ AFTER, ADD ]------------------------------------------ # $post_order = $user_post_order; $post_time_order = $user_post_time_order; Inste...
by mad_dog_bob
Fri Aug 22, 2003 3:12 pm
Forum: [2.0.x] MODs in Development
Topic: [RC] Post Display Order
Replies: 42
Views: 15782

Re: [BETA] Post Display Order

Hi, Thanks for posting this - I've been asked by some of my members to add this to my site so you've saved me some time. I've got a question - is this an error: # #-----[ OPEN ]------------------------------------------ # includes/usercp_register.php # #-----[ FIND ]---------------------------------...
by mad_dog_bob
Fri Aug 22, 2003 2:09 pm
Forum: 2.0.x Support Forum
Topic: Redirect wrong path?
Replies: 2
Views: 214

Check the 'server_name' in the phpbb_config table - this is used by the redirect() function to build the URL for a redirect, and is probably set to 'localhost'

This can also be set through the admin control panel, in General Admin - Configuration, look at the 'Domain Name' value.

hth,
rob
by mad_dog_bob
Fri Aug 22, 2003 1:40 pm
Forum: 2.0.x Support Forum
Topic: Error Sending EMail 2.0.4 to 2.0.6 and a solution to it...
Replies: 47
Views: 6132

I think one thing you're missing (and if you're not I apologise :oops: ) is that phpBB is still confined to work within the configuration of your server. The emailer script can use the PHP mail() function or SMTP and can work extremely well with both - however a lot of the problems posted are more t...
by mad_dog_bob
Fri Aug 15, 2003 9:36 am
Forum: 2.0.x Support Forum
Topic: Usergroups -> View Information broken
Replies: 4
Views: 203

Or look for my post here:

http://www.phpbb.com/phpBB/viewtopic.ph ... ht=groupcp

The SID really needs to be in a hidden field for those users where it appears on the URL.
by mad_dog_bob
Thu Aug 14, 2003 9:01 am
Forum: 2.0.x Support Forum
Topic: Emailer Issues
Replies: 4
Views: 226

Re: Emailer Issues

All the stuff that uses emailer (PMs, register, etc.) still get this message: Failed sending email :: PHP :: DEBUG MODE Line : 234 File : c:\phpdev\www\public\phpbb2\includes\emailer.php I get this on 2.0.6 for post notifications and mass email. I've tracked it down to the fact that they use the bc...
by mad_dog_bob
Thu Aug 07, 2003 4:02 pm
Forum: 2.0.x Support Forum
Topic: problem with usergroups
Replies: 15
Views: 559

The problem is with the 2.0.5/2.0.6 code rather than upgrade, the SID is in the wrong place. So I doubt your bad shutdowns caused it. I'm going to raise it as a bug, although I can't understand why more people haven't been affected. Anway, glad it worked for you 8) As an update - this has already be...
by mad_dog_bob
Fri Aug 01, 2003 2:25 pm
Forum: 2.0.x Support Forum
Topic: problem with usergroups
Replies: 15
Views: 559

Hi, I too have had this problem when upgrading my 2.0.3 forums to 2.0.5. I thought it was my fault but then I saw this thread :) Here is my fix: Open groupcp.php Go to around line 1267 - it should look like this: if ( $s_group_list_opt != '' ) { $template->assign_block_vars('switch_groups_remaining'...
by mad_dog_bob
Fri Jul 04, 2003 12:20 pm
Forum: 2.0.x Support Forum
Topic: Having problem with SQL injection fix for 2.0.5
Replies: 7
Views: 417

The announcement says to insert before or are my eyes deceiving me? 8O In CVS it uses 0 instead of false - and that works fine for me: // // Start initial var setup // $topic_id = $post_id = 0; if ( isset($HTTP_GET_VARS[POST_TOPIC_URL]) ) { $topic_id = intval($HTTP_GET_VARS[POST_TOPIC_URL]); } else ...
by mad_dog_bob
Thu Jul 03, 2003 9:21 am
Forum: 2.0.x Support Forum
Topic: Having problem with SQL injection fix for 2.0.5
Replies: 7
Views: 417

Probably me being an idiot - but why does it look like you've commented out the new code and left the old code in your viewtopic.php? Mine looks like this: // // This rather complex gaggle of code handles querying for topics but // also allows for direct linking to a post (and the calculation of whi...
by mad_dog_bob
Tue Jun 03, 2003 8:43 am
Forum: [2.0.x] MOD Requests
Topic: Local [url] and [img] bbcodes
Replies: 2
Views: 354

Local [url] and [img] bbcodes

I originally posted this in support but got no bites - hope you don't mind me trying here too. Is is possible to modify bbcode.php to allow to be used with local links, for example: [code]This is a [url=index.php]Local Link [/code] And [img] with local images: This is a [img]/images/logo.gif[/img] R...

Go to advanced search