Search found 32 matches

by guypat
Mon Nov 28, 2016 7:04 pm
Forum: [3.1.x] Support Forum
Topic: Contact Us Doesn't Work For Guests
Replies: 12
Views: 531

Re: Contact Us Doesn't Work For Guests

Nope, still doesn't work for guests. Works ok for registered users.
by guypat
Fri Nov 25, 2016 10:54 pm
Forum: [3.1.x] Support Forum
Topic: Contact Us Doesn't Work For Guests
Replies: 12
Views: 531

Re: Contact Us Doesn't Work For Guests

Upgraded to 3.1.10
by guypat
Fri Nov 25, 2016 9:01 pm
Forum: [3.1.x] Support Forum
Topic: Contact Us Doesn't Work For Guests
Replies: 12
Views: 531

Re: Contact Us Doesn't Work For Guests

HARRIS10 wrote:Dear Guypat

Where did you activate this feature

There is a "Can send emails" which I enabled.
Group permissions in the ACP, but it didn't resolve the issue. Guests are still unable to use the contact form. It works when a logged in user submits it.
by guypat
Fri Nov 25, 2016 12:42 pm
Forum: [3.1.x] Support Forum
Topic: Contact Us Doesn't Work For Guests
Replies: 12
Views: 531

Re: Contact Us Doesn't Work For Guests

There is a "Can send emails" which I enabled. Still won't allow guests to use "Contact Us". The page/form loads, and it says message/email was sent successfully, but the message never arrives in my inbox.

If a logged in user uses the form, message is delivered successfully.
by guypat
Fri Nov 25, 2016 11:54 am
Forum: [3.1.x] Support Forum
Topic: 700 Spam Accounts - Over 65,000 Posts - Please Help
Replies: 8
Views: 465

Re: 700 Spam Accounts - Over 65,000 Posts - Please Help

Ty for your help, guys. After several hours I managed to get it all cleaned up. Implemented a new Q&A captcha question (they broke the old one somehow), and installed the Stop Forum Spam plugin (which after testing doesn't appear to work). Forum is in good shape at the moment. Again, thank you for t...
by guypat
Thu Nov 24, 2016 10:22 pm
Forum: [3.1.x] Support Forum
Topic: Contact Us Doesn't Work For Guests
Replies: 12
Views: 531

Contact Us Doesn't Work For Guests

When a guest tries to use the "Contact Us" form at /forum/memberlist.php?mode=contactadmin -- the message aren't delivered.

When a logged in user uses the form, the message is delivered.

How can I get the Contact Us form to work for guests/non-logged in users?
by guypat
Thu Nov 24, 2016 6:36 pm
Forum: [3.1.x] Support Forum
Topic: 700 Spam Accounts - Over 65,000 Posts - Please Help
Replies: 8
Views: 465

Re: 700 Spam Accounts - Over 65,000 Posts - Please Help

Update - even trying to delete one of the spam accounts with 2300 posts results in a blank white page. Under 1,000 posts works fine.
by guypat
Thu Nov 24, 2016 6:01 pm
Forum: [3.1.x] Support Forum
Topic: 700 Spam Accounts - Over 65,000 Posts - Please Help
Replies: 8
Views: 465

Re: 700 Spam Accounts - Over 65,000 Posts - Please Help

Found some errors... What can I do to resolve this? [24-Nov-2016 13:00:04 America/New_York] PHP Fatal error: Cannot redeclare deregister_globals() in /var/www/domain.tld/forum/includes/startup.php on line 33 ==> lighttpd/server-error.log <== 2016-11-24 13:00:04: (mod_fastcgi.c.2569) unexpected end-o...
by guypat
Thu Nov 24, 2016 5:07 pm
Forum: [3.1.x] Support Forum
Topic: 700 Spam Accounts - Over 65,000 Posts - Please Help
Replies: 8
Views: 465

700 Spam Accounts - Over 65,000 Posts - Please Help

The prune user function keeps returning a white page. One spam account has 20,000 posts... I've increased time out, execution time, and memory limits in php.ini. Deleting accounts in batches of 20-30 at a time fails sometimes, and even then it could take several days. That still doesn't address the ...
by guypat
Sun Feb 07, 2016 8:19 pm
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

Unfortunately most of the posts I came across while researching answers were left without a conclusion. Some answers (not in this thread) were smug and arrogant, "go read the [outdated and/or vague] documentation" or "go read this [404] link", among others. One guy even criticized a block of code be...
by guypat
Sun Feb 07, 2016 1:45 pm
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

SUCCESS! Ok, wow. The topic was created! But phpBB generated an error, and I'm not sure how to fix it. Hopefully this is an easy one? Illegal use of $_SERVER. You must use the request class or request_var() to access input data. Found in /var/www/domain.tld/includes/functions.php on line 3922. This...
by guypat
Sun Feb 07, 2016 1:32 pm
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

The PHP documentation on include states: When a file is included, the code it contains inherits the variable scope of the line on which the include occurs. Any variables available at that line in the calling file will be available within the called file, from that point forward. So I tried moving in...
by guypat
Sun Feb 07, 2016 1:14 pm
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

Still working on a solution, I found some threads indicating an altered functions_posting.php might cause the issue I'm seeing. I downloaded a fresh copy of 3.1.7-pl1 and the file from the archive is the same as the file on my forum... No modifications. $ export FILE1SHA=/tmp/phpBB3/includes/functio...
by guypat
Sun Feb 07, 2016 2:20 am
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

So I'm at a loss... Anyone know how to get the $user->data from:
/var/www/domain.tld/content/styles/functions.php

To:
/var/www/domain.tld/forum/includes/functions_posting.php ?

What in my code is changing it to NULL? I don't understand.
by guypat
Sat Feb 06, 2016 9:46 pm
Forum: Extension Writers Discussion
Topic: submit_post Column 'topic_first_poster_colour' cannot be null 1048
Replies: 16
Views: 910

Re: submit_post Column 'topic_first_poster_colour' cannot be null 1048

perfect. All it says is: "NULL"
1 line, no HTML code in the source, just the word NULL. Why?

Go to advanced search