Search found 67 matches

by Schnorrer42
Wed Sep 08, 2010 5:23 pm
Forum: [3.0.x] Support Forum
Topic: Disable Report Post Button
Replies: 8
Views: 1989

Re: Disable Report Post Button

Thank you -- I understand. (I dunno, it feels like reporting posts ought to be a user/group permission not a forum role permission (whatever that is), but the whole permissions thing seems confusing to me.) While cleaning up the reported posts queue, I found that the forum sent emails to each report...
by Schnorrer42
Wed Sep 08, 2010 7:38 am
Forum: [3.0.x] Support Forum
Topic: Disable Report Post Button
Replies: 8
Views: 1989

Re: Disable Report Post Button

I have guest users (probably bots of some kind, but not identified as such by phpBB) that are reporting posts. I want to block guests from reporting posts. If I get the instructions above correct, I have to go I to each forum and set the role? How do I know which role or whatever to turn off reporti...
by Schnorrer42
Fri Apr 23, 2010 9:14 pm
Forum: [3.0.x] Support Forum
Topic: Custom Profile Field not showing on VT
Replies: 2
Views: 161

Re: Custom Profile Field not showing on VT

THANK YOU, THANK YOU, THANK YOU, THANK YOU, THANK YOU!

:D :D :D




(OK, now how do I mark this as resolved? LOL)
by Schnorrer42
Fri Apr 23, 2010 8:19 pm
Forum: [3.0.x] Support Forum
Topic: Custom Profile Field not showing on VT
Replies: 2
Views: 161

Custom Profile Field not showing on VT

Hi, I'm running 3.07-pl1 and I just added a custom profile field, and made it visible on the user control panel and on profiles and on vt. It is a single text, alphanumeric with spacers. I named it "firstname". I am using subsilver2, but the behavior is the same on prosilver. The field shows up on t...
by Schnorrer42
Wed Apr 21, 2010 5:34 pm
Forum: [3.0.x] Support Forum
Topic: Smilies problem after update to v3.07
Replies: 16
Views: 1506

Re: Smilies problem after update to v3.07

I also had this bug and removed MIN() and it solved my problems. Well, at least one of my problems. My wife has a long list.
by Schnorrer42
Thu Apr 08, 2010 7:41 pm
Forum: [3.0.x] Support Forum
Topic: Anyway to stop a single bot from showing?
Replies: 5
Views: 207

Re: Anyway to stop a single bot from showing?

Good thought! I would have noticed that, but I double checked anyway. Nope the bot appears as usual. I also logged out to check if the bot shows up to guests and yes, it does. Thanks for the idea, but I'm still stuck. You'd think that changing the user preference would override, no? I think I'll ope...
by Schnorrer42
Thu Apr 08, 2010 7:02 pm
Forum: [3.0.x] Support Forum
Topic: Anyway to stop a single bot from showing?
Replies: 5
Views: 207

Anyway to stop a single bot from showing?

Hi, Not a big issue, but just something that nags at me a little bit. I have a single bot that sits on my site all day long. I'd like to prevent that single bot from showing up in the Who's Online section. Any way to do that? I tried administrating the user account for the bot and clicked on the opt...
by Schnorrer42
Thu Feb 25, 2010 3:35 am
Forum: [3.0.x] MOD Writers Discussion
Topic: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x
Replies: 17
Views: 1527

Re: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x

OK, I just couldn't put it down without looking at the forums table in the second half. it is also unnecessary, so the query is down to this, at least: SELECT forum_id, "FROM_AG", "FROM_AG", "FROM_AG" FROM karmamod_groups g, karmamod_acl_options ao, karmamod_acl_groups ag WHERE ao.auth_option = 'f_r...
by Schnorrer42
Thu Feb 25, 2010 2:49 am
Forum: [3.0.x] MOD Writers Discussion
Topic: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x
Replies: 17
Views: 1527

Re: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x

You latest sql-snippet will cause an error :) because you set just forum_id and forum_name without table "pointers". OK, I'm not sure I follow that -- do you mean a syntax error or a logical error? I've just copied the code from this thread, substituted my prefix for karmamod then I re-reran it aga...
by Schnorrer42
Wed Feb 24, 2010 11:50 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x
Replies: 17
Views: 1527

Re: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x

Yes, and simplifying further... the first half doesn't need the forum table, either (and we can specify UNION ALL to reduce overhead since they apear to be exclusive?) SELECT forum_id, "FROM_AG", "FROM_AG", "FROM_AG" FROM karmamod_groups g, karmamod_acl_options ao, karmamod_acl_groups ag WHERE ao.au...
by Schnorrer42
Wed Feb 24, 2010 10:21 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x
Replies: 17
Views: 1527

Re: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x

Going on the assumption was that the ARD wasn't qualified, I decided to try a union splitting the two halves of the OR clause, and it seems to be giving the correct results. SELECT f.forum_id, forum_name, "NO ARD","NO ARD" FROM karmamod_forums f, karmamod_groups g, karmamod_acl_options ao, karmamod_...
by Schnorrer42
Wed Feb 24, 2010 10:12 pm
Forum: [3.0.x] MOD Writers Discussion
Topic: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x
Replies: 17
Views: 1527

Re: Duplicating phpbb2.0.x forums.auth_view in phpbb3.0.x

Why wouldn't there be an entry in acl_auth_groups with auth_option_id=20 ("f_read") for my GUESTS group ("2759") for each forum where they have read privs? There are only 12 in the table out of the 24 that are allowed to unregistered guests.

(PS Did you catch my edit in my post above?)

Go to advanced search