Search found 70 matches

by jasolo
Fri Feb 21, 2020 5:09 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

The actual code shows the users in the order they voted. User_id is just the seniority of the user in the forum, I'm not sure that's more useful than who voted first. Surely you mean to order by 'username', joining the table 'users' to the query, but that could be an option. Chronological order make...
by jasolo
Thu Feb 20, 2020 9:59 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Thanks to kasimi for the fix! :D Better than my idea of cloning. :? The fixed version for phpBB 3.2.9 and 3.3 is here: https://github.com/jasoloz/advancedpoll ... .2.4.1.zip
by jasolo
Sat Feb 15, 2020 12:15 am
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I have found the culprit. When the result are visible, the extension uses the official function vote_poll() in styles/prosilver/template/ajax.js and then another function from the extension. But around phpBB 3.2.5 the second line of vote_poll() was changed from: var poll = $('.topic_poll'); to: var ...
by jasolo
Mon Feb 10, 2020 8:06 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

At last! Activating the "notations" (show poll voters option) I see the problem. In my case is visual, that is, after reloading the page the correct number of votes and voters appears. And the votes are well recorded in the database. I'll have to find out why he does that.
by jasolo
Mon Feb 10, 2020 6:42 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I can't reproduce your case. :? I get the same Jsons and the number of votes I see is correct. By the way, are you still not seeing the fields I mentioned in the other post?
by jasolo
Fri Feb 07, 2020 11:50 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I'm doing the vote, je JSon back was : {"NO_VOTES":"No votes","success":true,"user_votes":{"1":0,"2":1,"3":2,"4":3,"5":4,"6":5,"7":6,"8":7},"vote_counts":{"1":4,"2":5,"3":4,"4":5,"5":7,"6":6,"7":5,"8":6,"9":0,"10":0},"total_votes":42,"can_vote":true} But, the counting wasn't change, it's still 41 v...
by jasolo
Fri Feb 07, 2020 10:24 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Aurelienazerty wrote:
Fri Feb 07, 2020 9:46 pm
Great, now, nothing works :

Screenshot_2020-02-07 Team-Azerty - Post a new topic.png
I get your first image when the extension is disabled. :shock: I am testing it on a local server with phpBB 3.3.0 and PHP 7.3.14. When enabled I see this with your settings:
advancedpolls1.png
by jasolo
Fri Feb 07, 2020 5:31 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I don't see the fieds 'Nombre maximum de votes' and 'Nombre total de votes' below 'Option(s) par utilizateur'. :!: Look at my panel (attached image). I haven't got this fields. Although the notification bug should not be the cause of your problem, I suggest you reinstall the extension with the last...
by jasolo
Fri Feb 07, 2020 5:21 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I have this error in 3.2.9 inside the UCP on edit notification options, and I have deleted the cache too: Sorry, I forgot to check that old bug before enabling the notifications. 😓 I have fixed the problem and changed the files in the 1.2.4 version . Download it, overwrite all the files and clear t...
by jasolo
Sun Feb 02, 2020 4:56 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

I don't see the fieds 'Nombre maximum de votes' and 'Nombre total de votes' below 'Option(s) par utilizateur'. :!: Look at my panel (attached image).
by jasolo
Sun Feb 02, 2020 3:16 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Can you post here the content of the "Poll creation" tab?
by jasolo
Sat Feb 01, 2020 5:13 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Maybe the problem is that the message "Your vote has been cast" appears below the "Submit vote" button during 5 seconds and then fades out, but that is the same behaviour with the default polls in phpBB. In Advanced Polls the code is located in line 95 of the file ext/wolfsblvt/advancedpolls/styles/...
by jasolo
Wed Jan 29, 2020 7:08 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

The pre-release of the version 1.2.4 can be downloaded from: https://github.com/jasoloz/advancedpolls/releases/download/1.2.4/advancedpolls.1.2.4.zip Install process: copy the contents of the ZIP file to the ext folder of your phpBB forum. Then enable the extension 'Advanced Polls' in Manage extensi...
by jasolo
Tue Jan 28, 2020 5:47 pm
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Although it is a fairly reliable extension, I have not made major changes with respect to the work of the previous programmer, so I am not sure of making the transition from beta to RC. Also this extension is my first contact with phpBB coding and surely some requirements are necessary to attain RC ...
by jasolo
Mon Jan 27, 2020 9:30 am
Forum: Extensions in Development
Topic: [3.2][3.3][BETA] Advanced Polls
Replies: 138
Views: 18263

Re: [3.2][BETA] Advanced Polls

Yes, I am aware that the extension is incompatible with version 3.3 because of the error indicated in services.yml: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar. The fix consists on adding quotes to the elements with @, as for example, replacing - @user with -...

Go to advanced search