Search found 22 matches

by omeroon
Wed May 29, 2019 5:13 pm
Forum: [3.2.x] Support Forum
Topic: PM in history - functionality mismatch?
Replies: 1
Views: 122

PM in history - functionality mismatch?

One of our editors brought up this issue and I am not sure if this is a bug or we just don't understand the logic. ;-) When you enter the user panel and go to the PM inbox ( /ucp.php?i=pm ) and you open a reply on a PM conversation (so I send a PM to user A, user A replied, I replied, he replied and...
by omeroon
Mon May 13, 2019 2:20 pm
Forum: [3.2.x] Support Forum
Topic: cant access acp The submitted form was invalid. Try submitting again.
Replies: 13
Views: 731

Re: cant access acp The submitted form was invalid. Try submitting again.

Nice, awesome work! Also for the bugreport, super!!! I fixed it using an extension. We are running a bit of a complex forum setup, containing 1 installation for multiple forums. To be able to update quickly I keep all core forum files "as is" and do all my modifications in a couple of custom extensi...
by omeroon
Mon May 13, 2019 12:45 pm
Forum: [3.2.x] Support Forum
Topic: cant access acp The submitted form was invalid. Try submitting again.
Replies: 13
Views: 731

Re: cant access acp The submitted form was invalid. Try submitting again.

You understand correctly, that is indeed exactly the problem.

Other templatesets may face the same issue. A quick fix is to remove any popup and just link to the login page.

Or hope the phpBB core team will add it in every page in 3.2.8. :mrgreen:
by omeroon
Mon May 13, 2019 11:33 am
Forum: [3.2.x] Support Forum
Topic: cant access acp The submitted form was invalid. Try submitting again.
Replies: 13
Views: 731

Re: cant access acp The submitted form was invalid. Try submitting again.

Exactly. The add_form_key() function call was only added to pages where phpBB already had login functionality, like on the index page at the bottom or on the login page itself. Other pages (like viewforum.php) don't generate a form token and therefore will render an empty {S_FORM_TOKEN_LOGIN} . Metr...
by omeroon
Mon May 13, 2019 11:24 am
Forum: [3.2.x] Styles Support & Discussion
Topic: Styles for 3.2.7
Replies: 5
Views: 1173

Re: Styles for 3.2.7

I am having the same problem with my Metro template set. I think the main problem is that the login form key is only generated in the index and the login page. You can add the token marker on other pages but it will render empty without having the add_form_token() in the page itself, just like it ha...
by omeroon
Mon May 13, 2019 11:10 am
Forum: [3.2.x] Support Forum
Topic: Error updating from 3.2.5 to 3.2.7, please help!
Replies: 7
Views: 353

Re: Error updating from 3.2.5 to 3.2.7, please help!

OK, I disabled all extensions and the board seems to be working properly. But I use those extensions. This is most unfortunate. :| Enable them one by one while clearing the cache in between and check if all still works. Do not log out of the backend but open the forum in a separate window (so you c...
by omeroon
Fri May 10, 2019 3:29 pm
Forum: [3.2.x] Support Forum
Topic: cant access acp The submitted form was invalid. Try submitting again.
Replies: 13
Views: 731

Re: cant access acp The submitted form was invalid. Try submitting again.

Yes and no; the form token may be what's missing, but not because the template wasn't updated. You are correct that this was directly the issue in phpBB 3.2.6. But phpBB 3.2.7 "forgives" a template which hasn't been updated yet, and inserts the form token anyway. Unfortunately this doesn't work if ...
by omeroon
Fri May 10, 2019 3:14 pm
Forum: [3.2.x] Support Forum
Topic: Not able to log in anymore after update to 3.2.6
Replies: 47
Views: 3731

Re: Not able to log in anymore after update to 3.2.6

I have updated to 3.2.6 RC.1 , but we have no style changes from 3.2.6 RC.1 to 3.2.6. So looks like where missing some changes then. EDIT I'm using the "quick login" extension. I needed to add add_form_key('login', '_LOGIN'); in listner.php And {{ S_FORM_TOKEN_LOGIN }} in quick_login.html So it's w...
by omeroon
Fri May 10, 2019 1:35 pm
Forum: [3.2.x] Support Forum
Topic: cant access acp The submitted form was invalid. Try submitting again.
Replies: 13
Views: 731

Re: cant access acp The submitted form was invalid. Try submitting again.

You are probably missing the form token in your (extension) templates.

Check: viewtopic.php?f=556&t=2509981
by omeroon
Thu Sep 20, 2018 4:43 pm
Forum: [3.2.x] Support Forum
Topic: Moderatorpanel link not showing everywhere?
Replies: 3
Views: 140

Re: Moderatorpanel link not showing everywhere?

Thanks for the quick reply. I understand what you are saying and understand the logic, however our moderators DO want to access the moderatorpanel from every page. :D We have a fairly successful board with a lot of users (200K+) sending messages to moderators or posting new topics that are placed in...
by omeroon
Thu Sep 20, 2018 4:31 pm
Forum: [3.2.x] Support Forum
Topic: Moderatorpanel link not showing everywhere?
Replies: 3
Views: 140

Moderatorpanel link not showing everywhere?

When I am logged in to our forum (phpBB3.2) it shows moderatorpanel link at the top of most pages except for the UCP, memberlist, help and search pages. Anyone else experiencing this? Is this maybe meant to work this way (as there is nothing to moderate on the help or search page)? We moved from php...
by omeroon
Wed May 30, 2018 3:26 pm
Forum: [3.2.x] Support Forum
Topic: How do I get the data in formaer database into the new site?
Replies: 35
Views: 926

Re: How do I get the data in formaer database into the new site?

It depends on your backup. If you dumped all the tables with phpMyAdmin with the box "DROP TABLE" selected you can just import it in your current database and it will overwrite everything.. . . I used the backup link in ACP MAINTENACE. Do you know if this functions as "DROP TABLE." You can see this...
by omeroon
Wed May 30, 2018 3:16 pm
Forum: [3.2.x] Styles Support & Discussion
Topic: Overriding T_THEME_PATH for easy inheritance
Replies: 3
Views: 269

Re: Overriding T_THEME_PATH for easy inheritance

Fixed it. For those looking for the answer:

Check the PHP event "core.twig_environment_render_template_before" - it contains T_THEME_PATH in the context data. ;)
by omeroon
Tue May 29, 2018 5:47 pm
Forum: [3.2.x] Support Forum
Topic: 7 years of data gone after upgrade
Replies: 24
Views: 1006

Re: 7 years of data gone after upgrade

If the original backup is missing the data too then you're pretty much screwed. :? Did it take long to export? Because PHP has a standard execution time of 30 sec. so maybe phpMyAdmin timed out in the process of dumping the tables However, if that is the case you should be able to see it in the dump...
by omeroon
Tue May 29, 2018 5:17 pm
Forum: [3.2.x] Support Forum
Topic: How do I get the data in formaer database into the new site?
Replies: 35
Views: 926

Re: How do I get the data in formaer database into the new site?

It depends on your backup. If you dumped all the tables with phpMyAdmin with the box "DROP TABLE" selected you can just import it in your current database and it will overwrite everything. However, be sure to check the config table as it might contain references to your old forum (for instance domai...

Go to advanced search