Search found 8752 matches

by Noxwizard
Fri Apr 13, 2018 3:42 pm
Forum: [3.2.x] Support Forum
Topic: Crossed Logins - users suddenly logged in under another username
Replies: 7
Views: 254

Re: Crossed Logins - users suddenly logged in under another username

There are two situations where this happens: Your host sets up a proxy in front of your site. You can tell this by looking at the Who Is Online list and seeing if every user has the same IP (usually the IP of the proxy). The proxy can be their own hardware or something like CloudFlare. The host need...
by Noxwizard
Sun Apr 01, 2018 6:34 pm
Forum: [3.2.x] Support Forum
Topic: Referral spam that goes to explicit websites...
Replies: 16
Views: 182

Re: Referral spam that goes to explicit websites...

This is nothing new and not unique to phpBB. There is no harm caused by them and it's just an attempt to get website owners to click links they find in their access logs. Your best bet is blocking whatever keywords you want at the Apache level: RewriteCond %{HTTP_REFERER} keyword1 [NC,OR] RewriteCon...
by Noxwizard
Sun Apr 01, 2018 6:15 pm
Forum: [3.2.x] Support Forum
Topic: Keep getting logged out
Replies: 6
Views: 143

Re: Keep getting logged out

If your site is sudaneenforums.com, then your cookie domain needs to be: .sudaneenforums.com
Also, "Cookie secure" should be disabled since your site is available over HTTP.
by Noxwizard
Sun Mar 25, 2018 1:32 am
Forum: [3.2.x] Support Forum
Topic: SSL Settings
Replies: 7
Views: 242

Re: SSL Settings

This is not caused by changing your SSL settings. This is caused by your host blocking a function we use. You can work around this by making the following change: Open: includes/acp/acp_board.php Find: $mod_rewrite = (bool) in_array('mod_rewrite', apache_get_modules()); Replace with: //$mod_rewrite ...
by Noxwizard
Tue Mar 13, 2018 3:18 am
Forum: [3.1.x] Support Forum
Topic: phpBB 3.1.0-dev upgrading to phpBB 3.2.2
Replies: 66
Views: 3409

Re: phpBB 3.1.0-dev upgrading to phpBB 3.2.2

Based on the files, your board is not running 3.1.0-dev, but is instead running 3.0.x; most likely 3.0.7-PL1. To upgrade to 3.1.0, make a backup of your files and database, then follow Steve's steps.
by Noxwizard
Fri Mar 09, 2018 12:04 am
Forum: [3.1.x] Support Forum
Topic: phpBB 3.1.0-dev upgrading to phpBB 3.2.2
Replies: 66
Views: 3409

Re: phpBB 3.1.0-dev upgrading to phpBB 3.2.2

Code: Select all

content-encoding:gzip
content-length: 144
content-type: text/html
date: Fri, 09 Mar 2018 00:01:41 GMT
server: Apache
status: 200
vary: Accept-Encoding,User-Agent
x-powered-by: PHP/4.4.9
Is your server really running PHP 4.4.9? The minimum requirements to run phpBB 3.1.x is PHP 5.3.3.
by Noxwizard
Mon Mar 05, 2018 3:40 am
Forum: [3.2.x] Support Forum
Topic: 503 Service Unavailable intermittently
Replies: 12
Views: 310

Re: 503 Service Unavailable intermittently

It appears in the instructions i don't need to put the . in front of the cookie domain since Im using a subdominan. Is this correct. That is correct. Your cookie domain should be: forums.wylieview.com If you change the domain, also change the name to make sure your browser sends the correct ones. L...
by Noxwizard
Mon Mar 05, 2018 3:19 am
Forum: [3.1.x] Support Forum
Topic: phpBB 3.1.0-dev upgrading to phpBB 3.2.2
Replies: 66
Views: 3409

Re: phpBB 3.1.0-dev upgrading to phpBB 3.2.2

Make a file called files.php with the following in it: <?php // This script checks the integrity of phpBB 3.1.0 installations // Allowing your FTP client to change the line endings of files may // generate false positives during the checksum verification. // Change this to point to the directory con...
by Noxwizard
Wed Feb 28, 2018 3:26 am
Forum: [3.2.x] Support Forum
Topic: Web Application Potentially Vulnerable to Clickjacking
Replies: 11
Views: 423

Re: Web Application Potentially Vulnerable to Clickjacking

You should deal with this in your web server configuration. If it's Apache, add this to your httpd.conf : Header always append X-Frame-Options SAMEORIGIN If you're on shared hosting, and depending on what your host allows in .htaccess files, you can add this to your .htaccess file: Header append X-F...
by Noxwizard
Wed Feb 21, 2018 1:29 am
Forum: [3.1.x] Support Forum
Topic: phpBB 3.1.0-dev upgrading to phpBB 3.2.2
Replies: 66
Views: 3409

Re: phpBB 3.1.0-dev upgrading to phpBB 3.2.2

I have to ask this again. Are you following Steve's steps exactly? Not skipping anything?

Those files should not exist in 3.1.0. They were renamed and moved. Those files are from 3.0.x.
by Noxwizard
Fri Feb 16, 2018 10:14 pm
Forum: [3.2.x] Support Forum
Topic: phpBB won't detect mariadb
Replies: 10
Views: 490

Re: phpBB won't detect mariadb

Again, the user is not even at that point yet. PHP itself needs to detect that the module has been installed. Also, SQLite does not use ports, it's a direct file based DBMS.
by Noxwizard
Fri Feb 16, 2018 6:16 am
Forum: [3.2.x] Support Forum
Topic: phpBB won't detect mariadb
Replies: 10
Views: 490

Re: phpBB won't detect mariadb

There are different ways to connect to MariaDB. I have a few listed on my site at Connecting to MariaDB . Maybe one of the suggestions will help. (On my website I use option 1 for phpBB) That really has nothing to do with the problem at hand. The dropdown menu which shows all DBMS platforms support...
by Noxwizard
Fri Feb 16, 2018 6:08 am
Forum: [3.1.x] Support Forum
Topic: phpBB 3.1.0-dev upgrading to phpBB 3.2.2
Replies: 66
Views: 3409

Re: phpBB 3.1.0-dev upgrading to phpBB 3.2.2

That is not the correct fix to make. The correct fix is to make all of those functions static. However, if you are receiving those errors, then it means two things: Your includes/startup.php is out of date, as others have stated. If it wasn't, those errors would be suppressed. Your includes/utf/utf_...
by Noxwizard
Sun Jan 28, 2018 9:20 pm
Forum: [3.2.x] Support Forum
Topic: iframe gives a blank window
Replies: 4
Views: 120

Re: iframe gives a blank window

That's because the page does not allow itself to be rendered that way. If you check your browser's console, you will see this:

Code: Select all

Refused to display 'https://developers.facebook.com/tools/debug/sharing/' in a frame because it set 'X-Frame-Options' to 'deny'.
by Noxwizard
Sun Jan 21, 2018 4:23 pm
Forum: [3.2.x] Support Forum
Topic: Doubt About Sessions
Replies: 10
Views: 237

Re: Doubt About Sessions

You have secure cookies enabled, but you allow both HTTP and HTTPS access to your site. Anyone visiting over HTTP will not have cookies set and if they came from the HTTPS version of your site, they will lose their cookies and get logged out. You can only enable secure cookies if your site is only a...

Go to advanced search