Search found 91 matches

by gianluigi.zanettini
Mon Feb 24, 2020 6:17 pm
Forum: Extension Writers Discussion
Topic: How can I check if a user is in the login/logout page from the template?
Replies: 2
Views: 396

How can I check if a user is in the login/logout page from the template?

Hi guys! From my custom template (included in multiple pages), I need to check if the user is currently looking either at the login page or at the logout page. I'm basically trying to do something like this:

Code: Select all

<!-- IF !IS_LOGIN_PAGE AND !IS_LOGOUT_PAGE -->
What's the syntax? Thanks!
by gianluigi.zanettini
Mon Jul 29, 2019 1:33 pm
Forum: [3.2.x] Support Forum
Topic: How do I restore "Newly registerd user needs post approval"?
Replies: 7
Views: 259

Re: How do I restore "Newly registerd user needs post approval"?

Hi warmweer, thanks for your reply too. I understand what you mean, but please note that both submit button takes you to a page where you must set "Advanced permission" on a forum-by-forum basis. Please see this demo video I just recoreded . Still: I see that all this permission matrices are the sam...
by gianluigi.zanettini
Mon Jul 29, 2019 12:54 pm
Forum: [3.2.x] Support Forum
Topic: How do I restore "Newly registerd user needs post approval"?
Replies: 7
Views: 259

Re: How do I restore "Newly registerd user needs post approval"?

Thanks again for your continued support. When I get there I see a list of my forums: https://i.postimg.cc/SRWFJQkv/Mobile-z-Shot-1564404546.png I tried to select both "all" and then only some, but in the end I always end up getting a per-forum permission mask like this: https://i.postimg.cc/XJCtzNGY...
by gianluigi.zanettini
Mon Jul 29, 2019 12:11 pm
Forum: [3.2.x] Support Forum
Topic: How do I restore "Newly registerd user needs post approval"?
Replies: 7
Views: 259

Re: How do I restore "Newly registerd user needs post approval"?

Hi Mick, thanks for your reply. I edited NRU post limit now, but it was at 50 (don't know why it was so high), so that's not it.
by gianluigi.zanettini
Mon Jul 29, 2019 12:04 pm
Forum: [3.2.x] Support Forum
Topic: How do I restore "Newly registerd user needs post approval"?
Replies: 7
Views: 259

How do I restore "Newly registerd user needs post approval"?

As per subject, I let NRUsers post freely 4 or 5 years ago, but now I would like to have them go through approval to fight spam. THe problem is, can't find where I did it :oops: :oops: :oops:

I'm with phpBB 3.2 at https://turbolab.it/forum Thanks!
by gianluigi.zanettini
Wed Mar 06, 2019 10:15 pm
Forum: [3.2.x] Support Forum
Topic: phpBB 3.2.4 with PHP 7.3: warning in zendframework/ArrayObject.php
Replies: 24
Views: 5679

Re: phpBB 3.2.4 with PHP 7.3: warning in zendframework/ArrayObject.php

Tomba wrote:
Wed Mar 06, 2019 9:10 pm
Sorry to reactivate this topic again
I'm glad that you did :D Thanks for posting that!
by gianluigi.zanettini
Sat Dec 08, 2018 9:20 am
Forum: [3.2.x] Support Forum
Topic: phpBB 3.2.4 with PHP 7.3: warning in zendframework/ArrayObject.php
Replies: 24
Views: 5679

phpBB 3.2.4 with PHP 7.3: warning in zendframework/ArrayObject.php

Hi guys, Zane from TurboLab.it here. I'm trying to upgrade from PHP 5.6 to PHP 7.3. We currently have phpBB version 3.2.4. The website is custom made, but we integrate phpBB for the user registration and sessions. Right now I'm experiencing this same problem: PHPBB3-15828 . [phpBB Debug] PHP Warning...
by gianluigi.zanettini
Sat May 06, 2017 8:07 pm
Forum: Custom BBCode Development and Requests
Topic: YouTube BBCode?
Replies: 37
Views: 67633

Re: YouTube BBCode?

This is the May-2017, phpBB 3.2 working version: [youtube]{IDENTIFIER}://{SIMPLETEXT1}youtube.com/watch?v={IDENTIFIER2}[/youtube] <iframe width="640" height="360" src="//www.youtube-nocookie.com/embed/{IDENTIFIER2}?rel=0" frameborder="0" allowfullscreen></iframe> The user must simply insert the YouT...
by gianluigi.zanettini
Wed Jan 18, 2017 12:02 am
Forum: Extension Writers Discussion
Topic: submit_post() spits notices since phpBB 3.1
Replies: 2
Views: 403

Re: submit_post() spits notices since phpBB 3.1

Thanks RMcGirr83,
I fixed the issue today. The notice was on topic_posts_unapproved + topic_posts_softdeleted: in edit mode, these must now be into the data array for submit_post.

Plus, topic_first_post_id + topic_last_post_id + post_edit_user must be set too.
by gianluigi.zanettini
Sun Jan 15, 2017 9:49 pm
Forum: Extension Writers Discussion
Topic: How should topic_title be encoded for submit_post()?
Replies: 1
Views: 146

Re: How should topic_title be encoded for submit_post()?

Ok, I must probably use htmlspecialchars(). But... when?

before utf8_normalize_nfc() or after?
before generate_text_for_storage() or after?
by gianluigi.zanettini
Sun Jan 15, 2017 9:44 pm
Forum: Extension Writers Discussion
Topic: How should topic_title be encoded for submit_post()?
Replies: 1
Views: 146

How should topic_title be encoded for submit_post()?

I use submit_post() to insert data into data into phpBB tables. My flow is this: $topicTile = "aaa > \"bbb\" < ccc"; $topicTile = utf8_normalize_nfc($topicTile); generate_text_for_storage($topicTile, $uid, $bitfield, $options, true, false, false); .... $arrData = array( ... 'topic_title' => $topicTi...
by gianluigi.zanettini
Fri Jan 13, 2017 11:31 pm
Forum: [3.2.x] Support Forum
Topic: Upgrade phpBB 3.1 to 3.2: Not yet implemented in s9e Configurator
Replies: 3
Views: 402

Re: Upgrade phpBB 3.1 to 3.2: Not yet implemented in s9e Configurator

Confirmed! As soon as I disabled xdebug, the error was gone. My site is now running phpBB 3.2 ;)

Thanks again!
by gianluigi.zanettini
Wed Jan 11, 2017 9:17 pm
Forum: [3.2.x] Support Forum
Topic: Upgrade phpBB 3.1 to 3.2: Not yet implemented in s9e Configurator
Replies: 3
Views: 402

Re: Upgrade phpBB 3.1 to 3.2: Not yet implemented in s9e Configurator

Hi JoshyPHP,
I think you nailed it: I totally have xdebug installed! I'll try to disable it and migrate again this coming weekend. I'll let you now or post the whole error_log.

Thanks A LOT for now!

Go to advanced search