Search found 10 matches

by schuel
Mon Oct 29, 2007 6:11 am
Forum: [3.0.x] MOD Writers Discussion
Topic: How to Encrypt password with the new system?
Replies: 73
Views: 63792

Re: How to Encrypt password with the new system?

I'm a bit confused. If I want to create a totally new hash (not compare), what code do I need? I have tried the following which works but every time I refresh the page I get a different result, is this right? <?php $password = "test"; define('IN_PHPBB', true); $phpbb_root_path = 'forums/'; $phpEx = ...
by schuel
Mon Oct 29, 2007 4:17 am
Forum: [3.0.x] MOD Writers Discussion
Topic: Insert a user into phpBB from PHP
Replies: 45
Views: 23215

Re: Insert a user into phpBB from PHP

Chuffin' typical... I make my forehead bleed working on this, post a request, and the answer comes to me minutes later if it's useful to anyone define('IN_PHPBB', true); $phpbb_root_path = 'pathtoroot/'; $phpEx = substr(strrchr(__FILE__, '.'), 1); include($phpbb_root_path . 'common.php'); include($...
by schuel
Fri Oct 26, 2007 2:01 pm
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

Try adding the following line of code right before define('IN_PHPBB', true); global $db,$cache,$phpEx,$config,$phpbb_root_path; That fixed it for me... it might not be a great way to do it though :P Well that fixes the original problem I had of a different error when running the code inside my own ...
by schuel
Wed Oct 24, 2007 3:08 am
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

If no one can help me with this error, perhaps someone could suggest the entries I would need to make to manually add a user to the database?

Note: I have updated to RC7 and still have the exact same problems
by schuel
Tue Oct 09, 2007 12:40 pm
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

bump. anyone?
by schuel
Sun Oct 07, 2007 12:10 pm
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

If I just run the following code below (not inside my own function as I was doing before) I get a different error. The error this time is reported by phpBB and says: General Error SQL ERROR [ mysql4 ] Unknown column 'Object' in 'field list' [1054] An sql error occurred while fetching this page. Plea...
by schuel
Sun Oct 07, 2007 11:43 am
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

Here are some details of our setup: -URL: https://secure.evertech.com.au/EverHome/forum/ (currently behind htaccess password though) -Version of phpBB3: 3.0.RC5 -Fresh install -Was this an install through your host? NO -MODs you have installed: None -When the problem started: Trying to add user via ...
by schuel
Sun Oct 07, 2007 11:05 am
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

Re: adding user with script

In common.php which is called from code processing a user activation request: There is a connection made to the DB // Connect to DB $db->sql_connect($dbhost, $dbuser, $dbpasswd, $dbname, $dbport, false, false); and very soon the obtain_config0 function is called // Grab global variables, re-cache if...
by schuel
Fri Sep 28, 2007 2:49 am
Forum: [3.0.x] Support Forum
Topic: adding user with script
Replies: 14
Views: 7153

adding user with script

I am trying to use the user_add() function to merge my site registration with the forum registration. However currently my code comes up with the following error: Fatal error: Call to a member function on a non-object in /home/ev/eve/evertech.com.au/public/www/EverHome/forum/includes/cache.php on li...
by schuel
Thu Sep 27, 2007 3:28 am
Forum: [3.0.x] MOD Writers Discussion
Topic: Help - How to Create phpBB account via code
Replies: 18
Views: 4302

Re: Help - How to Create phpBB account via code

I am trying to do the exact same thing but when I use the code above I get the following error: Fatal error: Call to a member function on a non-object in /home/ev/eve/evertech.com.au/public/www/EverHome/forum/includes/cache.php on line 50 The exact code I'm using is: require_once( 'forum/config.php'...

Go to advanced search