Search found 67 matches

by Matthew G. Saroff
Fri Jun 15, 2018 1:29 pm
Forum: [3.2.x] Support Forum
Topic: Automatic Reparser Progress Indicator
Replies: 6
Views: 369

Re: Automatic Reparser Progress Indicator

8 posts per second is very slow. Try running the CLI with --dry-run to see whether writing to the database is what takes up so much time. I don't know how your shell works but you should be able to use something like GNU Screen to leave the CLI process running in the background even while you're lo...
by Matthew G. Saroff
Fri Jun 15, 2018 4:04 am
Forum: [3.2.x] Support Forum
Topic: Is There A Way to Post an Interstitial?
Replies: 12
Views: 400

Re: Is There A Way to Post an Interstitial?

Actually, I'm worried about the unparsed posts throwing errors for a few weeks, there are over 500,000 posts on the board, and I figure that it would take a few weeks for the background task to finish that. How do you expect them to throw errors? And with a board that large you can export the datab...
by Matthew G. Saroff
Fri Jun 15, 2018 2:25 am
Forum: [3.2.x] Support Forum
Topic: Automatic Reparser Progress Indicator
Replies: 6
Views: 369

Re: Automatic Reparser Progress Indicator

given the number of posts on the board, more than 500K, running this from the command line would take something north of 12 hours In my experience, it should take closer to 20 minutes by CLI depending on your database. Letting the CLI run in the background should always be more efficient and faster...
by Matthew G. Saroff
Fri Jun 15, 2018 2:22 am
Forum: [3.2.x] Support Forum
Topic: Is There A Way to Post an Interstitial?
Replies: 12
Views: 400

Re: Is There A Way to Post an Interstitial?

When you disable the board to do the update you can add a message that will be displayed to anyone trying to access the board I always had some doubts with that "disable" option. The update instructions are telling you to to delete all files except "ext, images, ets" .. But when you delete your boa...
by Matthew G. Saroff
Thu Jun 14, 2018 8:39 pm
Forum: [3.2.x] Support Forum
Topic: Is There A Way to Post an Interstitial?
Replies: 12
Views: 400

Is There A Way to Post an Interstitial?

When I do an update, I expect the board to be down, and as opposed to posting in a pinned topic (where it is frequently missed), I'd like to have a page come up with the message, and then they would have to click through, so that the get the notice.
by Matthew G. Saroff
Thu Jun 14, 2018 4:40 pm
Forum: [3.2.x] Support Forum
Topic: Automatic Reparser Progress Indicator
Replies: 6
Views: 369

Automatic Reparser Progress Indicator

OK, I've finally got my import working, (Running php7 from the command line for phpbbcli.php). I have issues with how a lot of the posts are rendered, because they need to be reparsed. Obviously, they need to be reparsed, but given the number of posts on the board, more than 500K, running this from ...
by Matthew G. Saroff
Mon Jun 11, 2018 1:26 am
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

OK, I think that I got it fixed, though I still cannot install.

It turns out that one of my users had the non-standard character "ĂȘ" in his user name, and it caused upgrade to crash.

I've got another error that I am currently working out, but that's a few googles away.
by Matthew G. Saroff
Sat Jun 09, 2018 9:08 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

OK, I ran the installer in verbose mode, and got this: php ./bin/phpbbcli.php db:migrate -vvv Apply dependencies of \phpbb\db\migration\data\v320\v320. Apply dependencies of \phpbb\db\migration\data\v31x\increase_size_of_emotion. Apply dependencies of \phpbb\db\migration\data\v31x\v3110. Apply depen...
by Matthew G. Saroff
Fri Jun 08, 2018 1:14 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

kinerity wrote: ↑
Fri Jun 08, 2018 11:05 am
Matthew,

Please keep in mind that we have a six hour bumping rule. All team members and community members here are volunteers, so we ask you to wait at least six hours before bumping your topic or, if no-one has replied to your last post, edit your last post. Thanks!
Sorry
by Matthew G. Saroff
Fri Jun 08, 2018 5:31 am
Forum: [3.2.x] Convertors
Topic: Losing Passwords On Importing from MyBB
Replies: 0
Views: 708

Losing Passwords On Importing from MyBB

I'm importing from a MyBB BBS.

The import goes remarkably well, except that all the user passwords are gone. (Also, some user groups need to be fixed, but passwords is a show stopper)

Is there a setting to fix this?

I'm using mybb18_convertor_1.0.2.
by Matthew G. Saroff
Thu Jun 07, 2018 7:44 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

As is my custom, I found an incredibly ugly solution:
  • I imported 3.0.12 into MyBB
  • I imported MyBB into 3.1.12
  • I upgraded 3.1.12 to 3.2.2
It worked, but it took about 12 hours, and it's a hell of a way to run a railroad.
by Matthew G. Saroff
Wed Jun 06, 2018 8:00 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

OK, I think that I've identified part of the problem.

It appears that part of my bulletin board shows as being 3.0.12 and part of it shows as being 3.0.14.

IIRc, there was a failed attempt at that upgrade many moons ago.
by Matthew G. Saroff
Mon Jun 04, 2018 2:11 am
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

stevemaury wrote: ↑
Sun Jun 03, 2018 11:03 pm
Give me a link to the file your downloaded to upgrade. I think you are NOT using the full version.
https://www.phpbb.com/files/release/phpBB-3.2.2.zip

I then unzip, and remove the config.php, files/, store/, and images/, and copy into the install directory.
by Matthew G. Saroff
Sun Jun 03, 2018 9:49 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

If I try to update through the web page, I get:

Image

How do I change the timeout?
by Matthew G. Saroff
Sun Jun 03, 2018 9:16 pm
Forum: [3.2.x] Support Forum
Topic: Updating from 3.0.x Command Line Gives Error
Replies: 17
Views: 1402

Re: Updating from 3.0.x Command Line Gives Error

janus_zonstraal wrote: ↑
Sun Jun 03, 2018 8:29 pm
What php version are you using?
php 5.6

Go to advanced search