Search found 291 matches

by WelshPaul
Mon May 13, 2019 2:22 pm
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

Thx for reporting, I will test it again against this issue. :) What happens is this... 1. Go to a forum, topic or post and click on reply. 2. Click on Github - you will be redirected there 3. Enter your credentials 4. You get returned to forum where you get the error shown in my original post. (No ...
by WelshPaul
Mon May 13, 2019 2:04 pm
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

Just installed your Github extension 3Di and the issue is present there too.
by WelshPaul
Mon May 13, 2019 1:42 pm
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

Mick wrote:
Mon May 13, 2019 1:27 pm
Have you reported the issue?
Who me? No... I came here to get more information and confirmation of the issue... 3Di provided this link: https://github.com/phpbb/phpbb/pull/557 ... -488073115

So they are aware, not sure if it's been escalated or not though.
by WelshPaul
Mon May 13, 2019 1:20 pm
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

I don't understand your reply... I'm not complaining about, or requesting help for the extension i'm using or the use of third paty Oauth accounts. Github will work because they allow whitelisting of the whole domain unlike all the rest - but forget about Github and any other Oauth account that isn'...
by WelshPaul
Mon May 13, 2019 12:10 pm
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

No, I'm using a commercial extension that supports more Oauth accounts and account registration (not oneall).
by WelshPaul
Mon May 13, 2019 9:22 am
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Re: Oauth bug in phpBB

Facebook, Twitter, Google, Github, Discord, Coinbase, instagram all not working etc...

All work fine when used in main login and ucp though.
by WelshPaul
Mon May 13, 2019 8:33 am
Forum: [3.2.x] Support Forum
Topic: Oauth bug in phpBB
Replies: 25
Views: 987

Oauth bug in phpBB

I have discovered a problem with Oauth... I found this in my server log: `[Sat May 11 12:53:13.996584 2019] [php7:error] [pid 26868] [client 0.0.0.0:00000] PHP Fatal error: Uncaught OAuth\\Common\\Http\\Exception\\TokenResponseException: Failed to request resource. HTTP Code: HTTP/1.1 403 Forbidden ...
by WelshPaul
Wed May 08, 2019 9:08 am
Forum: [3.2.x] Support Forum
Topic: General SQL Errors ***Please Advise***
Replies: 5
Views: 361

Re: General SQL Errors ***Please Advise***

A VPS is cheap enough and you're in full control of what goes on with it. Providing you know how to set one up and secure it then it's a no brainer really.
by WelshPaul
Tue May 07, 2019 9:45 pm
Forum: [3.2.x] Support Forum
Topic: oauth_states Table
Replies: 25
Views: 732

Re: oauth_states Table

But if I don't have FB's OAuth set, those anonymouses are just trying to use a direct link? I mean, you have to press the FB button to get there, but that button is not there. :o Yes but if there is an entry for facebook and you haven't configured that in ACP then someone has manually inserted the ...
by WelshPaul
Tue May 07, 2019 9:39 pm
Forum: [3.2.x] Support Forum
Topic: Fix wrong topic_first_post_id
Replies: 23
Views: 1143

Re: Fix wrong topic_first_post_id

Leinad4Mind wrote:
Tue May 07, 2019 4:17 pm
Just being honest and providing my point of view after many years of reading this same nonsense.
Save yourself the wear and tear on your keyboard. :lol:
by WelshPaul
Tue May 07, 2019 9:28 pm
Forum: [3.2.x] Support Forum
Topic: oauth_states Table
Replies: 25
Views: 732

Re: oauth_states Table

Ok so it looks like the entry is made if all or some oauth have been configured in ACP - This wouldn't be a bug though as that's whats supposed to happen right? The real issue is that old entries are never purged from the table and so it grows, grows and grows.
by WelshPaul
Tue May 07, 2019 8:46 pm
Forum: [3.2.x] Support Forum
Topic: oauth_states Table
Replies: 25
Views: 732

Re: oauth_states Table

As I said it looks to me kinda strange, sort of attempts to do something I dunno. Our board uses OAuth, but my table is empty - http://prntscr.com/nlpmqg Edit: checked and the same goes for our secondary TEST live board. Can you try entering this URL into your browser replacing domain.com with your...
by WelshPaul
Tue May 07, 2019 8:43 pm
Forum: [3.2.x] Support Forum
Topic: oauth_states Table
Replies: 25
Views: 732

Re: oauth_states Table

Just to clarify, my board is using oauth such as Facebook, Twitter, Google and others via an extension so one expects to see entries in this table.... Thing is - Anyone or any bot that clicks / follows the link on one of the oauth buttons an entry is made in the table even if they go no further than...
by WelshPaul
Tue May 07, 2019 3:43 pm
Forum: phpBB Discussion
Topic: Should /docs folder be deleted during install or update?
Replies: 23
Views: 1849

Re: Should /docs folder be deleted during install or update?

Just don't upload the docs directory - That's how i've been doing it since 2006.
by WelshPaul
Tue May 07, 2019 1:10 pm
Forum: [3.2.x] Support Forum
Topic: oauth_states Table
Replies: 25
Views: 732

Re: oauth_states Table

But I do not use oauth!!! I don't recall saying you did. I was just pointing out what the cause of the entry in the database was. As I wrote before I already removed those entries and forum still works fine. Don't worry, create backup and delete them :) I had already deleted before making my very f...

Go to advanced search