Search found 85 matches

by bipolarmorgan
Fri Aug 09, 2019 8:27 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

except that they aren't stored in any way in the group table Nobody has mentioned the groups (there is no group) table - it is user_groups, but obviously you know the phpBB database structure better than anyone else so I will just leave you to it. And even if I have orphans, it didn't break anythin...
by bipolarmorgan
Fri Aug 09, 2019 8:15 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

how are they stored in the group table? by id? so i just have to compare existing ids with those in the group table, sounds like another quick query or two... except that they aren't stored in any way in the group table... There might be some orphaned entries in the notifications table, but not that...
by bipolarmorgan
Fri Aug 09, 2019 6:31 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

Tables that now have orphaned entries from your queries: user_group, user_notifications Your queries, other than creating those orphans, will probably not affect anything else, as long as limited to 0 post users. However, better to use and adequate Q&A CAPTCHA to prevent registration than remove th...
by bipolarmorgan
Fri Aug 09, 2019 6:16 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

possibly acl_users, login_attempts, cpf tables to name the ones that come to mind. To do what you want I would make a guess that you will need something in the region of 10 -12 queries (possibly more) and that is all before you even consider what extensions might be doing - although that is probabl...
by bipolarmorgan
Fri Aug 09, 2019 5:40 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

Still nothing broken and that was much faster than the phpbb prune system... but tell me again how you think i'm wrong... 100822 rows deleted. (Query took 26.2806 seconds.) DELETE FROM `phpbb_users` WHERE user_posts = 0 AND user_type = 0 Nobody's telling you that you're wrong. But then again nobody...
by bipolarmorgan
Fri Aug 09, 2019 4:13 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

Woh, slow your horses there guys... i told you it doesn't work properly and you blame mysql, yet phpbb is the one making the sql statements. so why can i run the sql commands directly in mysql and it works, but doesn't in phpbb's built in prune users function? You are missing the point here clearly ...
by bipolarmorgan
Fri Aug 09, 2019 2:19 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

Because you end up with orphaned references in other tables. You'll really mess things up if you do it that way. phpBB uses sql commands to do it too, so if i knew those then i could run it in mysql and be done rather quickly. Why isnt this built into the cli? And it didn't appear to mess anything ...
by bipolarmorgan
Fri Aug 09, 2019 1:06 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

It's quite a big query for the database to run as the tables are interlinked and the user IDs cross referenced in several places so you'll need to just play around deleting various amounts to see at what point it's happy to run it without timing out. It's a database limitation rather than a phpBB o...
by bipolarmorgan
Fri Aug 09, 2019 12:32 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

KevC wrote:
Fri Aug 09, 2019 12:26 pm
Are you trying to delete their posts as well?

Does it work with 2 or 3?
No i was selecting users with 0 posts, and yes i can delete a few at a time...
by bipolarmorgan
Fri Aug 09, 2019 12:20 pm
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Re: Prune Users not working

KevC wrote:
Fri Aug 09, 2019 10:55 am
How many is a large amount?
It'll probably time out if you try to do more than 100.
Most likely over 100.... I tried to narrow it down but no luck.
by bipolarmorgan
Fri Aug 09, 2019 10:51 am
Forum: [3.2.x] Support Forum
Topic: Prune Users not working
Replies: 34
Views: 1440

Prune Users not working

I have a large amount of users that I want to prune, but every time I attempt it fails. It just returns to the prune ACP screen and didn't actually delete any users. Please advise!

Using phpBB 3.2.7
by bipolarmorgan
Tue Aug 06, 2019 6:16 am
Forum: [3.2.x] Support Forum
Topic: Jabber error
Replies: 7
Views: 262

Re: Jabber error

Configuring Jabber is (or more precisely was) quite tricky when I last did it. Better yet, might be, if I manage to make it work, what do I gain by integrating jabber to phpbb? Does it allow IM'ing on the forum or ? What exactly does the integration do? You will not gain anything unless your users ...
by bipolarmorgan
Tue Aug 06, 2019 12:42 am
Forum: [3.2.x] Support Forum
Topic: Jabber error
Replies: 7
Views: 262

Re: Jabber error

Is this the first time you have tried this or is it something that has just started erroring after working previously? First time I've tried the jabber integration, was trying to see what it does for the overall functionality of the board. I even went as far as installing my own xmpp (jabber) serve...
by bipolarmorgan
Mon Aug 05, 2019 10:14 am
Forum: [3.2.x] Support Forum
Topic: Jabber error
Replies: 7
Views: 262

Re: Jabber error

There’s an old topic here that may help you. Unfortunately that topic doesn't hold the information I am looking for. phpBB fails to connect to the Jabber server, with a vague error message and basically no explanation as to why it fails. If there is anyone with knowledge on the subject of phpBB and...
by bipolarmorgan
Mon Aug 05, 2019 8:56 am
Forum: [3.2.x] Support Forum
Topic: Jabber error
Replies: 7
Views: 262

Jabber error

Am receiving an error when trying to configure the jabber server settings... is there anyone who can advise on this subject?

Code: Select all

Information

Could not connect to Jabber server.

Error: open_socket() - Connection refused

Error: connect() #2

Go to advanced search