Search found 207 matches

by Heo32
Sun Jun 30, 2019 6:34 pm
Forum: General Discussion
Topic: MySQL Update from 5.6 to 5.7
Replies: 28
Views: 26826

Re: MySQL Update from 5.6 to 5.7

A backup of phpBB through the ACP can be used and restored on a newer database version. I speak from experience.

Official link:
https://dev.mysql.com/doc/refman/5.7/en/upgrading.html

There is also YouTube for visual instructions.
by Heo32
Thu Jun 27, 2019 12:01 am
Forum: phpBB Discussion
Topic: CSP help
Replies: 8
Views: 1431

Re: CSP help

Well scratch that. I have to disable the CSP because I can't edit WordPress pages with it on. Looking at the web console I have all kinds of script error crap I have no idea what it all means. I go through the same issue. I have 3 different nginx.conf files, each with different levels of security f...
by Heo32
Sat Jun 22, 2019 7:10 pm
Forum: phpBB Discussion
Topic: CSP help
Replies: 8
Views: 1431

Re: CSP help

Header set Content-Security-Policy default-src 'self' *.cloudflare.com *.amazonaws.com *.googleapis.com *.youtube.com script-src 'self' 'unsafe-inline' Remove the 'self' from default-src . It should either be 'none' or only the 3rd party links you posted. script-src 'self' 'unsafe-inline' part due ...
by Heo32
Sat Jun 22, 2019 11:27 am
Forum: phpBB Discussion
Topic: Security Plug Ins
Replies: 18
Views: 1865

Re: Security Plug Ins

Firstly you need a VPS/Dedicated server where you have access to the firewall configuration. There is plenty of articles out there to describe how to implement this and it will vary depending on the server, if you have CSF on the server just google CSF deny all but cloudflare. Cool, I'll do some re...
by Heo32
Sat Jun 22, 2019 11:18 am
Forum: [3.2.x] Support Forum
Topic: PHP 7.3
Replies: 6
Views: 1803

Re: PHP 7.3

If that is what Marc said on Discord a few weeks ago, then I rest my case. phpBB 3.3 will support PHP 7.3. But I'll cover a few obvious points to help you out. 1. phpBB 3.3 is not out yet, therefore no one is using it in a public environment. If they are, then they shouldn't be. 2. PHP 7.3.0 and PHP...
by Heo32
Fri Jun 21, 2019 7:31 pm
Forum: phpBB Discussion
Topic: Security Plug Ins
Replies: 18
Views: 1865

Re: Security Plug Ins

I'm glad to help. Also, if you're hosting your website, be sure all software components are fully up to date on a regular basis. That will often patch known security holes. If you're going with a host provider, then its out of your hands and in theirs. Host providers don't always keep their software...
by Heo32
Fri Jun 21, 2019 7:15 pm
Forum: [3.2.x] Support Forum
Topic: PHP 7.3
Replies: 6
Views: 1803

Re: PHP 7.3

Uh, wrong. All versions of PHP 7.3 will be supported once phpBB 3.3 comes out.
by Heo32
Fri Jun 21, 2019 6:58 pm
Forum: phpBB Discussion
Topic: CSP help
Replies: 8
Views: 1431

Re: CSP help

What is CSP ? Christian Social Party? :lol: Content Security Policy. https://csp-evaluator.withgoogle.com/ I know nothing about code yet I implemented a flawless rating according to the link above link (Google's CSP Evaluator) using version 3. I use two settings depending on what I want to do with ...
by Heo32
Fri Jun 21, 2019 2:12 pm
Forum: [3.2.x] Support Forum
Topic: PHP 7.3
Replies: 6
Views: 1803

Re: PHP 7.3

phpBB 3.3 will support it.

Stick with PHP 7.2 for now.

Although it is nice to know the lowest versions of software that are supported, it is also important to know the highest supported versions, too. In the User Guide, maybe it should get updated to reflect that.
by Heo32
Fri Jun 21, 2019 1:49 pm
Forum: phpBB Discussion
Topic: Security Plug Ins
Replies: 18
Views: 1865

Re: Security Plug Ins

You're welcome. :) Have a backup plan in place and be sure everything is backed up on a regular basis. If you lose anything, or everything, you can look at the logs and figure out what went wrong, patch it up, restore everything and then go live again. You can prevent this by fire-walling all traffi...
by Heo32
Thu Jun 20, 2019 7:49 pm
Forum: phpBB Discussion
Topic: Security Plug Ins
Replies: 18
Views: 1865

Re: Security Plug Ins

1) phpBB has no security holes. If it did, they would get patched pretty quickly. 2) A good Q/A is all you need for registering. Don't make it too obvious. 3) Be sure you use TLS (https) with a key and certificate. Support TLSv1.2 and TLSv1.3 only. Do not allow TLSv1.1 or below since it is considere...
by Heo32
Tue Jun 18, 2019 10:42 am
Forum: phpBB Ideas
Topic: ACP Private Messages: Wording could be better
Replies: 11
Views: 22416

Re: ACP Private Messages: Wording could be better

Could someone change the status of this topic to "Implemented", please? I see Marc is working on it: https://tracker.phpbb.com/browse/PHPBB3-16047 Thank you, Marc. Something that was likely noticed but I'll point it out anyways is that in order for Can send private messages to multiple users to func...
by Heo32
Fri Jun 07, 2019 10:35 am
Forum: General Discussion
Topic: Firefox Extensions: Privacy and Security
Replies: 7
Views: 14470

Firefox Extensions: Privacy and Security

I'd like to share a few extensions I use to increase the security and privacy while browsing the Internet. Without diving deep into the reasons why these extensions are used, I'll let everyone read up on these to decide if they can benefit from them as well. Here they are: Introduction Main page: ht...
by Heo32
Thu Jun 06, 2019 1:02 am
Forum: phpBB Discussion
Topic: Discuss: phpBB 3.2.7 Release
Replies: 59
Views: 15341

Re: Discuss: phpBB 3.2.7 Release

JimA wrote:
Sat May 11, 2019 7:45 pm
This will be fixed soon, thanks for letting us know.
I still don't see 3.2.6 or 3.2.7 listed here:

https://download.phpbb.com/pub/release/3.2/

It's been 7 weeks now.
by Heo32
Fri May 31, 2019 5:09 am
Forum: General Discussion
Topic: VPN discussion: Are they necessary?
Replies: 22
Views: 50563

Re: VPN discussion: Are they necessary?

Contributing to this topic, I came across this video:

Is a VPN Worth it?
https://www.youtube.com/watch?v=ny0S5VK7I70

Go to advanced search