Search found 395 matches

by Leinad4Mind
Mon Sep 18, 2017 8:11 pm
Forum: Abandoned Extensions
Topic: [ABD] Quick Title Edition 2.0.0
Replies: 342
Views: 46245

Re: [3.1][3.2][ALPHA] Quick Title Edition 2.0.0

You need to create a copy of the extension with new database tables and with new positions. Seems "simple" to me. :P
by Leinad4Mind
Sat Sep 16, 2017 9:33 pm
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

david63 wrote:
Sat Sep 16, 2017 5:57 pm
Leinad4Mind wrote:
Sat Sep 16, 2017 3:53 pm
this is in fact a phpBB bug that will happen on some servers and the solution for it!
I trust that you have posted this in the Bug Tracker.
Ofcourse. I post it some days ago.
About the solution I will post it if still needed when got time.
Cheers
by Leinad4Mind
Sat Sep 16, 2017 3:53 pm
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

I've found (with the help of two friends @Calimero and @axiac) that this is in fact a phpBB bug that will happen on some servers and the solution for it! The solution is easy, just open /includes/acp/acp_board.php and find: enable_bitfield_column_flag(FORUMS_TABLE, 'forum_flags', log(FORUM_FLAG_QUIC...
by Leinad4Mind
Fri Sep 15, 2017 11:24 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

I've been studying the bitwise operators, and 1 << 6 seems to be 1*2*2*2*2*2*2 = 64 but for some reason I got 32 on the sql. I'll try to debug this part on the driver.php *fingercross* EDIT: If I put print(1 << 6); it gives me 64. If I put print($bit); it gives me 6. So the code (1 << $bit) should b...
by Leinad4Mind
Fri Sep 15, 2017 11:11 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

I know :( , I'm just trying to figure out what is happening. If I put 2 it works, that means that if the 1 is the right number on that function then the $bit variable that comes from the $flag variable that was a 6 maybe is wrong, maybe it's carrying a wrong value? I've check too that since FORUM_FL...
by Leinad4Mind
Fri Sep 15, 2017 10:49 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

I've found that on /phpbb/db/driver/driver.php If I change: return $column_name . ' | ' . (1 << $bit) . (($compare) ? ' ' . $compare : ''); to return $column_name . ' | ' . (2 << $bit) . (($compare) ? ' ' . $compare : ''); It solves my problem. It sends 64 instead of 32. (And my $bit value aka $flag...
by Leinad4Mind
Fri Sep 15, 2017 10:38 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

Great! Thks!

After submitting Im getting this sql: "UPDATE lei32_forums SET forum_flags = forum_flags | 32"

It should be 64, but it appears 32 as I thought. :|
by Leinad4Mind
Fri Sep 15, 2017 10:23 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

:lol: that would be easy. But I've already try that. I've tried to apply that inside the enable_bitfield_column_flag function, after/before the $db->sql_query($sql); but I get an error when submiting the button: ERR_CONTENT_DECODING_FAILED
by Leinad4Mind
Fri Sep 15, 2017 10:10 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

I already did that :P In /includes/constants.php I've check for the line: define('FORUM_FLAG_QUICK_REPLY', 64); And it's all OK. I've the 64 value. And on /includes/acp/acp_board.php $config->set($config_name, $config_value); if ($config_name == 'allow_quick_reply' && isset($_POST['allow_quick_reply...
by Leinad4Mind
Fri Sep 15, 2017 9:28 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

How can I know which sql query is being sent to the server? Can I output that? So when I click on the ACP button I'll know if something is wrong. Maybe the query that is created via php is grabbing wrong information.
by Leinad4Mind
Thu Sep 14, 2017 11:24 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

Leinad4Mind wrote:
Sun Sep 10, 2017 5:58 pm
On 3.1.9+ I've been testing release by release, but the problem still remains on 3.2.1.

Cheers
Right now I have 2 fresh foruns (test purpose) one with 3.2.0 and other with 3.2.1. But as I said this begun happening in a lot of releases. I guess since 3.1.6
by Leinad4Mind
Thu Sep 14, 2017 10:23 am
Forum: [3.2.x] Support Forum
Topic: ACP Quick Reply Option Not Working
Replies: 23
Views: 934

Re: ACP Quick Reply Option Not Working

Can anyone test this on a fresh 3.1.11 or 3.2.1 forum?
by Leinad4Mind
Thu Sep 14, 2017 8:19 am
Forum: Extension Requests
Topic: Create preformatted/prefilled post in a specific topic ?
Replies: 1
Views: 477

Re: Create preformatted/prefilled post in a specific topic ?

You need to search for template bbcode extension. There is already some available. Cheers
by Leinad4Mind
Thu Sep 14, 2017 8:17 am
Forum: Extension Requests
Topic: Customizible status dropdown for postings
Replies: 2
Views: 244

Re: Customizible status dropdown for postings

That can be solved with a prefix extension. And you've too the topic solved extension. That could work for you too. Cheers
by Leinad4Mind
Thu Sep 14, 2017 8:13 am
Forum: Extension Requests
Topic: calendar
Replies: 37
Views: 4710

Re: calendar

You can't... But there is a great premium Calender extension in development and will be available very soon.

Cheers

Go to advanced search