Search found 153 matches

by kaspir
Fri Feb 10, 2017 7:36 am
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

3di is not 3Di.. ;) May be another user.. dunno. :) No, I mean "0.0": { should be "1.0": { Notice 1.0 instead of 0.0 in "stable": { "0.0": { "current": "1.0.0-dev", If your version is 1.0.0-dev is quite fine, but should relate to 1.0 .. Like this { "stable": { "1.0": { "current": "1.0.0-dev", "down...
by kaspir
Fri Feb 10, 2017 6:11 am
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

Thanks for your response 3di. I was very tried after all those fails yesterday! I see in your copy is the "unstable". Which I read was not required, and you probably know that already. Do you mean that the "unstable" provides the re-check option in ACP? Cause that's what I'm looking for (and was app...
by kaspir
Thu Feb 09, 2017 7:47 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

I now got this: http://image.prntscr.com/image/102e3a9a81794fd3bdeaa003097ae261.png BUT, after I hit details and click this: http://image.prntscr.com/image/13d9e82cec444403b4cd051a7b3e16ff.png And I get this: http://image.prntscr.com/image/94730073811e400bae1452262fe8744f.png And also this pops up: ...
by kaspir
Thu Feb 09, 2017 6:34 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

kinerity wrote:
Thu Feb 09, 2017 6:26 pm
Try this for the rewrite rule:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{SERVER_NAME}$1 [R,L]
</IfModule>
Not sure if it will help, but worth a shot.
Anything is worth trying mate, thx! But add it to the 'fail pile', no change. :mrgreen:
by kaspir
Thu Feb 09, 2017 6:19 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

What the: RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$ RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$ :lol: same thing I asked my host, as I did not put it there, they explained they didn't either, I called BS.. then they said it's put in my domains panel, idk.. I removed...
by kaspir
Thu Feb 09, 2017 4:56 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

Paul wrote:
Thu Feb 09, 2017 12:46 pm
Add a

Code: Select all

"ssl": true
to your file if you use SSL.
Add this to which file, I've tried both.. would be great to be clear on this, thx!
by kaspir
Thu Feb 09, 2017 4:26 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

I think Paul meant this: "extra": { "display-name": "My Bookmarks Quick Link", "soft-require": { "phpbb/phpbb": ">=3.1.0,<3.3" }, "version-check": { "host": "thetopfew.com", "directory": "/development/phpbb/ext/mybookmarks", "filename": "version_check.json", "ssl": true } } Specification would help...
by kaspir
Thu Feb 09, 2017 4:25 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

HA! Nevermind.. that's not it.. I have no idea! Lost puppy..
by kaspir
Thu Feb 09, 2017 3:47 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

Okay, I've done this before but it wasn't as clear as it now with your edit Paul. The force https rule seems to be the culprit now, I'm sure of it this time. Works when I take it out, doesn't at alI put it back in! # Forces HTTPS when http is requested. RewriteCond %{HTTPS} off RewriteCond %{REQUEST...
by kaspir
Thu Feb 09, 2017 1:45 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

Can you try "ssl": 1 instead? I will try anything you tell me sir! Doing it now, you should see the changes by the time you read this. EDIT: Okay now we got a change in progress... with my original htaccess active and your new change in version_checker.json. Now in ACP it shows green and verified, ...
by kaspir
Thu Feb 09, 2017 12:52 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

Add a "ssl": true to your file if you use SSL. THX! That's new to me! Just did so, now what? https://thetopfew.com/development/phpbb/ext/mybookmarks/version_check.json :( If anyone of you wish to see my htaccess, I would prefer to PM it, not share it publicly. (reason I'm holding out) EDIT: Downloa...
by kaspir
Thu Feb 09, 2017 12:45 pm
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

I had it that way originally (followed the instructions to a T), and after speaking to another ext dev, he recommended what I have now and it does work without my htaccess file.

Thx, keep the thoughts coming, PLEASE!
by kaspir
Thu Feb 09, 2017 11:47 am
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Re: Can't get version check to work on my 1st ext!

david63 wrote:
Thu Feb 09, 2017 11:46 am
Not sure if it is the problem but try putting www. before host in your composer.json file.
THX for the feedback, I tried that already sir. :(
by kaspir
Thu Feb 09, 2017 11:41 am
Forum: Extension Writers Discussion
Topic: Can't get version check to work on my 1st ext!
Replies: 24
Views: 889

Can't get version check to work on my 1st ext!

Self-hosted check.json: https://thetopfew.com/development/phpbb/ext/mybookmarks/version_check.json My "extra" in composer.json: "extra": { "display-name": "My Bookmarks Quick Link", "soft-require": { "phpbb/phpbb": ">=3.1.0,<3.3" }, "version-check": { "host": "thetopfew.com", "directory": "/developm...
by kaspir
Tue Feb 07, 2017 11:28 am
Forum: phpBB Discussion
Topic: Custom php.ini Settings VS Shared Hosting Plans
Replies: 13
Views: 1092

Re: Custom php.ini Settings VS Shared Hosting Plans

Nerve-racking, isn't it? :lol: Between the shared host being conservative ('for security' also mentioned) for all, and the site owner's wants/needs to alter server settings. It's a double-edge sword. imo Applause for the go! And yes, there is some very good sense to it. As we all know, the custom ph...

Go to advanced search