Search found 70 matches

by EAM
Tue Apr 21, 2009 12:56 pm
Forum: [3.0.x] Support Forum
Topic: Login using users table user_password field value
Replies: 6
Views: 130

Re: Login using users table user_password field value

I'm thinking of using the hash value of a password as a password in another table, but it will be the input password which will then get hashed, I guess. I'm not too concerned about being able to know the input password to the other table since security for that table isn't a big issue. Do you know ...
by EAM
Mon Apr 20, 2009 6:14 pm
Forum: [3.0.x] Support Forum
Topic: Login using users table user_password field value
Replies: 6
Views: 130

Re: Login using users table user_password field value

If the password is hashed, then how is it validated? Does the function that logs in hash the password that is entered so it matches the user_password field? If so, then shouldn't there be a way to not hash the password and have it match and validate the user?
by EAM
Mon Apr 20, 2009 5:47 pm
Forum: [3.0.x] Support Forum
Topic: Login using users table user_password field value
Replies: 6
Views: 130

Login using users table user_password field value

I would like to be able to use the value that is in this field. I have been able to log in using the login function with the username and password as it would be entered in the login box but I am trying to write a script that queries the users table based on userid and then log in with the username ...
by EAM
Sun Dec 21, 2008 3:25 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, I'm getting an error on this line. Looks like there is a ' missing somewhere: $weekly_digest_sql = ($weekday_gmt == $config['digests_weekly_digest_day']) ? ' OR (user_digest_type = ' . DIGEST_WEEKLY_VALUE . " AND user_digest_send_hour_gmt = $current_hour_gmt)" : ''; The error shows as: SELE...
by EAM
Fri Dec 19, 2008 1:21 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

FYI, again. The $_SERVER fix does work in IIS7 too.
by EAM
Fri Dec 19, 2008 12:57 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, I'll apply that bug fix. Also, FYI, the getenv didn't work in IIS 6 which was the host server version but my Vista localhost is IIS7 and it did work. Not sure if the fix works in IIS7 but I'll be checking that out today (amazing what you think about at 3 in the morning). I did notice that t...
by EAM
Thu Dec 18, 2008 4:11 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Thanks, had already seen the POST one and fixed that too. This has been a great learning experience and now I've got to go get a PHP book!
by EAM
Thu Dec 18, 2008 2:26 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, it's me again. This looks like the problem in ucp_digests.php: 'U_ACTION' => htmlspecialchars(getenv('PHP_SELF')) . '?' . htmlspecialchars(getenv('QUERY_STRING')), When I get here I put in: echo $this->u_action . '<br />'; After the 'U_ACTION' assignment and the value is correct. It looks l...
by EAM
Wed Dec 17, 2008 2:28 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

It seems that when the user clicks the tab "digests" that is a link and that correctly brings up the next page which shows the digests selections. However, when I look at the sourceview of the generated page, on my correct installation the form "action" shows ucp.php?i=190 but on the incorrect insta...
by EAM
Tue Dec 16, 2008 8:52 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

I am not able to get that from the page that is submitted on the host machine. It doesn't appear at the top of the page the same as it does on my local machine. I did see something odd and that is that on my local machine, which works, when I hover over the submit button in the digests/basic screen,...
by EAM
Tue Dec 16, 2008 7:28 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, I don't believe that it is getting that far. I put the same line in my localhost copy and the other host copy. When I update my local machine, I get the ucp page with the sql statement showing at the top, then it redirects me back to the ucp, digests setting page that I just submitted. Seem...
by EAM
Tue Dec 16, 2008 5:58 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

I'm using MySql. It's not windows specific. I noticed that on my local machine I get the confirmation "your digest settings were saved" and then it brings me back to the digest basic page. On the host machine, it doesn't give me any confirmation of anything but redirects me to the general ucp page.
by EAM
Tue Dec 16, 2008 4:56 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, I can see that you are very busy. I have a question that might be a quick answer though. I had previously installed the digests on my local computer (localhost) and all was working great. Now I put it on a host computer which I am allowed administrator access through Microsoft Terminal Serv...
by EAM
Tue Dec 16, 2008 1:29 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hi Mark, When you say significant bugs, are you referring to the whole digests mod or just that conversion from 2 to 3? I'm putting this on a board that we are testing now but if all goes well, we will be going live. As long as we aren't having trouble, do you see that as a problem? Also, when the d...
by EAM
Mon Dec 15, 2008 5:20 pm
Forum: [3.0.x] MODs in Development
Topic: [RC7] phpBB Digests
Replies: 321
Views: 20468

Re: [BETA] Email Digests

Hello, I installed the digest stuff and followed the instructions explicitly. Everything seems to be working great. The only deviation that I had to make was that I duplicated all of the en files to my en_us directories and made changes there. I'm not too concerned about a little different spelling ...

Go to advanced search