Upgrade and new server

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Upgrade and new server

Post by DefinitiveJuxx »

Hello
So I run 2.0.17 and want to move to another server and also upgrade to Phpbb 3.X. The new host has 1-click installment of v. 2.0.22 wich is tempting since I suck at the upgrading.

I have mysql abnd acp backups. How do I move and upgrade the easiest way?

I also have the attachment mod installed, how do I not loose the attached files when I upgrade?

Thanks!
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51596
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Upgrade and new server

Post by stevemaury »

You are going to lose all MODs (except Attachment and Birthday) in the conversion and all version 2 styles.

So what I would do is to Upload a fresh set of 2.0.23 files to your present version 2 folder EXCEPT the contrib folder and config.php. Let them overwrite the files that are there. Then browse to install/update_to_latest.php and delete the install folder. Now you have a 2.023 install which you can move to the new host - see:

Knowledge Base - How to move a phpBB 2.0.x board to a new server

Once the version 2 board is running on the new server, install version 3 in a different folder and convert. Information on how to convert from phpBB2 to phpBB3 is here.

Basically, you must have both phpBB2 and phpBB3 installed on the same server. After you have finished installing phpBB3 you will have the option to convert your phpBB2 board using the built in converter. The information it asks you for is related to the phpBB2 installation and can be found in its config.php file on the server. All of your users, posts, forums, PMs etc are converted. However, styles and MODs are not (with the exception of the birthday and attachment MODs which are supported by the converter). The phpBB2 database is not converted per se, it is merely read and converted/moved to the new phpBB3 database, so if it goes wrong your old board will not be affected at all. At the end of the conversion, once you're happy it's all working, your phpBB2 database and files can be backed up and removed if you so wish. They are not connected to the new installation in any way.
Then, I would upload a fresh set of 2.0.23 files
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

Ok, so I'm using bigdump and I get 1/3 through and get theis notice:

Code: Select all

Error at the line 282707: INSERT INTO phpbb_search_wordlist (word_text, word_id, word_common) VALUES('et', '410', '0');

Query: INSERT INTO phpbb_search_wordlist (word_text, word_id, word_common) VALUES('et', '410', '0');

MySQL: Duplicate entry 'et' for key 1
"et" means "one" in my language, but how can this be a problem?

Thanks!
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Upgrade and new server

Post by ric323 »

There is a mismatch between the "collation" settings on your old database and your new one, so accented letters are being converted to the unaccented equivalent, causing those "duplicate entry" errors.

One way around this is to open your backup file with a text editor, and do a global search and replace of

Code: Select all

INSERT INTO phpbb_search_
to

Code: Select all

REPLACE INTO phpbb_search_
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

That worked, thanks.

But now I'm getting the old:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Upgrade and new server

Post by karlsemple »

DefinitiveJuxx wrote:That worked, thanks.

But now I'm getting the old:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?

Install this mod http://www.phpbb.com/community/viewtopi ... 3#p1285423 it should turn the error fro that unhelpful one to something more useful and thus show what the problem is :)
Image
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

Thanks, so it's a template thing?

Code: Select all

Critical Error!
message_die() was called multiple times.
 
--------------------------------------------------------------------------------
Error #1 
Information 
Board_disable 

 
--------------------------------------------------------------------------------
 Error #2 
Could not get theme data for themes_id [4] 
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Upgrade and new server

Post by ric323 »

It looks like you have not installed a theme you were using on the old board.
If you can't install it on the new server, you can use this script to force all users to the default subSilver theme.

Knowledge Base - Set subSilver as the default template
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

Ok, now I get this.
Critical Error!
message_die() was called multiple times.

--------------------------------------------------------------------------------
Error #1
Information
Board_disable


--------------------------------------------------------------------------------
Error #2
Could not get theme data for themes_id [4]
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Upgrade and new server

Post by karlsemple »

did you make sure you had the default subSilver template uploaded and then follow the article ric linked you to?
Image
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

Yes I did. It was done succesfully all the way.
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Upgrade and new server

Post by karlsemple »

DefinitiveJuxx wrote:Yes I did. It was done succesfully all the way.

Then why is it still looking for the theme_id 4, it should have dropped and re-created the table with subSilver which would have the theme_id 2 from looking at the script. Be sure you followed the article exactly :)
Image
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

I followed it exactly. Subsilver is the only template in the template folder.

Oh wait. I got the board in disabled mode, but couldn't get the ACP to open. Then I noticed that the bigdump was only 99% done. So I ran that again succefully, then I ran the reset_template and got the above mentioned error. Should I just try to install everything all over again?
DefinitiveJuxx
Registered User
Posts: 52
Joined: Thu Apr 27, 2006 11:04 am

Re: Upgrade and new server

Post by DefinitiveJuxx »

Ok, so I suspect there is a problem with my web hotel, because now the forum is visible. It is disabled and I get a http 404 error when I try to get to ACP.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68182
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Upgrade and new server

Post by Lumpy Burgertushie »

sounds more like a problem with uploading files.

double check using ftp, that all files and folders have been uploaded and that they are not empty, etc.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
Locked

Return to “2.0.x Support Forum”