Mail problems in 2.0.5?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Got Bud
Registered User
Posts: 2
Joined: Wed Jul 02, 2003 11:20 pm

Post by Got Bud » Fri Jul 04, 2003 6:35 am

That is very strange because I am running 2.04 and it still will not send confirmations to new sign up's, (disabled it so they are auto active) and when sending PMs it also gives error. I changed my email sever on my box and mass emails seem to be working now...
The error code I get for all of these is...
DEBUG MODE

Line : 225
File : c:\program files\instantservers\miniportal\phpbb2\includes\emailer.php

if someone could give me some insite that would be awesome, ton of members signing up and would like to have it bug free and stable within the next week...

Thanks ahead of time!

MrStormyNights
Registered User
Posts: 94
Joined: Mon Mar 25, 2002 5:52 pm

Would not recommend this!

Post by MrStormyNights » Fri Jul 04, 2003 3:41 pm

Dindal wrote: I did a bit of testing, and I came to this conclusion..
Until they come out with an official fix,
download the 2.0.4 emailer.
I have tested it and everyone gets the mass emails, regular emails, and everything.
PMs work, but they wern't broken for me.


I wouldn't recommend using the emailer.php from 2.0.4 on 2.0.5, it broke PM's for me and others that tried it. See this thread for a few more details
http://www.phpbb.com/phpBB/viewtopic.ph ... highlight=

User avatar
Juliooo
Registered User
Posts: 6
Joined: Wed Jul 02, 2003 11:20 pm
Location: Slovakia
Contact:

Post by Juliooo » Sat Jul 05, 2003 10:47 am

Answer on this problem is:

Edit your emailer.php:

--BEFORE--

Code: Select all

if ( !$result )
{
 message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
}

--AFTER--

Code: Select all

//if ( !$result )
//{
// message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
//}
THIS IS ALL!!! :-)))

modifiedcarclub
Registered User
Posts: 3
Joined: Fri Jul 04, 2003 9:11 pm

Post by modifiedcarclub » Sat Jul 05, 2003 2:48 pm

As simple as it seems that actually works!

Thankyou so much!!!!!!!!!

modifiedcarclub
Registered User
Posts: 3
Joined: Fri Jul 04, 2003 9:11 pm

Post by modifiedcarclub » Sat Jul 05, 2003 2:54 pm

I've just noticed that although the error message has dissapeared no e-mails are being sent! :evil:

User avatar
Dindal
Registered User
Posts: 236
Joined: Wed Jun 04, 2003 3:57 am
Contact:

Re: Would not recommend this!

Post by Dindal » Sat Jul 05, 2003 3:29 pm

MrStormyNights wrote:
Dindal wrote:I did a bit of testing, and I came to this conclusion..
Until they come out with an official fix,
download the 2.0.4 emailer.
I have tested it and everyone gets the mass emails, regular emails, and everything.
PMs work, but they wern't broken for me.


I wouldn't recommend using the emailer.php from 2.0.4 on 2.0.5, it broke PM's for me and others that tried it. See this thread for a few more details
http://www.phpbb.com/phpBB/viewtopic.ph ... highlight=


Interesting... It worked on freehu.com and myjspace.com for me....
Oh well..
I am a registered member, so I might not always be right.

My Message Boards, Feel Free To Talk About Anything

davidh44
Registered User
Posts: 386
Joined: Sat Mar 09, 2002 5:56 am

Post by davidh44 » Sat Jul 05, 2003 4:54 pm

All that's doing is surpressing the error message, not fixing the problem.
Juliooo wrote: Answer on this problem is:

Edit your emailer.php:

--BEFORE--

Code: Select all

if ( !$result )
{
 message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
}

--AFTER--

Code: Select all

//if ( !$result )
//{
// message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
//}
THIS IS ALL!!! :-)))

User avatar
Dindal
Registered User
Posts: 236
Joined: Wed Jun 04, 2003 3:57 am
Contact:

Post by Dindal » Sat Jul 05, 2003 5:57 pm

The
//
that was placed there makes it so that the code does not appear. You can make notes about everything with
//
before it.
I am a registered member, so I might not always be right.

My Message Boards, Feel Free To Talk About Anything

jet_Jaguar
Registered User
Posts: 63
Joined: Sat Apr 06, 2002 10:53 pm
Location: Central California, USA

Post by jet_Jaguar » Sat Jul 05, 2003 10:31 pm

-Server Operating System: Linux 2.4.1
-PHP version: 4.3.1
-Email server application: Using php, which uses sendmail (not sure which version)
-Hosting company: Synergy max
-When problem occurs? Mass emails, private emails, etc.

This was upgraded from a 2.0.4 installation.
Guy Talk Forum Admin

jet_Jaguar
Registered User
Posts: 63
Joined: Sat Apr 06, 2002 10:53 pm
Location: Central California, USA

Post by jet_Jaguar » Sat Jul 05, 2003 11:01 pm

I should add that my error message with 2.0.5 reads as such:
Failed sending email :: PHP ::

DEBUG MODE

Line : 246
File : /home/snowrobo/public_html/forum/phpBB2/includes/emailer.php


After I uploaded the emailer.php from 2.0.4, I get a different error message when trying to post mass emails:
Fatal error: Call to undefined function: from() in /home/snowrobo/public_html/forum/phpBB2/admin/admin_mass_email.php on line 119


Should I upload the admin_mass_email.php from 2.0.4 as well? I've copied the emailer from 2.0.5 back in for now.

When I try using the SMTP server , I get yet another error:
Ran into problems sending Mail. Response: 535 Incorrect authentication data

DEBUG MODE

Line : 133
File : /home/snowrobo/public_html/forum/phpBB2/includes/smtp.php


I've double-checked the authentication (username, password, server) and successfully sent mail with the same settings using eudora.
Guy Talk Forum Admin

Alcher
Registered User
Posts: 28
Joined: Mon May 20, 2002 5:24 am
Location: Russia

After upgrade to 2.0.5 (from 2.0.4)

Post by Alcher » Sun Jul 06, 2003 10:59 am

emailer.php - question to Acyd Burn :
Acyd Burn wrote: ...To clarify this, the only change is the non-trimming of $this->extra_headers at the end of the line.
This is not worked everywhere.
Juliooo wrote: Edit your emailer.php:

--BEFORE--
Code:

if ( !$result )
{
message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
}


--AFTER--
Code:

//if ( !$result )
//{
// message_die(GENERAL_ERROR, 'Failed sending email', '', __LINE__, __FILE__);
//}

THIS IS ALL!!! ))

This is solved problem indeed? or no?

mazvaz
Registered User
Posts: 4
Joined: Sun Jul 06, 2003 2:11 pm

Post by mazvaz » Sun Jul 06, 2003 2:13 pm

No, this just hides the problem. :roll:

CowBoyCyCo
Registered User
Posts: 19
Joined: Thu Jul 03, 2003 5:48 pm

Post by CowBoyCyCo » Sun Jul 06, 2003 2:15 pm

I have used this code and im still getting the register error and mass email error.. Why is that?
CowboyCyCo

phatman101
Registered User
Posts: 2
Joined: Sun Jul 06, 2003 5:49 pm

Lycos

Post by phatman101 » Sun Jul 06, 2003 10:38 pm

My provider is lycos


Phpbb version:2.25


Problem

when anyone try to sign up hes gets this message!



Failed sending email :: PHP :: 0

DEBUG MODE

Line : 246
File : /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/emailer.php




And when i setup and e-mail thing:


Warning: fsockopen, pfsockpen, show_source, php_uname, ini_get, ini_alter, ini_restore, ini_set, getrusage, mysql_list_dbs, get_current_user, set_time_limit, getmyuid, getmypid, dl, leak, listen, chown, chmod, chgrp, realpath, tmpfile, link() has been disabled for security reasons in /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/smtp.php on line 111

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/smtp.php:111) in /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/page_header.php on line 474

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/smtp.php:111) in /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/page_header.php on line 476

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/smtp.php:111) in /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/page_header.php on line 477
Day Care Fxp
Simply Warez
FAQ Search Memberlist Usergroups Register
Profile Log in to check your private messages Log in


Day Care Fxp Forum Index
General Error

Could not connect to smtp host : :

DEBUG MODE

Line : 113
File : /data/members/free/tripod/nl/d/a/y/daycarefxp2/htdocs/forums/phpbb2/includes/smtp.php

Powered by phpBB 2.0.5 © 2001, 2002 phpBB Group

C-106h057
Registered User
Posts: 1
Joined: Fri Jun 27, 2003 5:08 pm

Post by C-106h057 » Mon Jul 07, 2003 1:12 pm

I"m sorry that I dont have all the server info, but I know that my host does not allow me to send emails out. I need to edit the emailer file so that when someone registers that it does not send an email out. I am using phpbb 2.0.5.

I didnt feel like creating a new thread on it, since this feels like this is where it should go. I'll try and find my server info and post it here.

Locked

Return to “2.0.x Support Forum”