Mail problems in 2.0.5?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Paul Diederich
Registered User
Posts: 1
Joined: Sun Aug 03, 2003 3:48 am
Location: Arizona
Contact:

Post by Paul Diederich » Sun Aug 03, 2003 3:52 am

Hi, I just set up a Red Hat Linux 9 box up with everything installed. I've set up a phpBB but I'm having a problem setting up SMTP. I am only able to use SMTP by fowarding it to smtp.west.cox.net, othwerise the mail will never get through cox's network.

I have setup the options on the board with the appropreit settings, but everything I try to get it to send an e-mail, I get this:
Ran into problems sending Mail. Response: 502 Command is locally disabled

DEBUG MODE

Line : 127
File : /var/www/html/forum/includes/smtp.php


Any idea's how I can enable SMTP?
Paul D.

Demah
Registered User
Posts: 108
Joined: Wed Dec 18, 2002 2:33 am

Post by Demah » Sun Aug 03, 2003 6:30 am

Hosting Company: local network computer
Server Operating System: Windows XP
PHP Version: 4.3.2
Web Server: Windows XP IIS
Mysql Version: 3.25.52
Email Server: cableone.net

The error message I get when trying to register


Code: Select all

Failed sending email :: PHP :: 

DEBUG MODE

Line : 246
File : c:\inetpub\wwwroot\includes\emailer.php

User avatar
Mooncow
Registered User
Posts: 261
Joined: Tue Feb 25, 2003 8:10 am
Location: This Post
Contact:

Post by Mooncow » Sun Aug 03, 2003 10:14 am

I've read most of the topic... But heres my details and problems

Hosting company: cyberdevX.com
server operating system: Linux
PHP version: 4.3.2
email server application: (e.g. sendmail, qmail, postfix, etc.) - I dunno what this is

Problems:

I try to send a Mass email and only I recieve the email...
THis doesn't work with mass group emails either

I also get this error when people are meant to get reply notifications or PM notifications:
SMTP error from remote mailer after RCPT TO:<emailaddress@hotmail.com>:
host mx1.hotmail.com [65.54.166.99]: 501 Invalid address
I love teh phpBB

O
Registered User
Posts: 60
Joined: Sat Jul 12, 2003 9:28 am

Post by O » Sun Aug 03, 2003 12:08 pm

pls pls pls may one of you great coders try to fix the lycos errors. They're the only free host (that i know of) that will host phpbb2 forums, but whenever anyone registers, emails or pms from the forum, they get error messages about mailer.php. and lets face it, users will be a bit put off if the first thing they get after registering is an error message and then they might PM admin to tell them about it, but then they get another message. this also makes phpbb2 not look very good, so pls pls pls fix it!!!

jej
Registered User
Posts: 1
Joined: Sun Aug 03, 2003 4:29 pm

can't connect to download

Post by jej » Sun Aug 03, 2003 6:28 pm

Acyd Burn wrote: Ok, new files for you guys. These files should finally work.
Thanks to all of you giving feedback to us.

phpbb_emailer_test2.zip

phpbb_emailer_test2.tar.gz


I can't connect to these file downloads. Has the location been changed?

Acyd Burn
Consultant
Consultant
Posts: 5830
Joined: Wed Dec 05, 2001 8:31 pm
Location: Behind You
Name: Meik Sievertsen

Post by Acyd Burn » Sun Aug 03, 2003 7:54 pm

Files are taken down... phpBB 2.0.6 released (see Announcement).

It is highly recommended to update to phpBB 2.0.6.

Locked.

ZoliveR
Former Team Member
Posts: 11899
Joined: Sun Jul 14, 2002 7:36 pm
Location: floating in the light, never forgotten

Post by ZoliveR » Mon Aug 04, 2003 12:23 am

It's a good reason to update your board for fixing the email problems ;)
Well done for the 2.0.6 ;)
No more Team Chocolate Member. I decided to leave, it's my choice. Thanks to all for all these years.
I'm always near if you need news of me. But no more support is given (private notification disabled)

Locked

Return to “2.0.x Support Forum”