SID and Cookies

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
mlimburg
Registered User
Posts: 167
Joined: Thu Sep 06, 2001 11:27 am
Location: Adelaide, Aust.

SID and Cookies

Post by mlimburg »

Howdy,

I've been testing out phpBB2 for a while now, and after a short break from the net, I come back to see it's relelased. Woohoo!

Now, I installed the release onto my localhost machine, and fired it up (as per usual install) and there's no problem ... except I can't seem to get it to provide cookies. I'm stuck with SID in the URL.

Any ideas here? This is a 100% stock standard install ...

Regards,

Mark
Remember, friends don't let friends install phpNuke.
Kylecool
Registered User
Posts: 674
Joined: Sat Feb 02, 2002 3:51 am
Location: Southern California, U.S.A! GO USA!
Contact:

Post by Kylecool »

What is your cookie path in the admin panel?

-Kyle
VACATION UNTIL june 29TH or 30th. :)
mlimburg
Registered User
Posts: 167
Joined: Thu Sep 06, 2001 11:27 am
Location: Adelaide, Aust.

SID & Cookies

Post by mlimburg »

As I said, this is a 100% stock standard install ...

Cookie domain = phpbb2
Cookie name = phpbb2mysql
Cookie path = /

My hosts file is setup as 127.0.0.1 localhost webtopia phpbb2

I'm accessing the site via Apache, via the http://phpbb2/ address.

Hope this helps ...
Remember, friends don't let friends install phpNuke.
Kylecool
Registered User
Posts: 674
Joined: Sat Feb 02, 2002 3:51 am
Location: Southern California, U.S.A! GO USA!
Contact:

Post by Kylecool »

Try doing http://127.0.0.1/phpbb . Also, you might have more luck having it on a real server, not a test server. I sometimes have problems with cookies too on my personal windows computer, so you might want to try it on a site.

-Kyle 8)
VACATION UNTIL june 29TH or 30th. :)
Bear
Registered User
Posts: 2586
Joined: Mon Dec 31, 2001 7:50 pm
Location: 127.0.0.1
Contact:

Post by Bear »

Try leaving the cookie domain blank.
Bear
Got a thing for fashion? So do we at the Fashion Spot.
Let us give you the Royal Treatment at Les Tribunes Royales.
erossetto
Registered User
Posts: 217
Joined: Mon Dec 17, 2001 12:59 pm
Location: .ar

Post by erossetto »

Try changing the cookie name and leave cookie domian blank as Bear said....
^^^^
Locked

Return to “2.0.x Support Forum”