Page 1 of 1

Closing phpBB 2.0 forums?

Posted: Mon Oct 13, 2008 8:42 am
by Exbatts
Hi

We have a phpbb 2.0 forum, set up through createforum which we had migrated over to a version 3.0 recently. Due to so many problems for members we decided to go back to our older forum (2.0) which works fine apart from a recent :PHP: error when posting. Does anyone know if the version 2.0 forums created with creatforum are going to be closed down? I cannot get any support from createforum right now.

Sorry if im not meant to post about this, I dont know what else to do.

Re: Closing phpBB 2.0 forums?

Posted: Mon Oct 13, 2008 8:44 am
by ChrisRLG
As we do not support any version of v2 downloaded from anywhere than here, that is a little moot.

All support for v2 will be closed at the end of the year. Please read the links from the pink box above.

Re: Closing phpBB 2.0 forums?

Posted: Mon Oct 13, 2008 8:49 am
by Exbatts
Right, I did not know that you dont support forums downloaded from anywhere other than here, I just needed to be sure that our decision to go back to our older forum was the wrong one.

Cheers

Re: Closing phpBB 2.0 forums?

Posted: Mon Oct 13, 2008 9:02 am
by ChrisRLG
Downloads from other places - those with 'premods' or one click installs change the files so they are non-standard. That is why we do not support them, as we are unaware of what changes may have been made, which could easy add any problem you have experineced, and are asking a question on. For those type of installs you need to get support from the place you got the install from.

Downloads from phpBB.com (or the sourceforge open source system) are supported, except v2 will not be supported from the end of the year (its end of life has been announced).

phpBBv2 was not written for PHP5, PHP4 is no longer supported by its makers, so we too need to cease support for software which would need to run on unsupported operating systems, or operating systems it was not designed for.

Re: Closing phpBB 2.0 forums?

Posted: Mon Oct 13, 2008 1:55 pm
by espicom
Exbatts wrote:Does anyone know if the version 2.0 forums created with creatforum are going to be closed down? I cannot get any support from createforum right now.
This is the essence of your question, and the answer is, "They'll be supported on createforum.com as long as createforum.com wishes to support them." Since they are supporting the software themselves (as Chris points out in a round-about way), they can keep them going as long as they want, or shut them down tomorrow.

Personally, I am in no hurry to migrate to v3, because I do not have time right now to learn the differences in coding to add the modifications that my users want. There are a few v2 MODs that we use extensively that do not have viable v3 versions yet. I have three v3 boards running already, and those boards do not need anything other than stock configurations for now.

Not to mention the fact that v3 will be dropping support for PHP4 in the future, which is what our servers use...