Moderators permission problem

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
t0m|ta
Registered User
Posts: 49
Joined: Thu Apr 18, 2002 11:05 am
Location: Spain
Contact:

Moderators permission problem

Post by t0m|ta »

Hello

I posted this question quite a long time ago (with 2.03), but nobody answered me :-) Now that I know my way a little better may be I'll explain it better and some one can help me.

I'm having problem with permission, with moderators and with groups:

- Some users appear as moderators of a given forum spontaneusly

- If a user is moderator of a forum, I canot take the moderator staus away.

- Some times if a chosse a moderato for a forum, 7 or 8 appear as moderator in the same forum spontaneusly.

- Somer users appear spontaneusly as members of hidden groups

And it's getting worse. I have updated several times and the problem continues.

Can any one give a hint? I've take a look at the phpbb_auth_access table, but I dot know what group_id is, or how the auth_mod works. I also don't know what code/functions control this permissions.

¿Could anyone give a hint so I can start looking around to see i've I changed some thing very important or something. ¿Where does phpBB keep the information about who moderates what?

Thank you very much in advance :-)
t0m|ta
--
User avatar
Mav
Former Team Member
Posts: 2261
Joined: Wed May 15, 2002 9:19 am
Location: England
Contact:

Post by Mav »

moderator permissions are stored in the auth_access table (phpbb_auth_access)

the group_id can be a group or an individual user (you can match it up to the user/group in the phpbb_groups table). auth_mod is 1 if the user/group has moderator permissions and 0 if they don't.

are you using phpbb 2.0.6?
t0m|ta
Registered User
Posts: 49
Joined: Thu Apr 18, 2002 11:05 am
Location: Spain
Contact:

Post by t0m|ta »

Thank you very much, with that information i can start to track what has happened.

Actually I have not updated to 2.06 yet, I'm still on 2.04, I had this feeling that version 2.05 existence would be brief and I always wait a couple of weeks before updating. This way, when I update the little issues that always arise when a new version is released are solved already in these forums.

I'll be updating on monday next week, that's why I asked so I can solve this problem with the next version :-)

Thank you again for your help I'll be studing it and keeping you informed, as it it is a weird problem indeed :-)

Best regards
t0m|ta
--
Locked

Return to “2.0.x Support Forum”