Page 1 of 2

HELP PLEASE

Posted: Sat Aug 23, 2003 8:10 pm
by nra4ever
hi-

i screwed up my working phpbbs 204 when i tried to upgrade, so now i had to start over. i am uasing win98se, apache 2047, php,mysql.


when i click on install.php with iexplorer all i get is text. 8O
what is wrong?

Posted: Sat Aug 23, 2003 8:10 pm
by 7of12
sounds like apache isnt displaying php right

Posted: Sat Aug 23, 2003 8:12 pm
by nra4ever
AHAHA!!

cool- i just figured it out my slashes for....

LoadModule php4_module "c:/php/sapi/php4apache2.dll"
AddType application/x-httpd-php .php

were in the wrong direction-- :roll:

DOH! Thanks.

Posted: Sat Aug 23, 2003 8:13 pm
by 7of12
well the php files could be corrupt
i dont know how to reinstall php on apache as i dont use apache for my site

Posted: Sat Aug 23, 2003 8:30 pm
by nra4ever
ok 1 more problem-
this brings me back to how i screwed up originally-

i am now at the welcome to phpbb 2 installation screen and i get errors when i click on "start install" button


i have selected..

Language: English
database type: MySQL 4
method: Install

hostname: localhost
databasename: phpbb
username: sa
password: ****
prefix for tables: phpbb_

admin: myemail
domain: localhost
serverport: 80
scriptpath: /forum
admin username: one that i made up
admin pass word: one that i made up

here are the errors i am getting:


Warning: mysql_connect(): Can't connect to MySQL server on 'localhost' (10061) in C:\Program Files\Apache Group\Apache2\htdocs\forum\db\mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in C:\Program Files\Apache Group\Apache2\htdocs\forum\db\mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in C:\Program Files\Apache Group\Apache2\htdocs\forum\db\mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database

Posted: Sat Aug 23, 2003 8:41 pm
by A_Jelly_Doughnut
Perhaps your database server name is something other than localhost, or the database server is down.

Posted: Sat Aug 23, 2003 9:03 pm
by 7of12
makes it seem the site is hosted off your pc
so maybe you dont have mySQL installed on your pc

Posted: Sat Aug 23, 2003 9:04 pm
by nra4ever
how would i find out what it is?

Posted: Sat Aug 23, 2003 9:04 pm
by 7of12
i think it www.mysql.com
if not search on google.com for mySQL

Posted: Sat Aug 23, 2003 9:07 pm
by blueadmin
Did you get it as a pre set-up package, eg. easyPhp?, or did you install them all seperate, if the second you may not have started mysql.

You could also try the default mysql user:

Username: root
Pass: <blank>

Posted: Sat Aug 23, 2003 9:11 pm
by nra4ever
oh no- i am setting it up here on my pc- it is mysql.
im setting it up seperately- i dloaded each seperately- sorry if i am confused. once i get this working ill ghost this thing so it doesnt happen again.

let me try that- root suggestion. thanks...

Posted: Sat Aug 23, 2003 9:13 pm
by blueadmin
If root works, i would suggest getting phpMyAdmin and changing the password for it, it could be a security hole.

Posted: Sat Aug 23, 2003 9:15 pm
by nra4ever
ahhaa!!
the computer liked that much better. :D

user: root
pass:{ blank}

Thanks alot guys! damn you guys are smart-- haaha
cant wait to take an image to avoid this again. many thanks to all of you for helping me out.
:D

Posted: Sat Aug 23, 2003 9:17 pm
by blueadmin
Because of that I repeat that you should change your password for mysql, with phpMyAdmin, or some other kind of mysql editor.

Posted: Sat Aug 23, 2003 9:34 pm
by nra4ever
ok, i will. thanks again.

so i would need an editor though- you cant just change it with mysql alone? that surprises me.