Prety sure ive been Hacked..need help with Update!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
scrapdiggs
Registered User
Posts: 32
Joined: Thu Apr 29, 2004 5:23 am

Prety sure ive been Hacked..need help with Update!

Post by scrapdiggs » Thu Nov 27, 2008 7:30 am

Hey gang. We had a guy we had been using to do all of our PhpBB work in the past and he is no longer around.

We are looking for someone that can help us get updated from 2.0.1 to the latest.

We have about 6 mods and Easy mod installed. The forum has about 80k posts.

Looking to aquire someone to assist me, please PM me if your interested and have experience.

thanks!

Gene

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Prety sure ive been Hacked..need help with Update!

Post by ric323 » Thu Nov 27, 2008 8:03 am

What MODs do you have installed?
As support for phpBB2 ends in just a couple of weeks, you really should be looking at converting to phpBB3 ion the near future. See the pink box at the head of this page.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

scrapdiggs
Registered User
Posts: 32
Joined: Thu Apr 29, 2004 5:23 am

Re: Prety sure ive been Hacked..need help with Update!

Post by scrapdiggs » Thu Nov 27, 2008 8:10 am

ric323 wrote:What MODs do you have installed?
As support for phpBB2 ends in just a couple of weeks, you really should be looking at converting to phpBB3 ion the near future. See the pink box at the head of this page.

yea id love to get updated. hence this thread.

no serious mods. the Paypal one is most important to me.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Prety sure ive been Hacked..need help with Update!

Post by ric323 » Thu Nov 27, 2008 8:19 am

No MODS designed for phpBB2 will work directly in phpBB3, however many common phpBB2 MODs are built in to phpBB3.

Also note, rule-1j prohibits soliciting for people to work on your board. We are here to help you do any required work yourself.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

scrapdiggs
Registered User
Posts: 32
Joined: Thu Apr 29, 2004 5:23 am

Re: Prety sure ive been Hacked..need help with Update!

Post by scrapdiggs » Thu Nov 27, 2008 8:49 am

ric323 wrote:No MODS designed for phpBB2 will work directly in phpBB3, however many common phpBB2 MODs are built in to phpBB3.

Also note, rule-1j prohibits soliciting for people to work on your board. We are here to help you do any required work yourself.
Never worked on a board myself unfortunately. But im all ears for any migration tips!

I host with Lunarpages.com and they only do the 1 click auto install of Simple Machines now.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Prety sure ive been Hacked..need help with Update!

Post by ric323 » Thu Nov 27, 2008 9:02 am

All you need to know is how to create a database on your server (there should be a tool to do that on your website control panel), and how to upload files to your server with FTP.

Now, would you like to list exactly what MODs you have (that you still need), so we can see if phpBB3 has those features.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

scrapdiggs
Registered User
Posts: 32
Joined: Thu Apr 29, 2004 5:23 am

Re: Prety sure ive been Hacked..need help with Update!

Post by scrapdiggs » Thu Nov 27, 2008 4:08 pm

ric323 wrote:All you need to know is how to create a database on your server (there should be a tool to do that on your website control panel), and how to upload files to your server with FTP.

Now, would you like to list exactly what MODs you have (that you still need), so we can see if phpBB3 has those features.

Here is the problem. I cant log in to the admin panel to see what mods I have.


I also cant login to my hosting account now. Im not sure if its a Lunarpages error or what!

I emailed tech support to see if this is a server side erro.

Basically what is happening is all I can see is the forum but from 1yr ago. Not the current forum. I also do not have any admin right so I cant take the board down at all.

scrapdiggs
Registered User
Posts: 32
Joined: Thu Apr 29, 2004 5:23 am

Re: Prety sure ive been Hacked..need help with Update!

Post by scrapdiggs » Thu Nov 27, 2008 4:11 pm

Was able to log in under my wifes account. Non Admin.

This is the error that is being recieved now
DEBUG MODE

INSERT IGNORE INTO phpbb_search_wordlist (word_text, word_common) VALUES ('anyone', 0), ('difficulties', 0), ('post', 0), ('technical', 0)

Line : 235
File : functions_search.php

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Re: Prety sure ive been Hacked..need help with Update!

Post by espicom » Sat Nov 29, 2008 4:02 am

The error message you're getting indicates you have a problem with a table in the database, and a repair of that table will probably take care of it. Check out the first link in my signature......

At worst, you can drop the search tables and rebuild them from scratch using a MOD (such as this one).

But yes, you DO need to update. If nothing else, you can run the database update that is included in version 2.0.23, just prior to importing the data into phpBBv3. You may find that the MODs you are using are already included in v3; most of them that I use are there. But, two are not, so I'm staying with v2 until v3 gets these last two MODs I need.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Locked

Return to “2.0.x Support Forum”