[A] Installation Question-Main Page Link

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Kansas Viking
Registered User
Posts: 35
Joined: Thu Feb 27, 2003 4:05 am
Location: Salina, Kansas
Contact:

[A] Installation Question-Main Page Link

Post by Kansas Viking »

URL: See below
Template(s) used: Sub-Silver
Any and all MODs: None
Do you use a port of phpBB: Don't know
Version of phpBB: 2.0.04
Version of PHP: 4.3.2
Which database server and version: MySQL Version 3.23.56
Host: MySiteSpace
Did someone install this for you/who: No
Is this an upgrade/from what to what: New Installation
Is this a conversion/from what to what: No
Have you searched for your problem: Yes
If so, what terms did you try: Main Page url, url, index url
State the nature of your problem:


When I purchased my domain it came set up with several folders just like you would use setting up an html website. I uploaded the phpBB2 folder to the public_html folder so that I could access it through the web browser for set up. I got the board all installed finally. The problem is the address.

This is the acutal address of my web site http://www.norseboard.com. If you go there it has a standard html page with the welcome greeting put up by the host saying "Welcome to your new WebSite web hosting account. Everything is setup and ready for you to begin moving in!" There is no message board there.

But the message board can be found here http://www.norseboard.com/phpBB2/index.php, so my question is how do I get it to come up with the message board when you go to the actual address?

I didn't know if I put it in the wrong folder to start with or if I should have got rid of all the folders that were there and create something else to begin with. This is my first board set up and it has went fairly well. Any help or insight into what I did wrong and how to fix it would be appreciated and TIA.
User avatar
blueadmin
Registered User
Posts: 124
Joined: Wed May 14, 2003 4:58 pm
Location: Bradford, UK

Post by blueadmin »

Move ALL contents of phpBB2 including directories and files to your public_html folder.

Edit: Before you do that replace the path to phpBB2 with the new path.
Ho Ho Ho merry christmas
You Stuck? Read this before askinghere and here
Tim L
Registered User
Posts: 265
Joined: Sun Jun 29, 2003 7:15 pm
Location: I'll be where I'm at!

Post by Tim L »

You did everything just fine!

If you don't have a main site and you just want the boards as your site then you could put a meta redirect into a page called index.htm.

Put this in the head section:

Code: Select all

<meta http-equiv="refresh" content="1;URL=/PHPBB2/"

OR you could copy all the files from your PHBB2 directory (including folders) into your main root directory, and then delete your PHPBB2 directory. If you do this option don't do the redirect! Also, if you go with this option then you need to edit your config file.
The best way to escape from a problem is to solve it...
_________________
INSTALLING PHPBB
Kansas Viking
Registered User
Posts: 35
Joined: Thu Feb 27, 2003 4:05 am
Location: Salina, Kansas
Contact:

Post by Kansas Viking »

Tim L wrote: You did everything just fine!

If you don't have a main site and you just want the boards as your site then you could put a meta redirect into a page called index.htm.

Put this in the head section:

Code: Select all

<meta http-equiv="refresh" content="1;URL=/PHPBB2/"

OR you could copy all the files from your PHBB2 directory (including folders) into your main root directory, and then delete your PHPBB2 directory. If you do this option don't do the redirect! Also, if you go with this option then you need to edit your config file.


Thanks for all the replies. blueadmin also mention to replace the path to phpBB2 with the new path. Could you guys tell me exactly where and how to do that? Thanks again.
Stefan Koopmanschap
Former Team Member
Posts: 7388
Joined: Sun Oct 28, 2001 9:47 am
Location: Woudenberg, Netherlands
Contact:

Post by Stefan Koopmanschap »

General Admin => Configuration is where you can find this.
Kansas Viking
Registered User
Posts: 35
Joined: Thu Feb 27, 2003 4:05 am
Location: Salina, Kansas
Contact:

Post by Kansas Viking »

wanrecords wrote: General Admin => Configuration is where you can find this.


Found it. I was looking in the wrong place. Thanks a million!
Locked

Return to “2.0.x Support Forum”