Cannot access my site at all

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Count Karnstein
Registered User
Posts: 17
Joined: Mon Jun 30, 2008 11:57 pm

Cannot access my site at all

Post by Count Karnstein » Thu Nov 27, 2008 9:06 pm

Ok, I tried installing a new theme (a xmas one), tried setting it as the default, and now I cannot access my site at all, not even the admin area. All I get when go to the page is this:

phpBB : Critical Error

Could not open xmaxtheme template config file

DEBUG MODE

Line : 503
File : functions.php

Help!

Also, I am literally computer illiterate and will need step-by-step explanations. Me and computers mix like oil and water so be patient.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Cannot access my site at all

Post by ric323 » Thu Nov 27, 2008 9:30 pm

NEVER set a new theme as the "forced default" until you have tested it!
You have probably made a mistake naming the folder you put it in. You MUST use the correct name, and case is important.
(i.e. the folder name must match the name of the .cfg and .css files inside the folder. e.g. "subSilver" won't work if you put it into a folder called "subsilver" or "subSilver2")

If you can't fix it, then this script will let you get back to the default theme: Knowledge Base - Set subSilver as the default template
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Count Karnstein
Registered User
Posts: 17
Joined: Mon Jun 30, 2008 11:57 pm

Re: Cannot access my site at all

Post by Count Karnstein » Sat Nov 29, 2008 12:49 am

I can't access the admin panel at all. I looked at the link you posted, but the very first step confused me:

"Create a reset_template.php file with the following:"

How do I create a reset_template.php file? I have no clue whatsoever how to do that or even which program I use to do that.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69361
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Cannot access my site at all

Post by KevC » Sat Nov 29, 2008 12:51 am

It's just a plain text file.

Open notepad or wordpad
Paste that code in
Save it as reset_template.php
Upload it to the site and continue the instructions.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Count Karnstein
Registered User
Posts: 17
Joined: Mon Jun 30, 2008 11:57 pm

Re: Cannot access my site at all

Post by Count Karnstein » Sat Nov 29, 2008 12:58 am

Also, I just got notification that a spam account was created on my site just now. how is that possible if even I cannot access it? Does that mean anything relevant to my problem?

Count Karnstein
Registered User
Posts: 17
Joined: Mon Jun 30, 2008 11:57 pm

Re: Cannot access my site at all

Post by Count Karnstein » Sat Nov 29, 2008 1:04 am

OK, thanks. I ran the file, I can now access the site. However, it only allows me to use subsilver as a template. How do I get it back to the other themes I used to have? They don't even show up on the drop down list.

rollindts
Registered User
Posts: 13
Joined: Sun Jun 15, 2008 1:22 am

Re: Cannot access my site at all

Post by rollindts » Sat Nov 29, 2008 7:11 am

as long as the folders still exist in the templates folder then you can goto your admin control panel and under styles admin click on "add". you should see your templates in there and then click install to add it.

Locked

Return to “2.0.x Support Forum”