Problems with treads which cover many pages

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Dalixam
Registered User
Posts: 87
Joined: Wed Jul 11, 2001 4:28 pm

Problems with treads which cover many pages

Post by Dalixam »

I have a few threads in my forum which are 15-30 pages, but there is a problem with these big threads.

Scenario: Someone posts a reply on a page 14, but that reply trickers page 15 to be created, but this is not shown in the list of threads. It still says "Goto page 1...12, 13, 14". Page 15 is not shown and the only way to get to it is pressing the "Last post" link.

When another new reply is posted, THEN page 15 shows up, but the original post which should have been on page 15 is in limbo somewhere.

Is there a solution to this problem or is it a bug? If it is a bug, should I then report it on Sourceforge or wait until phpbb.com is up again?
Dalixam
Registered User
Posts: 87
Joined: Wed Jul 11, 2001 4:28 pm

Post by Dalixam »

*Shameless bump*
jbay
Registered User
Posts: 18
Joined: Tue Apr 02, 2002 2:27 pm
Contact:

Post by jbay »

I've seen this bug (many times), as well, and it's a major pain.

For some reason (sql crashes, maybe?) the counters & pagination get off. The workaround I've been using, and it's a total kludge, is to move the entire thread to a another forum, use the 'moderate' function to 'split posts' -- select all of the posts one by one -- and move them back to the original forum under the same or slightly different title. It spits out a heart-stopping erorr, but it works.

Then I go back to the 'temporary' forum and delete the old topic title, which will now have 0 posts in it.

Nice kludge, eh?

If anyone has a script to fix this, I'd appreciate it. A Lot.
User avatar
primedomain
Former Team Member
Posts: 25944
Joined: Sat Dec 15, 2001 10:23 am

Post by primedomain »

There is already a bug report @ sourceforge.net ("Pagination broken"). You may check if that's the same problem and maybe add some comments.
http://sourceforge.net/tracker/index.ph ... tid=107885
jbay
Registered User
Posts: 18
Joined: Tue Apr 02, 2002 2:27 pm
Contact:

Post by jbay »

thanks. Next time I catch a thread doing it, I'll rip into the database and see if I can figure out what data has gotten whacked.

it has been behaving itself recently (I have now jinxed myself), and we haven't recently had any big sql problems...so I'm thinking my cause/effect theory is right.

I hope somebody out there is working on a variety of end-user-friendly database utilities, like something to purge & rebuild & compact the search lists, reset the counters, etc...somebody with more of a clue than I have.
Dalixam
Registered User
Posts: 87
Joined: Wed Jul 11, 2001 4:28 pm

Post by Dalixam »

Oh ok, I'm glad I'm not the only one experiencing this :)
Thanks for the info!
Locked

Return to “2.0.x Support Forum”