bb code fix

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Indeed

Post by deny »

Indeed!

does not work :

Code: Select all

[url=http://www.site.com]site link[/url]
crazyd1415
Registered User
Posts: 63
Joined: Mon May 13, 2002 3:41 am

Post by crazyd1415 »

kawaja, can you post your file so i can see how you applie your code. or could you explain what you did with the parts that did not show up?
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

Okay, I'll try and clear some things up, the Support Team provides limited support for older versions for obvious reasons. First off, we cannot keep every single version somewhere for us to look at and help people with ... Secondly, it is not in our best interest to help people with outdated software. What if someone says "my 2.0.x board has hacked!!!!11" Well, I'm sorry, but the latest version is 2.0.6. We can help you if you have 2.0.5, but nothing older. Please upgrade. If you have MOD's, contact the authors and ask them if they have updated versions. The patch method is specifically for heavily MODded boards by the way, and works quite well.
Proven Offensive Security Expertise. OSCP - GXPN
User avatar
kawaja
Registered User
Posts: 17
Joined: Wed Apr 16, 2003 5:20 pm

Post by kawaja »

thanks for chiming in Techie-Micheal.
Techie-Micheal wrote: Okay, I'll try and clear some things up, the Support Team provides limited support for older versions for obvious reasons. First off, we cannot keep every single version somewhere for us to look at and help people with ... Secondly, it is not in our best interest to help people with outdated software. What if someone says "my 2.0.x board has hacked!!!!11" Well, I'm sorry, but the latest version is 2.0.6. We can help you if you have 2.0.5, but nothing older.


what? the announcement was clear about which versions were affected by this...starting at 2.0.4 and continuing till 2.0.6.

the team needs to offer a fix for 2.0.4, its not that old. if you need that version to look at, ive still got my tarball. i installed (and mod'd it up a bunch) 2.0.4 back in april when it was the latest version.

so, the team's official word is "no fix for 2.0.4"? i want that to be clear please, maybe i misunderstood.
your welcome.
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

kawaja wrote: the team needs to offer a fix for 2.0.4, its not that old. if you need that version to look at, ive still got my tarball. i installed (and mod'd it up a bunch) 2.0.4 back in april when it was the latest version.

so, the team's official word is "no fix for 2.0.4"? i want that to be clear please, maybe i misunderstood.
I'll see if I can't dig up something for 2.0.4. :) I apologize for the misunderstanding. :(
Proven Offensive Security Expertise. OSCP - GXPN
User avatar
kawaja
Registered User
Posts: 17
Joined: Wed Apr 16, 2003 5:20 pm

Post by kawaja »

crazyd1415 wrote: kawaja, can you post your file so i can see how you applie your code. or could you explain what you did with the parts that did not show up?


yikes, 26k i believe....i will provide a link to it, txt style of course.

[edited out url, not needed]

yeah, maybe some of us are "doing it wrong" i guess.
Last edited by kawaja on Fri Sep 12, 2003 7:15 pm, edited 1 time in total.
your welcome.
User avatar
kawaja
Registered User
Posts: 17
Joined: Wed Apr 16, 2003 5:20 pm

Post by kawaja »

thanks for posting that here deny, worked for me too...sigh.
your welcome.
psycho2000
Registered User
Posts: 6
Joined: Sun Jun 01, 2003 7:27 am

Post by psycho2000 »

ditto....
Die_H2k
Registered User
Posts: 121
Joined: Sun Mar 17, 2002 6:25 pm
Contact:

Post by Die_H2k »

its easy to upgrade to latest version even if you heavily modded
if you have shell access then you can patch it
and now acyd has posted changed code 2.0.4 to 2.0.5 and 2.0.5 to 2.0.6
and phpbb posted changed files only

only take you about 3 hours of your time ;)

or you can reinstall again ;). only take a whole night ;) reinstall but the post still there.. and there is easymod so installing mod only take about 3 minutes but you must remember what mod that you install on your old board and install it again so no other conflict

and its easy to change the mod that not yet easymod compatible to easymod compatible

the pain & humalition ;) is worthed.

like my board now just reinstalling from fresh 2.0.6 (before that i use 2.0.4 upgrade to 2.0.5 and 2.0.5 code by acyd)
and now i have 5 language, over 20 mod (80 % of them installed with easymod) and 3 templates and ofcourse all of the old data is still there

so what im saying here, all of that need works and need time
but if you enjoying it, you will miss it ;)

dont wait for 2.2 even they already milestone 9 lol ;)
just upgrade to recent version and try it first at your localhost (your computer). and make yourself happy and your user happy too ;)
Image
Birillo
Registered User
Posts: 15
Joined: Sat Sep 20, 2003 10:59 am

Post by Birillo »

Die_H2k wrote: its easy to upgrade to latest version even if you heavily modded
if you have shell access then you can patch it
and now acyd has posted changed code 2.0.4 to 2.0.5 and 2.0.5 to 2.0.6
and phpbb posted changed files only

I have founded only doc for 2.05 to 2.06, where can I find 2.04 to 2.05?!?!
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

Post by Bradman »

I think I found the 204 to 205 at phpbbhacks. Hmm, yes, I seem to remember the changes for each file in a separate post. I had to copy from the forum and paste it into my editor, then saved the whole thing.

I think I've decided not to upgrade. In my opinion everything is just too unpredictable. I downloaded the changed files for 205 and was getting ready to do that and before I knew it, 206 came out. So I'd have to do the 204 to 205, and then the 205 to 206. This will make many of my about 80 mods no longer work. So I'd have to individually update all of the affected mods. I can't imagine how long it would take to figure out exactly which ones were no longer working, locate and download the updated versions of those mods, if available, and then do all of that editing, uploading, and testing. And then I'd have to do all of that all over again because you know there would be a 207 out right after doing all that upgrading.
Die_H2k
Registered User
Posts: 121
Joined: Sun Mar 17, 2002 6:25 pm
Contact:

Post by Die_H2k »

why dont you install a webserver on your computer
and no need to testing it online again ;) (uploading and trying online)
you can try apache2triad its loaded with many stuff and no need to many configuring or you can install yourself by downloading the apache, php, mysql and ofcourse phpmyadmin.

anyway i think mod for 2.0.4 are work for 2.0.6
and if you already upgrade to 2.0.6 when you want to upgrade again
yes its still need to edit but the change wont be that much ;)
Image
Locked

Return to “2.0.x Support Forum”