changed service providers unable to restore from back up

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
aardil
Registered User
Posts: 11
Joined: Fri Aug 29, 2008 1:41 am

changed service providers unable to restore from back up

Post by aardil » Tue Dec 23, 2008 5:37 am

Your board's URL: http://www.gretnabmx.com
Version of phpBB2: 2.0.27
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? fresh
Did you use an automated wizard provided by your host to install phpBB? yes
MODs you have installed:
When the problem started:
Your level of expertise (be honest): newbie

try to make a long story short here.
My original service provider was having hacker issues.
They started implementing a bunch of changes and things went down hill from there.
Before I did a fresh install (a couple of weeks ago) I used the back up data from the admin. to create a file called localhost.sql and saved it to my PC.
Converted to phpBB3, everything looked good and was working, next day all the posts were gone.
The topics were there, the titles of the posts were there but if you clicked on a topic you would get a 500 error.
I came to the boards here and got a few ideas on what was going on, but no help to speak of from my service.
In fact when I finally gave up and switched services, they had it where going to the boards gave an instant 500 error and FTP was screwed to where it was useless to try and upload anything.

Which brings me to where I am now.
I installed a fresh phpBB3.0.4 on new server
it works but I have it blocked because I am trying to import / restore my old data before it goes live.
Tried restoring from my localhost.sql file and it gave me errors about the names were wrong ( since it is now on a new server the names dont match.

Tried install fresh copy of phpbb2.0.27 and it works but I get the same errors about names being wrong.

Is there a way to import the data into phpbb2 just the files I want to be recovered?

I would like to recover the old forum layout, posts and topics
and the users and passwords

I have involved the new server tech support and they said they migrated the old info into the data base, but I doent look like that is going to work either. board has no topics or post.

any help?
thanks aardil

User avatar
ric323
Former Team Member
Posts: 22908
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: changed service providers unable to restore from back up

Post by ric323 » Tue Dec 23, 2008 5:45 am

First, we need to establish if your backup file is complete.
A common issue is the web server timing out when you use the backup function built into the ACP.
Please post the last 20 lines of your backup file here, so we can see if it fiinshed the backup correctly.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Locked

Return to “2.0.x Support Forum”

Who is online

Users browsing this forum: No registered users and 22 guests