Cant signup new user or change profile

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
foe
Registered User
Posts: 21
Joined: Thu Apr 11, 2002 1:19 am
Contact:

Cant signup new user or change profile

Post by foe » Tue Apr 23, 2002 1:37 am

Could not update users table

and Could not insert into users table

are errors I get when i try to change profiles, or get new users to signup, I dont know whats wrong, tried fixing it myself, no luck, I think it happened right after update or maybe a little little not sure but prob right after update. Does anyone know what I need to do to fix the problem, couldnt get new members to join the board.

foe
Registered User
Posts: 21
Joined: Thu Apr 11, 2002 1:19 am
Contact:

Post by foe » Tue Apr 23, 2002 1:47 am

My Config file
<?php

//
// phpBB 2.x auto-generated config file
// Do not change anything in this file!
//

$dbms = "mysql";

$dbhost = "localhost";
$dbname = "foe_board";
$dbuser = "foe_board";
$dbpasswd = "pass";

$table_prefix = "phpbb_";

define('PHPBB_INSTALLED', true);

?>


Also the url of board is http://essayfarm.com/boards

and posting messages and stuff works fine. I also tried manually inserting into database and that works fine, also tried installing again like in essayfarm.com/bb3 same problem

Greven
Registered User
Posts: 69
Joined: Fri Aug 10, 2001 4:25 pm
Contact:

Post by Greven » Tue Apr 23, 2002 1:55 am

Don't give your password. :D

foe
Registered User
Posts: 21
Joined: Thu Apr 11, 2002 1:19 am
Contact:

Post by foe » Tue Apr 23, 2002 1:57 am

I changed it buddy ;), but do you know whats wrong?

Greven
Registered User
Posts: 69
Joined: Fri Aug 10, 2001 4:25 pm
Contact:

Post by Greven » Tue Apr 23, 2002 1:59 am

What does the error say?

ShadowRaven
Registered User
Posts: 929
Joined: Tue Apr 16, 2002 5:33 pm
Location: Kansas
Contact:

Post by ShadowRaven » Tue Apr 23, 2002 2:14 am

foe posted the error earlier:
Could not update users table

Could not insert into users table

Greven
Registered User
Posts: 69
Joined: Fri Aug 10, 2001 4:25 pm
Contact:

Post by Greven » Tue Apr 23, 2002 2:15 am

I don't know... SQL is my downfall.

ShadowRaven
Registered User
Posts: 929
Joined: Tue Apr 16, 2002 5:33 pm
Location: Kansas
Contact:

Post by ShadowRaven » Tue Apr 23, 2002 2:19 am

couple of questions:
  • Have you recently upgraded or installed the board?
  • Are you running 2.0?
  • Has this table been updated successfully before?
  • Has you or your host made any recent changes with the database?
  • Do you have a recent back-up of the db from when this worked (if ever)?

foe
Registered User
Posts: 21
Joined: Thu Apr 11, 2002 1:19 am
Contact:

Post by foe » Tue Apr 23, 2002 2:40 am

  • Have you recently upgraded or installed the board? Yes just said this prob jsut after update
  • Are you running 2.0?Yes final version
  • Has this table been updated successfully before?Just updated and using now, cant go back becuase lots of new posts since pdate
  • Has you or your host made any recent changes with the database?Not that i know off, Im on hostrocket, and dought they would
  • Do you have a recent back-up of the db from when this worked (if ever)?Yes, but do not want to go back becuase lots of new posts from existing members.

ShadowRaven
Registered User
Posts: 929
Joined: Tue Apr 16, 2002 5:33 pm
Location: Kansas
Contact:

Post by ShadowRaven » Tue Apr 23, 2002 2:43 am

If you just restore the user table form the backup copy, that should rmove any corruption that occured in that table (which looks like it is probably the culprit). Leave the other tables alone, and you should keep the posts.

foe
Registered User
Posts: 21
Joined: Thu Apr 11, 2002 1:19 am
Contact:

Post by foe » Tue Apr 23, 2002 2:30 pm

The only backup copy I have is from phpbb 1.4 Im going to do a seperate update and then copy those over is the user table the only one I need to copy or do i need to copy like user_groups and other tables as well.

gameofhit
Registered User
Posts: 986
Joined: Sun Oct 07, 2001 10:29 pm
Location: Michigan Tech
Contact:

Post by gameofhit » Tue Apr 23, 2002 2:59 pm


Grishin
Registered User
Posts: 7
Joined: Sat Apr 13, 2002 2:11 pm
Contact:

Post by Grishin » Fri Apr 26, 2002 12:26 pm

gameofhit wrote: Did you try this?

http://www.phpbb.com/phpBB/viewtopic.php?t=10263


At me similar problems. I tried that you offer. All problems have remained. What to me to do?
My forum: http://forum.spas.org.ua

Locked

Return to “2.0.x Support Forum”