Username Disallowed- what username!?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Username Disallowed- what username!?

Post by The Other Guy » Sun Nov 16, 2003 4:37 am

At my forums, which can be found here:
http://www.dotmanandbob.com/forums
or here:
http://16.webmasters.com/*dotmanandbob. ... ocs/forums
Users cannot choose a username when they sign up for an account, and their username is not displayed in their profiles. Then, whenever they try to edit their profile or register, the error "Username is Disallowed" appears, preventing either action.

What do I do? Please help me. I've had this problem on two other forums on other servers, and I though it was the fault of a template (subInvert) I was using. But now I'm using a different style, and the problem has shown up again! What's my problem?
Er... yeah.

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Sun Nov 16, 2003 9:39 am

For support request please use the draft here :-)
http://www.phpbb.com/phpBB/viewtopic.php?t=128123
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Post by The Other Guy » Mon Nov 17, 2003 10:56 pm

URL: http://www.dotmanandbob.com/forums
Template(s) used: subDotman (based on subSilver)
Any and all MODs: N/A- the problem occured before any mods were installed
Do you use a port of phpBB: no
Version of phpBB: 2.0.6 (newest version, I think this is it)
Version of PHP: 4.3.3
Which database server and version: MySQL (is this what you mean?)
Host: webmasters.com
Did someone install this for you/who: I did
Is this an upgrade/from what to what: full install
Is this a conversion/from what to what: nope
Have you searched for your problem: no
State the nature of your problem: The "username" field is left off of the registration (and profile, when username changes are allowed). This prevents username changes by the user (when allowed by the admin) and registrations.
Do you have a test account for us: Nope.
Last edited by The Other Guy on Tue Nov 18, 2003 2:40 am, edited 1 time in total.
Er... yeah.

The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Post by The Other Guy » Tue Nov 18, 2003 2:35 am

Sorry for the mispost. Please help if you can.
Er... yeah.

The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Post by The Other Guy » Wed Nov 19, 2003 12:14 am

Come on, you guys! I'm searching for this again, but so far it hasn't helped.

I found 2 solutions- the first was setting "Annonymous"'s ID to -1, but this was ok

subSilver didn't work either...

I don't know the problem!
Er... yeah.

The Other Guy
Registered User
Posts: 33
Joined: Mon Mar 24, 2003 3:55 am
Location: Here
Contact:

Post by The Other Guy » Fri Dec 05, 2003 3:07 am

I think I found a solution! I reinstalled my forums, changing the database prefix, and now I have no problems with this. Try it, and tell me if this works for the rest of you.
Er... yeah.

Locked

Return to “2.0.x Support Forum”