Page 1 of 1

Avatar uploading errors?

Posted: Sat Dec 13, 2003 7:48 pm
by L0cke
I've searched for this, couldn't find the answer.. so here it goes.

Recently my forum has stopped allowing people to upload their avatars from their own computer. Off-site uploading is fine, but uploading it from your own computer it will give you the error saying the file size is too big (bigger than the max avatar file size limit). The thing is, the file size isn't too big..

What's going on?

Posted: Sat Dec 13, 2003 10:41 pm
by primedomain

Posted: Sun Dec 14, 2003 6:28 am
by L0cke
URL: www.forum-central.com
Template(s) used: modified subSilver
Any and all MODs: Couldn't even begin to list them all.
Do you use a port of phpBB: No
Version of phpBB: 2.0.2 (though it says .5 or .6)
Version of PHP: I forget
Which database server and version: Uh
Host: www.tiora.net
Did someone install this for you/who: No
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: No
Have you searched for your problem: Yes
If so, what terms did you try: upload avatar, avatar errors, avatar bugs
State the nature of your problem: Suddenly, after 1.5 years of working properly, I can no longer upload an avatar from my desktop to my forum (using upload in profile). No, my server space isn't full. The error received is "the file size is larger than 35KB" when the file size is no where near that size.
Do you have a test account for us: Ask if you need it.

Posted: Wed Dec 17, 2003 12:34 pm
by renaissancehuman
This problem suddenly developed for me as well. It seemed to coincide with my upgrade to 2.0.6 from 2.0.4, although the avatar problem didn't become known until last night. The upgrade was a week or two ago.

I too am unable to upload certain files as avatars, with a "file too big" error message being generated, even though the file I'm trying to upload is 6k less than the max. limit.

To thicken the plot a little, another admin and one of the users are having the same problem, but are getting a different error message, theirs saying to contact the system administrator (me), referencing line 592 in admin_users.php. (Same deal, but from their perspective, program-wise, instead of the admin's.)

To thicken the plot a little further, I rolled back to 2.0.4 - did a clean install - and restored my database. The upload problem is still there, and it still reads "2.0.6" in the copyright stuff at the bottom, making me wonder if something in the upgrade to 2.0.6 changed something in the database which is affecting avatar uploads, although I did hack the config table, and everything looked exactly the way it should be.

URL: http://www.theoreticallyphilosophy.com
Template(s) used: Chronicles
Any and all MODs: n/a
Do you use a port of phpBB: No
Version of phpBB: 2.0.4 (with possibly a few remnants of 2.0.6)
Version of PHP: 4.3.4
Which database server and version: MySQL 3.23.54
Host: WorldZone
Did someone install this for you/who: No
Is this an upgrade/from what to what: 2.0.6 from 2.0.4, and also 2.0.4 clean install with a few remnants of 2.0.6 from the database
Is this a conversion/from what to what:
Have you searched for your problem: Yes.
If so, what terms did you try: Tried checking PHP code, in the SQL data, by reinstalling an older version, by altering parameters, etc.

State the nature of your problem: See post above.
Do you have a test account for us: Feel free to sign up for one at the URL given above.

Posted: Wed Dec 17, 2003 12:48 pm
by renaissancehuman
Addendum: I managed to hack the SQL database to give myself and the user our images back, but that's not exactly the *best* solution. :)

Posted: Wed Dec 17, 2003 7:55 pm
by L0cke
This is what I had to resort to, going through the SQL DB to give the avatars needed. It can also link offsite avatars (by URL, then uploading to server from the URL) just fine.

My url, forum-central.com, is down for a few days. The alternate (though less pretty, with broken images as I've not prepared it for this URL) is www.vieuphoria.com/forum/community.php