Problems with installation on PostgreSQL

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
jaeger_m
Registered User
Posts: 21
Joined: Mon Sep 03, 2001 11:29 am
Location: Croatia
Contact:

Problems with installation on PostgreSQL

Post by jaeger_m »

An error has occured during installation


An error occured trying to update the database
ERROR: pg_aclcheck: class "phpbb_disallow_id_s" not found


What can I do?

dougk_ff7
Former Team Member
Posts: 1191
Joined: Fri Jul 06, 2001 3:17 am
Location: I dunno, I've lost it.
Contact:

Post by dougk_ff7 »

Doesn't go here. Moving.
dougk_ff7.... stand by for sig! oooh! wow.

theFinn
Founder and ex-Contributor
Posts: 1767
Joined: Tue Jul 03, 2001 7:58 pm
Location: Edmonton, AB, Canada
Contact:

Post by theFinn »

Ya, thats a bug in the schema file. If you get the latest CVS is should be fixed IIRC.

Otherwise just do a search and replace on the postgres_schema.sql file

Search for: phpbb_disallow_id_s
Replace with: phpbb_disallow_id_seq

:)
James 'theFinn' Atkinson
Founder & ex-Contributor
http://www.thefinn.net

Locked

Return to “2.0.x Support Forum”