Help!Problems with postgres 4.3.3 don't hapen in 4.3.2

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
armindo
Registered User
Posts: 18
Joined: Mon Jan 27, 2003 3:15 pm
Contact:

Help!Problems with postgres 4.3.3 don't hapen in 4.3.2

Post by armindo »

Hi

Need urgent! Help....


My index.php returns the following error:

"Warning: pg_connect(): Cannot create new link. Too many open links (0). in /home/armindo/public_html/forum/db/postgres7.php on line 79
phpBB : Critical Error

Could not connect to the database "

It started this error when i upgraded the server to fedora core 1 with postgres 4.3.3. Before it didn't give any errors.


Can anyone help me?!


My forum page http://www.iseg.utl.pt/forum


thank you

Stefan Koopmanschap
Former Team Member
Posts: 7388
Joined: Sun Oct 28, 2001 9:47 am
Location: Woudenberg, Netherlands
Contact:

Post by Stefan Koopmanschap »

it sounds like a problem with the postgres installation that does not allow any links (?)

you might want to check the postgres configuration and documentation.

R45
Registered User
Posts: 2830
Joined: Tue Nov 27, 2001 10:42 pm

Post by R45 »

Check your maximum connection setting in your postgresql.conf file. I assume you mean PostgreSQL 7.4?

armindo
Registered User
Posts: 18
Joined: Mon Jan 27, 2003 3:15 pm
Contact:

Didn't work

Post by armindo »

:(

R45
Registered User
Posts: 2830
Joined: Tue Nov 27, 2001 10:42 pm

Re: Didn't work

Post by R45 »

armindo wrote: :(

Why :( ? I answered you.

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

The post subject "didn't work" ;)
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

R45
Registered User
Posts: 2830
Joined: Tue Nov 27, 2001 10:42 pm

Post by R45 »

Ah sorry, missed that

Looking at the C source for the postgresql extension

Code: Select all

 			if (PGG(max_links)!=-1 && PGG(num_links)>=PGG(max_links)) {
 				php_error_docref(NULL TSRMLS_CC, E_WARNING,
-								 "Cannot create new link. Too many open links (%ld).", PGG(num_links));
+								 "Cannot create new link. Too many open links (%ld)", PGG(num_links));
 				goto err;
 			}
What is your pgsql.max_links setting in your php.ini file? By default it's -1, which is unlimited. Check that, adjust it to -1 if need then restart your webserver.

armindo
Registered User
Posts: 18
Joined: Mon Jan 27, 2003 3:15 pm
Contact:

although it isn't working yet thank u for all support

Post by armindo »

It already -1 (unlimited). That's the wierd part


So i'm still offline... and without ideas

R45
Registered User
Posts: 2830
Joined: Tue Nov 27, 2001 10:42 pm

Post by R45 »

Hmm, try changing it to a positive value then. Try 10 and see.

armindo
Registered User
Posts: 18
Joined: Mon Jan 27, 2003 3:15 pm
Contact:

Working

Post by armindo »

The !"##%$&/)/)(/=&&$ upgrade left my old PHP.INI file the fucking problem was a question of overwriting the php.ini with the new one.....


Man i feel so stupid.... Sorry guys and once again THANK U!!!!

HySpeed
Registered User
Posts: 9
Joined: Mon Dec 08, 2003 9:25 pm

Post by HySpeed »

I get the same error.
I just upgraded the sytem from Red Hat to Fedora.
During the upgrade I got a message that the database could not be migrated,
so I renamed the folder and started all over.

I've created the postgreSQL database and checked the php.ini file, the value is set to -1.

Any ideas?

thanks

R45
Registered User
Posts: 2830
Joined: Tue Nov 27, 2001 10:42 pm

Post by R45 »

HySpeed wrote: I get the same error.
I just upgraded the sytem from Red Hat to Fedora.
During the upgrade I got a message that the database could not be migrated,
so I renamed the folder and started all over.

I've created the postgreSQL database and checked the php.ini file, the value is set to -1.

Any ideas?

thanks

Replace your php.ini with a new one from the PHP distribution. That usually cures it. This is a problem with redhat leaving old php.ini files intact.

HySpeed
Registered User
Posts: 9
Joined: Mon Dec 08, 2003 9:25 pm

Post by HySpeed »

Thanks.

My friend looked at it and determined that he only needed to comment out the "extensions=" lines in php.ini and restart the daemon.

Yippee!

Locked

Return to “2.0.x Support Forum”