Page 1 of 3

Parse errors in template.php, sessions.php and mysql4.php

Posted: Mon Jan 05, 2004 11:35 pm
by zeroK
There currently seems to be a problem with some hosts running cPanel and PHP 4.3.3. If you get the following erorrs ...

Code: Select all

Parse error: parse error in /.../includes/template.php on line 356 

Parse error: parse error in /.../includes/sessions.php on line 205 

Parse error: parse error in /.../db/mysql4.php on line 103 

Fatal error: Cannot instantiate non-existent class: sql_db in /.../includes/db.php on line 60
... please contact your host's support and make them aware of this problem :-) According to some reports downgrading or upgrading PHP can solve this problem.

For further details please read this topic:
http://www.phpbb.com/phpBB/viewtopic.php?t=162665

Note: Please keep in mind, that we don't support the cPanel installation of phpBB here. Please contact your host if you notice any problem with your installation.

Posted: Tue Jan 06, 2004 12:05 pm
by Slow Joe
Great information. I've sooo been there before.

Posted: Sun Feb 22, 2004 6:21 am
by Rebos
Would this be effecting installation process on phpbb also? I recently deleted all my sql and my files for my pbpBB board to reinstall a new one and here is what I get. Here is what I get when I attempt to do the install by typing mysite.com/forum/phpBB2.install/install.php .

Parse error: parse error in mysite.com/forum/phpBB2/install/install.php on line 813

My host is 1and1 if that helps.

Posted: Sun Feb 22, 2004 8:25 pm
by A_Jelly_Doughnut
No, it would not, as the installation isn't used on CPanel installed boards ;)

Posted: Mon Mar 08, 2004 7:53 pm
by cazny
what about this?

Parse error: parse error in /home/webmaste/public_html/viewtopic.php on line 422

Posted: Mon Mar 08, 2004 9:32 pm
by wilff
Strange I've just had this parse error, so I reloaded an old viewtopic.php, wasnt this one updated recently....works ok again now??

Posted: Mon Mar 08, 2004 10:09 pm
by A_Jelly_Doughnut
Both of you: You probably b0rked something with the latest security fix (if you applied it)

Posted: Mon Mar 08, 2004 10:10 pm
by A_Jelly_Doughnut
Both of you: You probably b0rked something with the latest security fix (if you applied it)

Posted: Tue Mar 09, 2004 12:32 pm
by Rebos
I figured out my problem in this case. Being first time I installed it I followed directions exactly. Second time was on easyphp so it was extremely easy. Then third I tried to install it like easyphp again. That's where my problem started. Needless to say I never messed with CHMOD. :oops:

Posted: Thu Mar 18, 2004 2:17 pm
by Mudwalker
Does this error fall under this category?

Parse error: parse error in /..../..../..../..../gruntbunker.com/phpBB2/includes/bbcode.php(61) : eval()'d code on line 7

It only shows on one topic in my forum and I have searched this forum for information but have been unsuccessful.

How can I get this fixed? Would deleting the topic solve it?

Any advice would be greatly appreciated.

Posted: Thu Mar 18, 2004 9:44 pm
by catfish109tc
I have the same type of error, but on line 1 showing in one of my posts. I am curious as to what I can do to fix it.

Posted: Thu Mar 18, 2004 9:59 pm
by catfish109tc
Mudwalker,

Try re-uploading your bbcode.tpl file. I did it and the error message dissappeared.

Hope it works for you!

Posted: Thu Mar 25, 2004 1:44 am
by brianru
i have also been having a parse error but one in my index.php file. Which is really annoying cause I can't access my forums at all! Sadly this is my 3rd. The others I have fixed by replacing the file with a new copy of it. Is this a bug that will be fixed in 2.2?

Posted: Fri Mar 26, 2004 8:44 am
by amagab
I get the messag too but when trying to do a search:

Parse error: parse error in /usr/www/user/.../forum/search.php on line 692

Someone please help?

Below is code for lines above and below line 692:
(line 692 in red)

if ( $search_id )
{
$sql = "SELECT search_array
FROM " . SEARCH_TABLE . "
WHERE search_id = $search_id
AND session_id = '". $userdata['session_id'] . "'"
if ( !($result = $db->sql_query($sql)) )
{
message_die(GENERAL_ERROR, 'Could not obtain search results', '', __LINE__, __FILE__, $sql);
}

Thanks!

Posted: Sat Mar 27, 2004 1:24 am
by amagab
Anyone?????? Need help with post right above this one. Thanks!

:?: :?: