Rebuild search index problems

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

Rebuild search index problems

Post by joefish » Sat Jan 17, 2004 11:55 am

When I try to rebuild my search index:
Could not insert new word matches

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'is Alucard, im a hopeful writer from New Zealand and wuld just

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT hello everyone, my name is Alucard, im a hopeful writer from New Zealand and wuld just like to say hello. hopefully i can post part of my short story on this site. hopefully, word_id, 0 FROM phpbb_search_wordlist WHERE word_text IN ('saying')

Line : 249
File : /home/jfish/public_html/community/includes/functions_search.php


How do I fix this?

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Sat Jan 17, 2004 11:58 am

For support request please use the draft here :-)
http://www.phpbb.com/phpBB/viewtopic.php?t=128123
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

OK

Post by joefish » Sun Jan 18, 2004 4:56 am

URL: http://www.jesuscore.net/community/
Template(s) used: Modified subsilver
Any and all MODs:
- eXtreme Styles
- View Watched Topics
- Statistics hack
- Dates for Humans
Do you use a port of phpBB: No
Version of phpBB: 2.0.6
Version of PHP: 4.3.3
Which database server and version: MySQL 4.0.15-standard
Host: http://www.myhost.co.nz
Did someone install this for you/who: No, I installed it myself
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: Conversion from InvisionBoard 1.1 to phpBB 2.0.6
Have you searched for your problem:v Yes
If so, what terms did you try: rebuild search index
State the nature of your problem: When rebuilding the search index from the admin CP, I get the folowing error:
Could not insert new word matches

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'is Alucard, im a hopeful writer from New Zealand and wuld just

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT hello everyone, my name is Alucard, im a hopeful writer from New Zealand and wuld just like to say hello. hopefully i can post part of my short story on this site. hopefully, word_id, 0 FROM phpbb_search_wordlist WHERE word_text IN ('saying')

Line : 249
File : /home/jfish/public_html/community/includes/functions_search.php


The post that can be seen in the error was posted a while after my conversion from InvisionBoard.

Do you have a test account for us: No

joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

/bump

Post by joefish » Tue Jan 20, 2004 8:33 pm

/bump

joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

/bump

Post by joefish » Tue Jan 27, 2004 9:07 am

/bump

joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

Anyone?

Post by joefish » Wed Jan 28, 2004 3:58 am

Can anyone help?

joefish
Registered User
Posts: 113
Joined: Fri Mar 28, 2003 9:32 pm
Contact:

Solved!

Post by joefish » Thu Jan 29, 2004 10:44 pm

Well, I tried a few things:

I tried deleting the topic, but then it would stop on another one. I tried a couple of the rebuild search tables mods that were available, to replace the built in one, and this one worked:

http://phpbbhacks.com/viewhack.php?id=434

Not sure how different this one does it to the default, and it took a while, but now I'm a happy phpBB user again :)

bigjon
Registered User
Posts: 18
Joined: Sat Nov 15, 2003 4:05 pm
Location: uk - Wigan
Contact:

Post by bigjon » Fri Apr 29, 2005 7:22 pm

Many thanks from here as well - our search has been ckufed for months since a hacker messed in it, now its up and running again !!

http://www.topqualityfreeware.com/phpBB/index.php

skadamo
Registered User
Posts: 10
Joined: Fri Jan 07, 2005 4:17 pm

Post by skadamo » Wed Jun 08, 2005 3:46 am

http://phpbbhacks.com/viewhack.php?id=434

That link rocks!!! my search works again!!!!!!!!!!!

Thanks!!

I had to change a few lines to make it work with PHP-Nuke board.

Changed line 36 through 42 to this...
$phpbb_root_path2 = "./../../../";
$phpbb_root_path = "./../";
require($phpbb_root_path . 'extension.inc');
require('./pagestart.' . $phpEx);

if(( isset($HTTP_POST_VARS['rebuild'])) OR ($HTTP_GET_VARS['start_id'] > 0))
{
include($phpbb_root_path2 . 'includes/functions_search.'.$phpEx);


because the includes directory is in a different place for nuke.

Locked

Return to “2.0.x Support Forum”