Access Errors on Deleting Posts / IP Query

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Apestyler
Registered User
Posts: 7
Joined: Thu May 09, 2002 5:17 pm

Access Errors on Deleting Posts / IP Query

Post by Apestyler » Thu May 09, 2002 5:25 pm

Hi

I have just installed the phpbb forums on my website, everything works fine except when I try to delete a post I get the following error;

"PHP Warning: SQL error: [Microsoft][ODBC Microsoft Access Driver] Circular reference caused by alias 'post_id' in query definition's SELECT list., SQL state S1000 in SQLExecDirect in d:\users\madape\public\phpbb2\db\msaccess.php on line 120 PHP Warning: Cannot add header information - headers already sent in d:\users\madape\public\phpbb2\includes\page_header.php on line 451 PHP Warning: Cannot add header information - headers already sent in d:\users\madape\public\phpbb2\includes\page_header.php on line 452 PHP Warning: Cannot add header information - headers already sent in d:\users\madape\public\phpbb2\includes\page_header.php on line 453 "

It still deletes the post, but the post count remains the same, and I have to resync, also when I do an IP query I get the following error;

"PHP Warning: SQL error: [Microsoft][ODBC Microsoft Access Driver] Too few parameters. Expected 1., SQL state 07001 in SQLExecDirect in d:\users\madape\public\phpbb2\db\msaccess.php on line 120 "

I would be very grateful if anyone can help, MS Access is the only platform available to me on my current host package, I know mySQL is far superior, but really need a solution for Access.

Cheers

Ape

User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal » Fri May 10, 2002 1:10 pm

I'm moving this to support
Proven Offensive Security Expertise. OSCP - GXPN

Apestyler
Registered User
Posts: 7
Joined: Thu May 09, 2002 5:17 pm

Post by Apestyler » Fri May 10, 2002 1:31 pm

Oops - Sorry about posting in the wrong forum

Ape

User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal » Fri May 10, 2002 1:42 pm

No problem. :)

Now, you are using MS Access. Maybe one of the other mods will see this as I am not familiar with Access.
Proven Offensive Security Expertise. OSCP - GXPN

Apestyler
Registered User
Posts: 7
Joined: Thu May 09, 2002 5:17 pm

Post by Apestyler » Mon May 13, 2002 1:37 pm

Sorry to be nagging, but I've tried a few things, and I'm still getting the above errors, I'm kinda getting desperate now, anyone which can help would be greatly appreciated

Ape

Stefan Koopmanschap
Former Team Member
Posts: 7388
Joined: Sun Oct 28, 2001 9:47 am
Location: Woudenberg, Netherlands
Contact:

Post by Stefan Koopmanschap » Mon May 13, 2002 3:18 pm

I'll ask a dev to have a look at this :D

AL
Registered User
Posts: 442
Joined: Tue Jul 03, 2001 10:21 pm
Location: Texas Ya'll

Post by AL » Mon May 13, 2002 3:58 pm

it will be fixed with 2.0.1. which should be out soon :)
"A nerd is someone whose life is focused on computers and technology, but a geek is someone whose life is focused on computers and technology and LIKES it that way."

Apestyler
Registered User
Posts: 7
Joined: Thu May 09, 2002 5:17 pm

Niceone :)

Post by Apestyler » Mon May 13, 2002 9:24 pm

Hey thanks for the information, looking forward to the next version
:D
Cheers

Ape

Locked

Return to “2.0.x Support Forum”