How do I get my users back?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
k2s4l
Registered User
Posts: 174
Joined: Thu Dec 26, 2002 6:23 am

How do I get my users back?

Post by k2s4l » Tue Mar 16, 2004 2:59 am

I deleted my database and I'm now trying to use a backup to restore my users. I let it fully upload, but it never works. I get the install.php page. When I try to reinstall my forum it tells me "phpBB_aeth_access already exists" and config, banlist, categories, user_group, groups, etc. Well, of course they exist, I'm trying to keep all the users, posts, etc I had before. How do I get that back?

computersOC
Registered User
Posts: 2528
Joined: Thu Dec 04, 2003 6:21 am
Location: New York
Contact:

Post by computersOC » Tue Mar 16, 2004 3:23 am

You can either upgrade to the latest version or tell us what happens when you try restoring the db? What message do you get?
http://www.computersOC.com - overclocking, P2P, broadband tweaks, ISP forums, more... Computer Building Help -- Overclocking Guide

Want us to install you a phpBB board or update your current one? Want mods/anti-spam mods installed? Moving to a new host? Check us out here.

k2s4l
Registered User
Posts: 174
Joined: Thu Dec 26, 2002 6:23 am

Post by k2s4l » Tue Mar 16, 2004 4:42 am

Well, the database is restored fine, but when I try to go to my forum ( http://www.skate-forums.com/forum/ ) it goes to the install. Then when I fill out all the boxes I get:

Code: Select all

An error occurred trying to update the database
Table 'phpbb_auth_access' already exists

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Post by AdamR » Tue Mar 16, 2004 4:47 am

Open up config.php, is there any info in there? If so, please post it, editing out your database password for security reasons.
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 » Tue Mar 16, 2004 6:01 am

delete your install and contrib folders


robert

k2s4l
Registered User
Posts: 174
Joined: Thu Dec 26, 2002 6:23 am

Post by k2s4l » Tue Mar 16, 2004 12:58 pm

There nothing in the config.php file.


If I delete the install folder, when I go to the forum index, it redirects to the install... Argh, I'm screwed aren't I?

wuddk
Registered User
Posts: 568
Joined: Sat Sep 27, 2003 3:51 pm
Location: #RPGzone.dk or Denmark :P
Contact:

Post by wuddk » Tue Mar 16, 2004 1:01 pm

You ain't screwed. Delete all your tables in your MYSQL database, and then install the forum. After that, upload the backup, but remember to split up the file in maximum 1 mb!
Please, do not PM me for support | support template | Proud to be able to help inhere

sickmusic
Registered User
Posts: 24
Joined: Fri Oct 25, 2002 1:22 pm
Location: London, UK
Contact:

Post by sickmusic » Tue Mar 16, 2004 1:07 pm

if u have access to a shell prompt then the easiest and quickest solution i found is the following.

edit the config part of your backup.sql file to suit your settings, servernames, database..etc etc.. theyll be inside the INSERT commands..

upload to your server using FTP software

and using a shell client such as putty type the following command:

mysql -u [userid] -p [databasename] < backup.sql

it will then ask for ur password

and will restore your database in seconds.

k2s4l
Registered User
Posts: 174
Joined: Thu Dec 26, 2002 6:23 am

Post by k2s4l » Wed Mar 17, 2004 2:00 am

wuddk wrote: You ain't screwed. Delete all your tables in your MYSQL database, and then install the forum. After that, upload the backup, but remember to split up the file in maximum 1 mb!

I got everything but the last part.

k2s4l
Registered User
Posts: 174
Joined: Thu Dec 26, 2002 6:23 am

Post by k2s4l » Wed Mar 17, 2004 2:56 am

wuddk wrote: You ain't screwed. Delete all your tables in your MYSQL database, and then install the forum. After that, upload the backup, but remember to split up the file in maximum 1 mb!

It worked, thank you.

Locked

Return to “2.0.x Support Forum”