[SOLVED] Upgrading to 2.0.7, 2.0.7a, 2.0.8 query?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
leoz
Registered User
Posts: 35
Joined: Wed Nov 12, 2003 6:35 am
Location: Nashville, TN, USA.
Contact:

[SOLVED] Upgrading to 2.0.7, 2.0.7a, 2.0.8 query?

Post by leoz »

URL: Not necessary.
Template(s) used: ?
Any and all MODs: not necessary.
Do you use a port of phpBB: ?
Version of phpBB: Original 2.0.6? now at 2.0.7a looking at 2.0.8.
Version of PHP: 4
Which database server and version: MySQL.
Host: gisol.com
Did someone install this for you/who: NO.
Is this an upgrade/from what to what: 2.0.6 to 2.0.7a.
Is this a conversion/from what to what: ?
Have you searched for your problem: yes.
If so, what terms did you try: search for update_to_207.php file.

State the nature of your problem: Finally, most of the above is not necessary for this question. I have 2.0.6 running just fine, have updated manually to 2.0.7 and 2.0.7a on my own. I get to this line in the html version of the 2.0.7 file:

"After you have finished this tutorial, you have to upload the update_to_207.php file, execute it and then delete it from your webspace."

Where do I find this file? Is it really necessary? If I find it and use it, will I need to find a update_to_208.php file as well?

If I have made all the changes successfully, what exactly does this file do?

Any information would be greatly appreciated.



Do you have a test account for us: NOT YET.

If so, please have it ready in case a Support Team Member asks for it.
I am having no problems yet so this is not necessary.

Thanks in advance,
Last edited by leoz on Fri Mar 26, 2004 6:19 am, edited 1 time in total.
mikesnow
Registered User
Posts: 108
Joined: Mon Feb 02, 2004 2:40 am

Post by mikesnow »

There are at least three different ways to update.

1. manually
2. patch (the patch program, command line info in the install doc)
3. unzip the archive to your phpbb root, and open a browser and go to http://yoursite.com/<phpbbroot>/install ... to_208.php

You do NOT have to do all three. If you do method 2, the version number isn't updated to 2.0.8. With method 3, it is.
leoz
Registered User
Posts: 35
Joined: Wed Nov 12, 2003 6:35 am
Location: Nashville, TN, USA.
Contact:

[SOLVED] Where is update_to_207.php file?

Post by leoz »

mikesnow wrote: There are at least three different ways to update.

1. manually
2. patch (the patch program, command line info in the install doc)
3. unzip the archive to your phpbb root, and open a browser and go to http://yoursite.com/<phpbbroot>/install ... to_208.php

You do NOT have to do all three. If you do method 2, the version number isn't updated to 2.0.8. With method 3, it is.


Great I chose method 1: manually.

Now do I still have to do the update_to_207.php file or will the update_to_208.php do the exact same thing?

Thanks for taking the time to reply,

*ADDED NOTE: THANKS FOR THE HELP, I went ahead and used the 208 version anyways.
Last edited by leoz on Fri Mar 26, 2004 6:17 am, edited 1 time in total.
User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion »

If you manually update to 2.0.8 (from 2.0.7/2.0.7a), you need not run the update script - you can change the forum version via the query

Code: Select all

UPDATE phpbb_config SET config_value = '.0.8' WHERE config_name = "version";
(which is basically what the script would do from a 2.0.7 to a 2.0.8 )
Same for 2.0.6 to 2.0.7 - you can use that query ( '.0.7' instead). However when updating from previous versions the update script needs to be run.
Locked

Return to “2.0.x Support Forum”