Upgrade from 2.0.6 --> 2.0.8 (First Time)

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
ssq_webmaster
Registered User
Posts: 17
Joined: Tue Oct 07, 2003 9:24 pm

Upgrade from 2.0.6 --> 2.0.8 (First Time)

Post by ssq_webmaster »

Hey gang ... I have not done an upgrade before and wanted to confirm one small point before I proceeded ...

I downloaded the "Changed Files" ZIP for the most recent release ...

In that ZIP there a 4 directories plus ZIP files corresponding to each previous release people could be upgrading from ....

Do I add the contents of those 4 directories to my current PHPBB install (overwriting where necessary) + the contents of the ZIP file for the Version I am upgrading from???

For the record ... I did read the instructions and it seems to only mention grabbing the files from the ZIP file for the version you are upgrading from and doesn't mention the 4 directories ..... but then it mentions to run the "install/update_to_208.php" file....

Thanks for confirming this point for me ... I just don't want to mess it up!!

Cheers!
ssq_webmaster
Registered User
Posts: 17
Joined: Tue Oct 07, 2003 9:24 pm

Post by ssq_webmaster »

One more thing to add to my previous post .....

I don't have any mods or anything ... it's a plain 2.0.6 install ....
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

Yes, that is correct. Upload the /install/, /contrib/, /docs/, and anything in teh /2.0.6to2.0.8 zip file :)
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
evepowr
Registered User
Posts: 85
Joined: Sun Jan 04, 2004 6:54 pm
Contact:

Post by evepowr »

Im doing my first time upgrade to and im confused on the part with the patch file. How exactly do i use the unix application i tend to use cute ftp and im not sure what to do in order to upgrade it properly. Little more detail will be great.
ssq_webmaster
Registered User
Posts: 17
Joined: Tue Oct 07, 2003 9:24 pm

Post by ssq_webmaster »

Hey gang ....

I finally got around to testing an upgrade .. and it didn't do anything ...

I am currently running 2.0.6 ..... and here's what I did ....

1) Downloaded the "Changed Files Only" for 2.0.8a
2) Copied the "Cache" "Contrib" "Docs" and "Install" to my PHPBB directory and overwrote when it asked me to ...
3) Took all the files in the "2.0.6-to-2.0.8.zip" file and copied the to the PHPBB directory .....

I did all that ... and when I go to the Message board ... all I get is a message saying that I need to delete the Contrib and Install directories .... is there a step past #3 above that I am missing????

Would appreciate any help people can give and I will keep digging for answers as well ...
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

Run /install/update_to_208.php, and then delete those two directories.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
ssq_webmaster
Registered User
Posts: 17
Joined: Tue Oct 07, 2003 9:24 pm

Post by ssq_webmaster »

Thanks so much!!!! I went digging in all the directories after I posted my message to see if I could dig up any ideas ....

I found the PHP file you mentioned and I ran it ... it worked like a charm ...

Thanks so much for the quick response.... !
Locked

Return to “2.0.x Support Forum”