Failed sending email - error

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
timbercrawler
Registered User
Posts: 99
Joined: Mon Jul 21, 2003 1:25 am
Location: Seattle
Contact:

Failed sending email - error

Post by timbercrawler »

When I post a reply to a message on my board I get this error:

----------------------------------------------------------------
Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : /hsphere/local/home/*******/timbercrawler.com/bb/phpBB2/includes/emailer.php
-----------------------------------------------------------------

I added the stars for security. What the heck, why is mailer.php being invoked and if it is supposed to be, any idea why it is failing? The site hasn't changed in 4 weeks, all the files are the same as they have been. ideas?
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

It basically means that there is a problem with the email software installed on the server.

Enable SMTP in Admin Panel --> General Admin --> Configuration, use as SMTP server localhost, leave username and password empty and see if it works.

If it still doesn't work, try as SMTP server the SMTP server of your hoster or your ISP as well as the respective username (if necessary) and your SMTP password (only possible, if the SMTP server supports authentication).

If this is a personal server, you'll probably want to install and SMTP server. Please see Google for some links.

On some servers, such as CoolFreePages, no email options are avalaible. In this case, you'll need to modify emailer.php to not send emails and not error out. It just so happens, that I've made such a file http://www.phpbb.com/phpBB/viewtopic.ph ... 253#989253
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
timbercrawler
Registered User
Posts: 99
Joined: Mon Jul 21, 2003 1:25 am
Location: Seattle
Contact:

Post by timbercrawler »

Ok thanks. This runs on a large hosting company server. maybe their mail software just crashed for a bit?
mrguytx
Registered User
Posts: 205
Joined: Sat Feb 14, 2004 3:48 pm

Post by mrguytx »

if those options don't work for you, try this link:

http://www.phpbb.com/phpBB/viewtopic.ph ... ebug+email

look at the last page.
Locked

Return to “2.0.x Support Forum”