Problems restoring DB

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
burnout1
Registered User
Posts: 33
Joined: Mon Apr 19, 2004 2:14 am
Location: North Bay, Ontario, Canada

Problems restoring DB

Post by burnout1 » Mon Apr 19, 2004 3:45 pm

MY db SIZE IS ABOUT 26MB, i use phpmyadmin, the newer version and 1.56 or whatever.

when trying to restore my DB after backing it up
i get an action canceled page for some reason, happens when i try to restore either localhost mysql or on my webserver
as well for both i tried both phpmyadmin.

any ideas?

Poupoune
Former Team Member
Posts: 702
Joined: Sun Apr 18, 2004 4:04 pm
Location: In the stars... where you left me, and where I will wait for you... always...
Contact:

Post by Poupoune » Mon Apr 19, 2004 4:01 pm

Maybe your database is too big. Try to restore it table by table :wink:
Poupoune - http://www.poup.net
My styles : [ La courbe de tes yeux ] - [ Stars are for dying ] - [ Plenitude ] - [ genElectro ]

User avatar
UberSphen
Registered User
Posts: 272
Joined: Mon Feb 16, 2004 5:41 pm
Location: Land of the Beaver
Contact:

Post by UberSphen » Mon Apr 19, 2004 6:28 pm

The max size for uploading is only about 1.5 MB. If you have PhpMyAdmin, you can upload it that way, or you can split it into smaller chunks and upload it that way. This article explains how to use PhpMyAdmin. Good Luck :D
I think, therefore I am, I think... :D

burnout1
Registered User
Posts: 33
Joined: Mon Apr 19, 2004 2:14 am
Location: North Bay, Ontario, Canada

Post by burnout1 » Tue Apr 20, 2004 4:34 pm

ok thanks
that will take a while :(

Anothwer question
would it work if i copied the DB into a php, and make it like the hack install files are?

imagedude
Registered User
Posts: 296
Joined: Wed Sep 25, 2002 10:28 pm
Location: /home/kai
Name: Kai Ponte
Contact:

Post by imagedude » Tue Apr 20, 2004 5:04 pm

I'm getting the same issues.

Just use your command line - it always works. In my case, I did a backup and restore this morning. I just backed up using the PHPBB ACP backup utility then opened a command processor (I am on NT 5.0).
  • I changed to the MySQL directory on my C drive: CD MYSQL

    I then ran the command processor: MYSQL

    I then changed to my database:
    mysql> use mydatabase
    Database changed


    I then ran the script I had downloaded:
    mysql> source c:\projects\mycoolsite\mybackup\mysite.sql
It worked great. No issues with timeouts. No reason to download the different tables.

HTH

burnout1
Registered User
Posts: 33
Joined: Mon Apr 19, 2004 2:14 am
Location: North Bay, Ontario, Canada

Post by burnout1 » Wed Apr 21, 2004 12:25 pm

Sweet i will try it when i get home:)

Locked

Return to “2.0.x Support Forum”