Database Error

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
sidewinder
Registered User
Posts: 55
Joined: Wed Dec 31, 2003 1:20 pm
Location: England
Contact:

Database Error

Post by sidewinder » Sat May 08, 2004 2:44 pm

hey, i have just had a problem with the database for my forums, all of a sudden it just stopped working. its at http://forums.XEclan.co.uk/ . please help.

alegis gensan
Registered User
Posts: 310
Joined: Fri Nov 01, 2002 5:49 pm
Location: Belgium

Post by alegis gensan » Sat May 08, 2004 2:48 pm

always post the error message. An error is there to help you, to say what exactly is wrong

Code: Select all

phpBB : Critical Error 

Could not obtain lastvisit data from user table

DEBUG MODE

SQL Error : 1016 Can't open file: 'phpbb_users.MYI'. (errno: 145)

SELECT * FROM phpbb_users WHERE user_id = -1

Line : 62
File : /usr/local/psa/home/vhosts/xeclan.co.uk/httpdocs/forums/includes/sessions.php 
Seems the lastvisit data is missing from the database, and _users.MYI is weird. Did you install any mods releated to last visit lately?

sidewinder
Registered User
Posts: 55
Joined: Wed Dec 31, 2003 1:20 pm
Location: England
Contact:

Post by sidewinder » Sat May 08, 2004 4:17 pm

havent install a mod for a fair few weeks

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Sat May 08, 2004 4:53 pm

Run following query on your database

Code: Select all

REPAIR TABLE phpbb_users;
You can do things like that for example with phpMyAdmin
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

davidjovan
Registered User
Posts: 26
Joined: Fri Dec 12, 2003 9:39 pm

Post by davidjovan » Tue May 11, 2004 2:02 am

I got this same error... I can't find the REPAIR command u r talking about... help

What is this. A timed failure conspiracy?

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Tue May 11, 2004 2:10 am

davidjovan wrote: What is this. A timed failure conspiracy?
:lol:

As for your problem...You can't find phpMyAdmin? If not, you can always install it yourself; follow ZeroK's link. Their documentation is great.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

davidjovan
Registered User
Posts: 26
Joined: Fri Dec 12, 2003 9:39 pm

Post by davidjovan » Tue May 11, 2004 2:30 am

A_Jelly_Doughnut wrote:
davidjovan wrote:What is this. A timed failure conspiracy?
:lol:

As for your problem...You can't find phpMyAdmin? If not, you can always install it yourself; follow ZeroK's link. Their documentation is great.


Thanks for the help... I found phpMyAdmin installed it, ran it and I was good to gooooo!

Respect!

Locked

Return to “2.0.x Support Forum”