SQL error after updating from 2.0.8a to 2.0.9

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

SQL error after updating from 2.0.8a to 2.0.9

Post by tbartold »

URL: http://forums.palladium-megaverse.com/index.php
Template(s) used: Appalachia Chronicles Classic ClassicLarge comicBook SpacePilot3K subSilver subSilverLarge
Any and all MODs:
Prune polls also 1.0.0
Easy MOD Add-on 1.2.0a
POCLogin for phpBB2 1.0.0
Add Fields for DigiChat MOD
Installation Guide for Visual Confirmation 1.0.0
DigiChat MOD 0.1.5
Super Moderators 2.1.1
Multiple variable logo images 1.0.0
alternate total posts calculation 1.0.0
printer-friendly topic view option mod 1.0.8
Post per page - Topics per page - Hot Threshold 1.0.1
Report post hack 1.0.6
Custom Title MOD 1.0.2
Anti-Spam MOD Posting and Signatures 1.1.2
(Dis)allow signatures and avatars 1.0.2
Faq Manager (vers. English) 0.8.8
phpbbspell 1.06
Prune users 1.4.3
Advanced Banned User Management 1.1.2
EasyMOD 0.0.11a
Do you use a port of phpBB: no
Version of phpBB: 2.0.9
Version of PHP: 4.3.2
Which database server and version: MySQL version 4.0.15-standard
Host: Dr2.net
Did someone install this for you/who:
Is this an upgrade/from what to what: 2.0.8a to 2.0.9
Is this a conversion/from what to what: No
Have you searched for your problem: Yes
If so, what terms did you try: 2.0.9 SQL Error (search results in a totally blank page)
State the nature of your problem: Some users are getting SQL error when trying to view a forum after upgrading from 2.0.8a to 2.0.9. We used the patch update method.
The users report the following:

Could not obtain topic information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 11

SELECT t.*, u.username, u.user_id, u2.username as user2, u2.user_id as id2, p.post_username, p2.post_username AS post_username2, p2.post_time FROM phpbb_topics t, phpbb_users u, phpbb_posts p, phpbb_posts p2, phpbb_users u2 WHERE t.forum_id = 15 AND t.topic_poster = u.user_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id AND t.topic_type <> 2 ORDER BY t.topic_type DESC, t.topic_last_post_id DESC LIMIT 0,

Line : 327
File : /home/pallad/public_html/forums/viewforum.php

Also the file error_log has multiple entries of another error, which has not been reported by any users:
[15-Jul-2004 01:26:09] PHP Warning: Division by zero in /home/pallad/public_html/forums/viewtopic.php on line 224
[15-Jul-2004 01:26:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/pallad/public_html/forums/viewtopic.php:224) in /home/pallad/public_html/forums/includes/page_header.php on line 587
[15-Jul-2004 01:26:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/pallad/public_html/forums/viewtopic.php:224) in /home/pallad/public_html/forums/includes/page_header.php on line 589
[15-Jul-2004 01:26:09] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/pallad/public_html/forums/viewtopic.php:224) in /home/pallad/public_html/forums/includes/page_header.php on line 590

Do you have a test account for us: yes, but not all users are having this problem.
Stefan Koopmanschap
Former Team Member
Posts: 7388
Joined: Sun Oct 28, 2001 9:47 am
Location: Woudenberg, Netherlands
Contact:

Post by Stefan Koopmanschap »

have you looked at this yet?

aside from the above linked thread, there is little else I can do to help you. such a heavily MODded forum is not something we can support here. This problem could be caused by a lot of things.
Locked

Return to “2.0.x Support Forum”