Page 1 of 1

Email addresses being displayed

Posted: Thu Aug 26, 2004 10:08 pm
by allmighty
I run a furom located at www.njfreeforums/phpbb. It is dependent on my users anymonity, I noticed that if you click the "email" link under the users post, it shows you the email address of the poster. This is hurting my page hits and will enventually destry my site. How can I remove that button from the forum posts?

Edited verbatim by moderator - Removed yelling - Techie-Micheal

Posted: Fri Aug 27, 2004 12:00 am
by fumbalah
Yo. please dont shout at us, ITS RUDE. Have you disabled email in the admin panel, and because you are an admin, you see alll email adresses

EMAIL ADDRESSES BEING DISPLAYED

Posted: Fri Aug 27, 2004 12:10 am
by allmighty
lol, sorry, caps was on. yes display email is set to no. if i go into the user admin section and delete their email address from their sign up / profile, which will solve the displayed email problem, but will they still be able to post? i would think that the only effect that whould have is if they lost thier password, they wouldnt be able to get it back.

EMAIL ADDRESSES BEING DISPLAYED

Posted: Fri Aug 27, 2004 12:12 am
by allmighty
oops, i forgot. also, if that works, i will set the user activation to admin, that way i can delete their emaill address when i get home from work, vs them having it displayed for hours untill i get home from work if i do that, will i get an email or something saying there are 10 new users waiting to be activated?

Posted: Fri Aug 27, 2004 12:39 am
by A_Jelly_Doughnut
If you enable "email sending through board" in the admin panel, email addresses will appear as they do here at phpBB.com. (profile.php?mode=sendemail&u=123).

Empting users email addresses would prevent them from getting new passwords, new post and pm notificaions, et cetera. Probably not the best idea :)

Posted: Fri Aug 27, 2004 1:48 am
by geocator
and since you seemed to skip over it. As an admin all email address are visible to you.

EMAIL ADDRESSES BEING DISPLAYED

Posted: Sat Aug 28, 2004 6:47 pm
by allmighty
i know all addresses are displayed to me, and yes, the email through board is disabled. if you look at these 5 replies, u will notice that only fumbala has an email button under his post. thats what i was wondering how that button is sometimes there then other times its not. no big deal anymore though, my users will just have to deal with it, lol. thanks for your help

Posted: Sat Aug 28, 2004 8:20 pm
by Techie-Micheal
Actually, everybody has an email button under their post. ^_^

Besides the yelling, please 'post in a way which is consistent with "normal writing"', thank you.

Posted: Sat Aug 28, 2004 8:38 pm
by Shanana
Honestly, you should just leave it alone. I can understand why you want it changed, but it's too much of a hassle.

Most PHPBB boards I've come across didn't change it & the boards are doing just fine or better.

Posted: Sat Aug 28, 2004 8:41 pm
by Techie-Micheal
Please explain why it is a hassle. All you do is click a button in the admin panel.

Posted: Sun Aug 29, 2004 6:25 am
by AlphaJoe
Techie-Micheal wrote: Actually, everybody has an email button under their post. ^_^

Besides the yelling, please 'post in a way which is consistent with "normal writing"', thank you.


Actually, he is right. Only fumbala has an e-mail link under his post. This link is only visible when the user has said yes to the "Always show my e-mail address" option in their profile. To make that go away, turn off that option. I thought that it always defaulted to No, but I could be wrong.

AlphaJoe

Posted: Sun Aug 29, 2004 1:41 pm
by Techie-Micheal
AlphaJoe wrote:
Techie-Micheal wrote:Actually, everybody has an email button under their post. ^_^

Besides the yelling, please 'post in a way which is consistent with "normal writing"', thank you.


Actually, he is right. Only fumbala has an e-mail link under his post. This link is only visible when the user has said yes to the "Always show my e-mail address" option in their profile. To make that go away, turn off that option. I thought that it always defaulted to No, but I could be wrong.

AlphaJoe
Not from where I am sitting. ;) But anywho. As has been already mentioned, the way to prevent the addresses from being shown is to change it to "allowed to email via board."